summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-04-03 12:25:44 +0000
committerTorsten Veller <tove@gentoo.org>2009-04-03 12:25:44 +0000
commitd06c279b2597701e4836a179d1901ec24d89bce2 (patch)
tree6950de1fa8e15d91b9cc401e486779531720a7c6 /app-text/po4a
parentVersion bump (diff)
downloadgentoo-2-d06c279b2597701e4836a179d1901ec24d89bce2.tar.gz
gentoo-2-d06c279b2597701e4836a179d1901ec24d89bce2.tar.bz2
gentoo-2-d06c279b2597701e4836a179d1901ec24d89bce2.zip
Version bump (#264474)
(Portage version: 2.2_rc28/cvs/Linux i686)
Diffstat (limited to 'app-text/po4a')
-rw-r--r--app-text/po4a/ChangeLog10
-rw-r--r--app-text/po4a/files/0.36-3-debian.patches50
-rw-r--r--app-text/po4a/po4a-0.36.ebuild36
3 files changed, 94 insertions, 2 deletions
diff --git a/app-text/po4a/ChangeLog b/app-text/po4a/ChangeLog
index 0c41d9b51f89..388442a37c04 100644
--- a/app-text/po4a/ChangeLog
+++ b/app-text/po4a/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/po4a
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/ChangeLog,v 1.35 2008/11/19 13:26:08 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/ChangeLog,v 1.36 2009/04/03 12:25:44 tove Exp $
+
+*po4a-0.36 (03 Apr 2009)
+
+ 03 Apr 2009; Torsten Veller <tove@gentoo.org>
+ +files/0.36-3-debian.patches, +po4a-0.36.ebuild:
+ Version bump (#264474)
19 Nov 2008; Torsten Veller <tove@gentoo.org> -po4a-0.21.ebuild,
-po4a-0.25.ebuild, -po4a-0.29.ebuild, -po4a-0.30.ebuild,
diff --git a/app-text/po4a/files/0.36-3-debian.patches b/app-text/po4a/files/0.36-3-debian.patches
new file mode 100644
index 000000000000..9e2274bb6dc3
--- /dev/null
+++ b/app-text/po4a/files/0.36-3-debian.patches
@@ -0,0 +1,50 @@
+Patches from debian's po4a_0.36-3
+
+--- po4a-0.36/lib/Locale/Po4a/LaTeX.pm
++++ po4a-0.36/lib/Locale/Po4a/LaTeX.pm
+@@ -360,6 +360,7 @@
+ }
+ register_generic_environment("tabular,[]{}");
+ register_generic_environment("tabular*,{}{}");
++register_generic_environment("tabularx,{}{}");
+ register_generic_environment("multicols,{}");
+ register_generic_environment("list,{_}{}");
+ register_generic_environment("array,[]{}");
+@@ -375,7 +376,8 @@
+ # & is the cell separator, \\ is the line separator
+ # '\' is escaped twice
+ $env_separators{'array'} =
+- $env_separators{'tabular'} = "(?:&|\\\\\\\\)";
++ $env_separators{'tabular'} =
++ $env_separators{'tabularx'} = "(?:&|\\\\\\\\|\\\\hline)";
+
+ $env_separators{'trivlist'} =
+ $env_separators{'list'} =
+
+--- po4a-0.36/lib/Locale/Po4a/TeX.pm
++++ po4a-0.36/lib/Locale/Po4a/TeX.pm
+@@ -1079,9 +1079,9 @@
+ if ($line =~ m/^\s*((?:\{_?\}|\[_?\])*)\s*$/) {
+ register_generic_environment("$env,$1");
+ }
+- } elsif ($line =~ /^separator\s+(\w+(?:\[#[0-9]+\]))\s+\"(.*)\"\s*$/) {
++ } elsif ($line =~ /^separator\s+(\w+(?:\[#[0-9]+\])?)\s+\"(.*)\"\s*$/) {
+ my $env = $1; # This is not necessarily an environment.
+- # It can also be smth like 'title{#1}'.
++ # It can also be smth like 'title[#1]'.
+ $env_separators{$env} = $2;
+ } elsif ($line =~ /^verbatim\s+environment\s+(\w+)\s+$/) {
+ register_verbatim_environment($1);
+
+--- po4a-0.36/lib/Locale/Po4a/Pod.pm
++++ po4a-0.36/lib/Locale/Po4a/Pod.pm
+@@ -147,7 +147,7 @@
+ sub docheader {
+ my $self=shift;
+ my $encoding = $self->{TT}{file_out_charset};
+- if (defined $encoding) {
++ if (defined $encoding and length $encoding) {
+ $encoding = "\n=encoding $encoding\n";
+ } else {
+ $encoding = "";
+
diff --git a/app-text/po4a/po4a-0.36.ebuild b/app-text/po4a/po4a-0.36.ebuild
new file mode 100644
index 000000000000..9618c4f2fd9f
--- /dev/null
+++ b/app-text/po4a/po4a-0.36.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/po4a/po4a-0.36.ebuild,v 1.1 2009/04/03 12:25:44 tove Exp $
+
+inherit perl-app
+
+DESCRIPTION="Tools for helping translation of documentation"
+HOMEPAGE="http://po4a.alioth.debian.org"
+SRC_URI="mirror://debian/pool/main/p/po4a/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/SGMLSpm
+ >=sys-devel/gettext-0.13
+ app-text/openjade
+ dev-perl/Locale-gettext
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ >=virtual/perl-Module-Build-0.28
+ test? ( app-text/docbook-sgml-dtd
+ app-text/docbook-sgml-utils
+ virtual/tex-base )"
+
+PATCHES=( "${FILESDIR}/0.36-3-debian.patches" )
+SRC_TEST="do"
+
+src_compile() {
+ rm "${S}"/Makefile || die
+ sed -i '/^Makefile$/d' "${S}"/MANIFEST || die
+ perl-app_src_compile
+}