summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-04-03 22:20:28 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-04-03 22:20:28 +0000
commite64ab75705f0396d2242073523821da40e6635b7 (patch)
tree0ee445b9e88e1e9c187d64d26523d8d3a84f25f7 /app-text/pelican
parentAdd patch to respect system keyboard layout. #460796 (diff)
downloadgentoo-2-e64ab75705f0396d2242073523821da40e6635b7.tar.gz
gentoo-2-e64ab75705f0396d2242073523821da40e6635b7.tar.bz2
gentoo-2-e64ab75705f0396d2242073523821da40e6635b7.zip
move pelican to eapi5 and added a missing dep
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/ChangeLog8
-rw-r--r--app-text/pelican/pelican-3.1.1-r1.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/app-text/pelican/ChangeLog b/app-text/pelican/ChangeLog
index 8ab99ac15ce6..c65032549273 100644
--- a/app-text/pelican/ChangeLog
+++ b/app-text/pelican/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/pelican
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.5 2013/01/28 10:06:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.6 2013/04/03 22:20:28 prometheanfire Exp $
+
+*pelican-3.1.1-r1 (03 Apr 2013)
+
+ 03 Apr 2013; Matthew Thode <prometheanfire@gentoo.org>
+ +pelican-3.1.1-r1.ebuild:
+ move pelican to eapi5 and added a missing dep
*pelican-3.1.1 (28 Jan 2013)
diff --git a/app-text/pelican/pelican-3.1.1-r1.ebuild b/app-text/pelican/pelican-3.1.1-r1.ebuild
new file mode 100644
index 000000000000..df171a15544f
--- /dev/null
+++ b/app-text/pelican/pelican-3.1.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/pelican-3.1.1-r1.ebuild,v 1.1 2013/04/03 22:20:28 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text (or markdown) input files."
+HOMEPAGE="http://pelican.notmyidea.org/ http://pypi.python.org/pypi/pelican"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples markdown"
+
+DEPEND="dev-python/feedgenerator[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+DOCS="README.rst"
+
+python_install() {
+ distutils-r1_python_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "failed to install examples"
+ fi
+}
+
+# no tests: tests/content not in tarball for 2.8.1
+# for 3.0, should be based on tox (refer to virtualenvwrapper)