summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-12-10 05:32:17 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-12-10 05:32:17 +0000
commita3f0022d266824ebcfb4f350c7af8f17cfec8848 (patch)
tree4cb40791c34979a835dd6327ec7d0a34607090e8 /app-text/pelican
parentBump (diff)
downloadgentoo-2-a3f0022d266824ebcfb4f350c7af8f17cfec8848.tar.gz
gentoo-2-a3f0022d266824ebcfb4f350c7af8f17cfec8848.tar.bz2
gentoo-2-a3f0022d266824ebcfb4f350c7af8f17cfec8848.zip
Bump
(Portage version: 2.2.0_alpha147/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/ChangeLog7
-rw-r--r--app-text/pelican/pelican-3.0.1.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-text/pelican/ChangeLog b/app-text/pelican/ChangeLog
index c3dbd92cc3cc..01ce96f93792 100644
--- a/app-text/pelican/ChangeLog
+++ b/app-text/pelican/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pelican
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.3 2012/10/29 16:33:04 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/ChangeLog,v 1.4 2012/12/10 05:32:17 patrick Exp $
+
+*pelican-3.0.1 (10 Dec 2012)
+
+ 10 Dec 2012; Patrick Lauer <patrick@gentoo.org> +pelican-3.0.1.ebuild:
+ Bump
29 Oct 2012; Michał Górny <mgorny@gentoo.org> pelican-2.8.1.ebuild,
pelican-3.0.ebuild:
diff --git a/app-text/pelican/pelican-3.0.1.ebuild b/app-text/pelican/pelican-3.0.1.ebuild
new file mode 100644
index 000000000000..aca170217e1b
--- /dev/null
+++ b/app-text/pelican/pelican-3.0.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pelican/pelican-3.0.1.ebuild,v 1.1 2012/12/10 05:32:16 patrick Exp $
+
+EAPI=4
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="A tool to generate a static blog, with restructured text (or markdown) input files."
+HOMEPAGE="http://pelican.notmyidea.org/ http://pypi.python.org/pypi/pelican"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples markdown"
+
+DEPEND="dev-python/feedgenerator
+ dev-python/jinja
+ dev-python/docutils
+ dev-python/pygments
+ dev-python/pytz
+ dev-python/unidecode
+ dev-python/blinker
+ markdown? ( dev-python/markdown )
+ virtual/python-argparse"
+RDEPEND=""
+
+DOCS="README.rst"
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/* || die "failed to install examples"
+ fi
+}
+
+# no tests: tests/content not in tarball for 2.8.1
+# for 3.0, should be based on tox (refer to virtualenvwrapper)