summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-10-22 15:11:40 +0000
committerThomas Kahle <tomka@gentoo.org>2010-10-22 15:11:40 +0000
commit40a6fc935a690ffea594d373498b42971a058553 (patch)
tree23bf9507b84220b262d1b634b7e4418e882eded3 /app-text/pdfsandwich
parentstable x86, bug 331531 (diff)
downloadgentoo-2-40a6fc935a690ffea594d373498b42971a058553.tar.gz
gentoo-2-40a6fc935a690ffea594d373498b42971a058553.tar.bz2
gentoo-2-40a6fc935a690ffea594d373498b42971a058553.zip
new ebuild: app-text/pdfsandwich
(Portage version: 2.1.9.21/cvs/Linux i686)
Diffstat (limited to 'app-text/pdfsandwich')
-rw-r--r--app-text/pdfsandwich/ChangeLog11
-rw-r--r--app-text/pdfsandwich/metadata.xml23
-rw-r--r--app-text/pdfsandwich/pdfsandwich-0.0.2.ebuild29
3 files changed, 63 insertions, 0 deletions
diff --git a/app-text/pdfsandwich/ChangeLog b/app-text/pdfsandwich/ChangeLog
new file mode 100644
index 000000000000..56fd61d758f2
--- /dev/null
+++ b/app-text/pdfsandwich/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-text/pdfsandwich
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdfsandwich/ChangeLog,v 1.1 2010/10/22 15:11:40 tomka Exp $
+
+*pdfsandwich-0.0.2 (22 Oct 2010)
+
+ 22 Oct 2010; Thomas Kahle <tomka@gentoo.org> +pdfsandwich-0.0.2.ebuild,
+ +metadata.xml:
+ New ebuild: app-text/pdfsandwich, fixes bug 321885, original ebuild
+ by Tobias Elze.
+
diff --git a/app-text/pdfsandwich/metadata.xml b/app-text/pdfsandwich/metadata.xml
new file mode 100644
index 000000000000..35ca8c3c458c
--- /dev/null
+++ b/app-text/pdfsandwich/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>tomka@gentoo.org</email>
+</maintainer>
+<herd>no-herd</herd>
+<longdescription>
+pdfsandwich generates "sandwich" OCR pdf files, i.e. pdf files which
+contain only images (no text) will be processed by optical character
+recognition (OCR) and the text will be added to each page invisibly
+"behind" the images.
+
+pdfsandwich is a command line tool which is supposed to be useful to
+OCR scanned books or journals. It is able to recognize the page layout
+even for multicolumn text.
+
+Essentially, pdfsandwich is a wrapper script which calls the following
+binaries: convert, cuneiform, gs, and hocr2pdf. It is known to run on
+Unix systems and has been tested on Linux and MacOS X. It supports
+parallel processing on multiprocessor systems.
+</longdescription>
+</pkgmetadata>
diff --git a/app-text/pdfsandwich/pdfsandwich-0.0.2.ebuild b/app-text/pdfsandwich/pdfsandwich-0.0.2.ebuild
new file mode 100644
index 000000000000..6d7d17ee1e30
--- /dev/null
+++ b/app-text/pdfsandwich/pdfsandwich-0.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pdfsandwich/pdfsandwich-0.0.2.ebuild,v 1.1 2010/10/22 15:11:40 tomka Exp $
+
+EAPI="2"
+
+DESCRIPTION="generator of sandwich OCR pdf files"
+HOMEPAGE="http://pdfsandwich.origo.ethz.ch/wiki/pdfsandwich"
+SRC_URI="http://download.origo.ethz.ch/pdfsandwich/1809/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="<app-text/cuneiform-0.9.0[imagemagick]
+ media-gfx/exact-image
+ app-text/ghostscript-gpl"
+
+DEPEND="sys-apps/gawk
+ >=dev-lang/ocaml-3.08[ocamlopt]"
+
+src_prepare() {
+ sed -i "/^OCAMLOPTFLAGS/s/$/ -ccopt \"\$(CFLAGS) \$(LDFLAGS)\"/" Makefile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}