summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-11-24 21:45:46 +0000
committerMichael Weber <xmw@gentoo.org>2014-11-24 21:45:46 +0000
commit76c6137776688357af214a3f033945223238b849 (patch)
tree48bdd14d01d8829a399f4cf5862466a1808e2239 /app-text/paps/files
parentSupport python 3.4 (diff)
downloadgentoo-2-76c6137776688357af214a3f033945223238b849.tar.gz
gentoo-2-76c6137776688357af214a3f033945223238b849.tar.bz2
gentoo-2-76c6137776688357af214a3f033945223238b849.zip
Revbump to fix as-needed, doxygen and freetype linkage (bug 514584, thanks Hendrik v. Raven).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-text/paps/files')
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch36
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch20
-rw-r--r--app-text/paps/files/paps-0.6.8-fix-freetype-include.patch13
3 files changed, 69 insertions, 0 deletions
diff --git a/app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch b/app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch
new file mode 100644
index 000000000000..ec4ba8b2b180
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-as-needed-build.patch
@@ -0,0 +1,36 @@
+--- paps-0.6.8/configure.in
++++ paps-0.6.8/configure.in
+@@ -18,4 +18,6 @@
+
+ DX_INIT_DOXYGEN(libpaps, doxygen.cfg, doxygen-doc)
+
++PKG_CHECK_MODULES([PANGO], [pangoft2])
++
+ AC_OUTPUT(Makefile src/Makefile)
+--- paps-0.6.8/src/Makefile.am
++++ paps-0.6.8/src/Makefile.am
+@@ -7,21 +7,19 @@
+ bin_PROGRAMS = paps
+ paps_CFLAGS = -Wall
+ paps_SOURCES = paps.c
+-paps_LDADD = $(lib_LIBRARIES) $(all_libraries)
+-paps_LDFLAGS = `pkg-config --libs pangoft2`
++paps_LDADD = $(lib_LIBRARIES) $(all_libraries) $(PANGO_LIBS)
+ paps_DEPENDENCIES = $(lib_LIBRARIES)
+
+ EXTRA_DIST = test_libpaps.c paps.1
+
+ # set the include path found by configure
+-INCLUDES= $(all_includes) `pkg-config --cflags pangoft2`
++INCLUDES= $(all_includes) $(PANGO_CFLAGS)
+
+ # Test program
+ noinst_PROGRAMS = test_libpaps
+
+
+ test_libpaps_SOURCES = test_libpaps.c
+-test_libpaps_LDADD = $(lib_LIBRARIES) $(all_libraries)
+-test_libpaps_LDFLAGS = `pkg-config --libs pangoft2`
++test_libpaps_LDADD = $(lib_LIBRARIES) $(all_libraries) $(PANGO_LIBS)
+ test_libpaps_DEPENDENCIES = $(lib_LIBRARIES)
+
diff --git a/app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch b/app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch
new file mode 100644
index 000000000000..baba74b4b8bb
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-doxygen-acinclude.patch
@@ -0,0 +1,20 @@
+--- paps-0.6.8/acinclude.m4
++++ paps-0.6.8/acinclude.m4
+@@ -78,7 +78,7 @@
+ AC_PATH_TOOL([$1], [$2])
+ if test "$DX_FLAG_[]DX_CURRENT_FEATURE$$1" = 1; then
+ AC_MSG_WARN([$2 not found - will not DX_CURRENT_DESCRIPTION])
+- AC_SUBST([DX_FLAG_[]DX_CURRENT_FEATURE], 0)
++ AC_SUBST([DX_FLAG_]DX_CURRENT_FEATURE, 0)
+ fi
+ ])
+
+@@ -101,7 +101,7 @@
+ # ----------------------------------------------------------
+ # Turn off the DX_CURRENT_FEATURE if the required feature is off.
+ AC_DEFUN([DX_CLEAR_DEPEND], [
+-test "$DX_FLAG_$1" = "$2" || AC_SUBST([DX_FLAG_[]DX_CURRENT_FEATURE], 0)
++test "$DX_FLAG_$1" = "$2" || AC_SUBST([DX_FLAG_]DX_CURRENT_FEATURE, 0)
+ ])
+
+ # DX_FEATURE_ARG(FEATURE, DESCRIPTION,
diff --git a/app-text/paps/files/paps-0.6.8-fix-freetype-include.patch b/app-text/paps/files/paps-0.6.8-fix-freetype-include.patch
new file mode 100644
index 000000000000..30b456e77416
--- /dev/null
+++ b/app-text/paps/files/paps-0.6.8-fix-freetype-include.patch
@@ -0,0 +1,13 @@
+--- paps-0.6.8/src/libpaps.c
++++ paps-0.6.8/src/libpaps.c
+@@ -25,8 +25,8 @@
+
+ #include <pango/pango.h>
+ #include <pango/pangoft2.h>
+-#include <freetype/ftglyph.h>
+-#include <freetype/ftoutln.h>
++#include <ftglyph.h>
++#include <ftoutln.h>
+ #include <errno.h>
+ #include <stdlib.h>
+ #include <stdio.h>