summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-10 17:54:46 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-10 17:54:46 +0000
commitc3eb63014e73fde911abe0716bf43ed07c3199af (patch)
tree9c74dd1452f4a2e522c91a7330514e56e72de8fd /app-text/pandoc
parentMove call to setContext right after the setting of salt wrt #407555 using ups... (diff)
downloadgentoo-2-c3eb63014e73fde911abe0716bf43ed07c3199af.tar.gz
gentoo-2-c3eb63014e73fde911abe0716bf43ed07c3199af.tar.bz2
gentoo-2-c3eb63014e73fde911abe0716bf43ed07c3199af.zip
Version bump (requested by #406835 by jorro).
(Portage version: 2.2.0_alpha90_p1/cvs/Linux x86_64)
Diffstat (limited to 'app-text/pandoc')
-rw-r--r--app-text/pandoc/ChangeLog9
-rw-r--r--app-text/pandoc/pandoc-1.9.1.2.ebuild64
2 files changed, 71 insertions, 2 deletions
diff --git a/app-text/pandoc/ChangeLog b/app-text/pandoc/ChangeLog
index b7b8d2e1cd1b..6dce5bb5d0ae 100644
--- a/app-text/pandoc/ChangeLog
+++ b/app-text/pandoc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/pandoc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.2 2011/05/03 19:35:58 slyfox Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/ChangeLog,v 1.3 2012/03/10 17:54:46 slyfox Exp $
+
+*pandoc-1.9.1.2 (10 Mar 2012)
+
+ 10 Mar 2012; Sergei Trofimovich <slyfox@gentoo.org> +pandoc-1.9.1.2.ebuild:
+ Version bump (requested by #406835 by jorro).
*pandoc-1.8.1.1-r1 (03 May 2011)
diff --git a/app-text/pandoc/pandoc-1.9.1.2.ebuild b/app-text/pandoc/pandoc-1.9.1.2.ebuild
new file mode 100644
index 000000000000..8b09c92edc66
--- /dev/null
+++ b/app-text/pandoc/pandoc-1.9.1.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/pandoc/pandoc-1.9.1.2.ebuild,v 1.1 2012/03/10 17:54:46 slyfox Exp $
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion between markup formats"
+HOMEPAGE="http://johnmacfarlane.net/pandoc"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="=dev-haskell/base64-bytestring-0.1*[profile?]
+ >=dev-haskell/blaze-html-0.4.3.0[profile?] <dev-haskell/blaze-html-0.5[profile?]
+ >=dev-haskell/citeproc-hs-0.3.4[profile?] <dev-haskell/citeproc-hs-0.4[profile?]
+ >=dev-haskell/highlighting-kate-0.5.0.2[profile?] <dev-haskell/highlighting-kate-0.6[profile?]
+ >=dev-haskell/http-4000.0.5[profile?] <dev-haskell/http-4000.3[profile?]
+ >=dev-haskell/json-0.4[profile?] <dev-haskell/json-0.6[profile?]
+ >=dev-haskell/mtl-1.1[profile?] <dev-haskell/mtl-2.1[profile?]
+ >=dev-haskell/network-2[profile?] <dev-haskell/network-2.4[profile?]
+ >=dev-haskell/pandoc-types-1.9.0.2[profile?] <dev-haskell/pandoc-types-1.10[profile?]
+ =dev-haskell/parsec-3.1*[profile?]
+ >=dev-haskell/tagsoup-0.12.5[profile?] <dev-haskell/tagsoup-0.13[profile?]
+ =dev-haskell/temporary-1.1*[profile?]
+ >=dev-haskell/texmath-0.6.0.2[profile?] <dev-haskell/texmath-0.7[profile?]
+ >=dev-haskell/time-1.2[profile?] <dev-haskell/time-1.5[profile?]
+ =dev-haskell/utf8-string-0.3*[profile?]
+ >=dev-haskell/xml-1.3.12[profile?] <dev-haskell/xml-1.4[profile?]
+ >=dev-haskell/zip-archive-0.1.1.7[profile?] <dev-haskell/zip-archive-0.2[profile?]
+ >=dev-haskell/zlib-0.5[profile?] <dev-haskell/zlib-0.6[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/ansi-terminal
+ dev-haskell/diff
+ dev-haskell/hunit
+ dev-haskell/quickcheck:2
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ dev-haskell/test-framework
+ )
+ "
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag test tests)
+}
+
+src_install() {
+ cabal_src_install
+
+ doman "${S}/man/man1/${PN}.1"
+
+ # COPYING is installed by the Cabal eclass
+ dodoc README COPYRIGHT changelog
+}