summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-10-30 11:47:30 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-10-30 11:47:30 +0000
commitd70f3b283013a82069854411d52fe16afa789cfb (patch)
tree887185e9277ffabf52a7d5bb0ec332424195a84c /app-text/notecase
parentversion bump (diff)
downloadgentoo-2-d70f3b283013a82069854411d52fe16afa789cfb.tar.gz
gentoo-2-d70f3b283013a82069854411d52fe16afa789cfb.tar.bz2
gentoo-2-d70f3b283013a82069854411d52fe16afa789cfb.zip
Version bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.25-gentoo-r8 i686)
Diffstat (limited to 'app-text/notecase')
-rw-r--r--app-text/notecase/ChangeLog7
-rw-r--r--app-text/notecase/notecase-1.9.7.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/app-text/notecase/ChangeLog b/app-text/notecase/ChangeLog
index d98150e5edb2..e65733d9da06 100644
--- a/app-text/notecase/ChangeLog
+++ b/app-text/notecase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/notecase
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/ChangeLog,v 1.21 2008/08/26 09:40:32 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/ChangeLog,v 1.22 2008/10/30 11:47:30 armin76 Exp $
+
+*notecase-1.9.7 (30 Oct 2008)
+
+ 30 Oct 2008; Raúl Porcel <armin76@gentoo.org> +notecase-1.9.7.ebuild:
+ Version bump
*notecase-1.9.5 (26 Aug 2008)
diff --git a/app-text/notecase/notecase-1.9.7.ebuild b/app-text/notecase/notecase-1.9.7.ebuild
new file mode 100644
index 000000000000..20da9b0e4839
--- /dev/null
+++ b/app-text/notecase/notecase-1.9.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/notecase/notecase-1.9.7.ebuild,v 1.1 2008/10/30 11:47:30 armin76 Exp $
+
+inherit eutils fdo-mime
+
+DESCRIPTION="Hierarchical note manager written using GTK+ and C++"
+HOMEPAGE="http://notecase.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}_src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome nls"
+
+RDEPEND=">=x11-libs/gtk+-2.6"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+# test doesn't work
+RESTRICT="test"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Respect CFLAGS and don't use --as-needed by default
+ epatch "${FILESDIR}/notecase-1.7.2-CFLAGS.patch"
+
+ if ! use gnome; then
+ # Comment variable in the Makefile if we don't have gnome
+ sed -i -e 's/HAVE_GNOME_VFS=1/#HAVE_GNOME_VFS=1/g' \
+ -e 's/AUTODETECT_GNOME_VFS=1/#AUTODETECT_GNOME_VFS=1/g' \
+ Makefile || die "gnome sed failed"
+ fi
+
+ ! use nls && {
+ sed -i -e 's/notecase$(EXE) poinstall/notecase$(EXE)/g' \
+ Makefile || die "nls sed failed"
+ }
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc readme.txt
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}