summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2004-07-18 13:46:19 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2004-07-18 13:46:19 +0000
commitf028393c3909bc529a6a1c017f114bde9f034c6c (patch)
treea8b0d61c7d0612735a1cdfa2ee64c7a2fa5f0f73 /app-text/new
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-f028393c3909bc529a6a1c017f114bde9f034c6c.tar.gz
gentoo-2-f028393c3909bc529a6a1c017f114bde9f034c6c.tar.bz2
gentoo-2-f028393c3909bc529a6a1c017f114bde9f034c6c.zip
Version bump and gcc3 fix, closing #55382.
Diffstat (limited to 'app-text/new')
-rw-r--r--app-text/new/Manifest2
-rw-r--r--app-text/new/files/digest-new-1.3.21
-rw-r--r--app-text/new/files/new-gcc-3.patch82
-rw-r--r--app-text/new/new-1.3.2.ebuild25
4 files changed, 110 insertions, 0 deletions
diff --git a/app-text/new/Manifest b/app-text/new/Manifest
index 55e5a2302e7f..ca810d524612 100644
--- a/app-text/new/Manifest
+++ b/app-text/new/Manifest
@@ -1,3 +1,5 @@
MD5 48ceddf4c96d3a7394bc314cad311e9c new-1.3.1.ebuild 527
MD5 70edd737ed410c5d656b270d191b73b2 ChangeLog 363
+MD5 857397e6c018da255388b4ab7d16cf75 new-1.3.2.ebuild 664
MD5 4375f4317433979f8eb4f4d791f6bd8e files/digest-new-1.3.1 61
+MD5 3f6e87b37924420a18c55327386b3e6f files/digest-new-1.3.2 61
diff --git a/app-text/new/files/digest-new-1.3.2 b/app-text/new/files/digest-new-1.3.2
new file mode 100644
index 000000000000..451e4184384f
--- /dev/null
+++ b/app-text/new/files/digest-new-1.3.2
@@ -0,0 +1 @@
+MD5 94a3c293b2df8f5a65a4a62b8d03b96b new-1.3.2.tar.gz 233218
diff --git a/app-text/new/files/new-gcc-3.patch b/app-text/new/files/new-gcc-3.patch
new file mode 100644
index 000000000000..a4a240364a11
--- /dev/null
+++ b/app-text/new/files/new-gcc-3.patch
@@ -0,0 +1,82 @@
+--- usage_new.c 2002-07-13 03:01:57.000000000 -0700
++++ usage_new.c.new 2004-06-27 20:28:06.565095345 -0700
+@@ -1,44 +1,35 @@
+-char *usage_new = "
+-
+- _________________________________________________________
+-
+- Table of Contents
+-
+- new [options] filename [template]
+-
+- filename
+- Filename of the file to create
+-
+- -h, --help
+- Print a list of options
+-
+- -f, --force
+- Overwrite any existing file
+-
+- -l, --list
+- List templates available for given filename
+-
+- -m, --mapping path
+- Use tge file at path to provide additional key/value
+- mappings
+-
+- -g, --global
+- Use global templates instead of personal ones
+-
+- -t, --template path
+- Use the file at path as template
+-
+- -s, --set FOO=bar
+- Set the key FOO to the value bar
+-
+- -y, --type type
+- Set the file's type and do not try to extract it from
+- the filename
+-
+- -p, --permissions octal
+- Set the new file's permissions
+-
+- template
+- Name of the template to use within global or local
+- template dir
+-";
++char *usage_new =
++" template-new [options] filename [template]\n"
++" _________________________________________________________________\n"
++" \n"
++" filename\n"
++" Filename of the file to create\n"
++" \n"
++" -h, --help\n"
++" Print a list of options\n"
++" \n"
++" -f, --force\n"
++" Overwrite any existing file\n"
++" \n"
++" -l, --list\n"
++" List templates available for given filename\n"
++" \n"
++" -g, --global\n"
++" Use global templates instead of personal ones\n"
++" \n"
++" -t, --template path\n"
++" Use the file at path as template\n"
++" \n"
++" -s, --set FOO=bar\n"
++" Set the key FOO to the value bar\n"
++" \n"
++" -y, --type type\n"
++" Set the file's type and do not try to extract it from the\n"
++" filename\n"
++" \n"
++" -p, --permissions octal\n"
++" Set the new file's permissions\n"
++" \n"
++" template\n"
++" Name of the template to use within global or local template dir\n"
++;
diff --git a/app-text/new/new-1.3.2.ebuild b/app-text/new/new-1.3.2.ebuild
new file mode 100644
index 000000000000..16dbfa246af0
--- /dev/null
+++ b/app-text/new/new-1.3.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/new/new-1.3.2.ebuild,v 1.1 2004/07/18 13:46:19 aliz Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="template system useful when used with a simple text editor (like vi)"
+HOMEPAGE="http://www.flyn.org/"
+SRC_URI="http://www.flyn.org/projects/new/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}/src
+ epatch ${FILESDIR}/${PN}-gcc-3.patch
+
+ cd ${S} ; gnuconfig_update
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README TODO
+}