summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2013-06-20 09:11:08 +0000
committerMichael Weber <xmw@gentoo.org>2013-06-20 09:11:08 +0000
commit90fa268a5fd02bd85c3f9e2a3f960fe9fa347a35 (patch)
tree7dbed711289666e6309bec0dcb498a18173d78bb /app-text/mupdf
parentInitial commit (bug #371773) (diff)
downloadgentoo-2-90fa268a5fd02bd85c3f9e2a3f960fe9fa347a35.tar.gz
gentoo-2-90fa268a5fd02bd85c3f9e2a3f960fe9fa347a35.tar.bz2
gentoo-2-90fa268a5fd02bd85c3f9e2a3f960fe9fa347a35.zip
Adapt to include file splitting
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'app-text/mupdf')
-rw-r--r--app-text/mupdf/ChangeLog6
-rw-r--r--app-text/mupdf/files/mupdf-9999-install-headers.patch19
-rw-r--r--app-text/mupdf/mupdf-9999.ebuild9
3 files changed, 29 insertions, 5 deletions
diff --git a/app-text/mupdf/ChangeLog b/app-text/mupdf/ChangeLog
index 7197b7b10886..b222e3c2f801 100644
--- a/app-text/mupdf/ChangeLog
+++ b/app-text/mupdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/mupdf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.77 2013/06/15 01:18:55 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/ChangeLog,v 1.78 2013/06/20 09:11:08 xmw Exp $
+
+ 20 Jun 2013; Michael Weber <xmw@gentoo.org>
+ +files/mupdf-9999-install-headers.patch, mupdf-9999.ebuild:
+ Adapt to include file splitting
15 Jun 2013; Michael Weber <xmw@gentoo.org> files/mupdf-9999-pkg-config.patch,
mupdf-9999.ebuild:
diff --git a/app-text/mupdf/files/mupdf-9999-install-headers.patch b/app-text/mupdf/files/mupdf-9999-install-headers.patch
new file mode 100644
index 000000000000..7c91abc9f2f9
--- /dev/null
+++ b/app-text/mupdf/files/mupdf-9999-install-headers.patch
@@ -0,0 +1,19 @@
+based on http://bugs.ghostscript.com/show_bug.cgi?id=694365&list_id=6717
+
+--- mupdf-9999/Makefile
++++ mupdf-9999/Makefile
+@@ -248,9 +248,12 @@
+ mandir ?= $(prefix)/share/man
+
+ install: $(MUPDF_LIB) $(MUVIEW) $(MUDRAW) $(MUTOOL)
+- install -d $(DESTDIR)$(bindir) $(DESTDIR)$(libdir) $(DESTDIR)$(incdir) $(DESTDIR)$(mandir)/man1
++ install -d $(DESTDIR)$(bindir) $(DESTDIR)$(libdir) $(DESTDIR)$(mandir)/man1
++ install -d $(DESTDIR)$(incdir)/mupdf/{fitz,pdf}
+ install $(MUPDF_LIB) $(DESTDIR)$(libdir)
+- install fitz/memento.h fitz/fitz.h pdf/mupdf.h xps/muxps.h cbz/mucbz.h image/muimage.h $(DESTDIR)$(incdir)
++ install include/mupdf/*.h $(DESTDIR)$(incdir)/mupdf
++ install include/mupdf/fitz/*.h $(DESTDIR)$(incdir)/mupdf/fitz
++ install include/mupdf/pdf/*.h $(DESTDIR)$(incdir)/mupdf/pdf
+ install $(MUVIEW) $(MUDRAW) $(MUTOOL) $(DESTDIR)$(bindir)
+ install $(wildcard apps/man/*.1) $(DESTDIR)$(mandir)/man1
+
diff --git a/app-text/mupdf/mupdf-9999.ebuild b/app-text/mupdf/mupdf-9999.ebuild
index ca70f8c0ffb0..78c8004d1d4e 100644
--- a/app-text/mupdf/mupdf-9999.ebuild
+++ b/app-text/mupdf/mupdf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-9999.ebuild,v 1.35 2013/06/15 01:18:55 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mupdf/mupdf-9999.ebuild,v 1.36 2013/06/20 09:11:08 xmw Exp $
EAPI=5
@@ -39,7 +39,8 @@ src_prepare() {
epatch \
"${FILESDIR}"/${P}-buildsystem.patch \
"${FILESDIR}"/${P}-openjpeg2.patch \
- "${FILESDIR}"/${P}-pkg-config.patch
+ "${FILESDIR}"/${P}-pkg-config.patch \
+ "${FILESDIR}"/${P}-install-headers.patch
sed -e "/^libdir=/s:/lib:/$(get_libdir):" \
-e "/^prefix=/s:=.*:=${EROOR}/usr:" \
@@ -109,8 +110,8 @@ src_install() {
use X && dobin "${S}"-static/build/debug/mupdf
fi
- insinto /usr/include
- doins pdf/mupdf-internal.h fitz/fitz-internal.h xps/muxps-internal.h
+ #insinto /usr/include
+ #doins pdf/mupdf-internal.h fitz/fitz-internal.h xps/muxps-internal.h
insinto /usr/$(get_libdir)/pkgconfig
doins debian/mupdf.pc