summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-05-09 09:01:18 +0000
committerJeroen Roovers <jer@gentoo.org>2015-05-09 09:01:18 +0000
commit64fe69d41f3ccfa1956c9e82be91f310345384e7 (patch)
tree7c3d6c9329010007e9b27d716874600317e2cfa5 /app-text/multitail
parentSupport apache 2.4 (#532840) (diff)
downloadgentoo-2-64fe69d41f3ccfa1956c9e82be91f310345384e7.tar.gz
gentoo-2-64fe69d41f3ccfa1956c9e82be91f310345384e7.tar.bz2
gentoo-2-64fe69d41f3ccfa1956c9e82be91f310345384e7.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-text/multitail')
-rw-r--r--app-text/multitail/ChangeLog8
-rw-r--r--app-text/multitail/files/multitail-6.4.1-gentoo.patch31
-rw-r--r--app-text/multitail/multitail-6.4.1.ebuild67
3 files changed, 105 insertions, 1 deletions
diff --git a/app-text/multitail/ChangeLog b/app-text/multitail/ChangeLog
index 07a8c3270ced..a56bdb8c2341 100644
--- a/app-text/multitail/ChangeLog
+++ b/app-text/multitail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/multitail
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/ChangeLog,v 1.126 2015/04/07 14:08:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/ChangeLog,v 1.127 2015/05/09 09:01:18 jer Exp $
+
+*multitail-6.4.1 (09 May 2015)
+
+ 09 May 2015; Jeroen Roovers <jer@gentoo.org> +multitail-6.4.1.ebuild,
+ +files/multitail-6.4.1-gentoo.patch:
+ Version bump.
*multitail-6.3 (10 Feb 2015)
diff --git a/app-text/multitail/files/multitail-6.4.1-gentoo.patch b/app-text/multitail/files/multitail-6.4.1-gentoo.patch
new file mode 100644
index 000000000000..080417b6b302
--- /dev/null
+++ b/app-text/multitail/files/multitail-6.4.1-gentoo.patch
@@ -0,0 +1,31 @@
+--- a/Makefile
++++ b/Makefile
+@@ -8,11 +8,11 @@
+ CC?=gcc
+ DEBUG+=-g -Wall # -D_DEBUG # -pg # -D_DEBUG #-pg -W -pedantic # -pg #-fprofile-arcs
+ ifeq ($(UTF8_SUPPORT),yes)
+-LDFLAGS+=-lpanelw -lncursesw -lutil -lm
+-CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT -D_FORTIFY_SOURCE=2 -O3
++LIBS+=$(shell $(PKG_CONFIG) --libs ncursesw panelw) -lutil -lm
++CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -DUTF8_SUPPORT
+ else
+-LDFLAGS+=-lpanel -lncurses -lutil -lm
+-CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\" -D_FORTIFY_SOURCE=2 -O3
++LIBS+=$(shell $(PKG_CONFIG) --libs ncurses panel) -lutil -lm
++CFLAGS+=-funsigned-char -D`uname` -DVERSION=\"$(VERSION)\" -DCONFIG_FILE=\"$(CONFIG_FILE)\"
+ endif
+
+ OBJS=utils.o mt.o error.o my_pty.o term.o scrollback.o help.o mem.o cv.o selbox.o stripstring.o color.o misc.o ui.o exec.o diff.o config.o cmdline.o globals.o history.o xclip.o
+@@ -20,10 +20,10 @@
+ all: multitail
+
+ multitail: $(OBJS)
+- $(CC) $(OBJS) $(LDFLAGS) -o multitail
++ $(CC) $(CFLAGS) $(OBJS) $(LDFLAGS) -o multitail $(LIBS)
+
+ multitail_ccmalloc: $(OBJS)
+- ccmalloc --no-wrapper $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o ccmultitail
++ ccmalloc --no-wrapper $(CC) $(CFLAGS) $(LDFLAGS) -Wall -W $(OBJS) $(LDFLAGS) -o ccmultitail $(LIBS)
+
+ install: multitail
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
diff --git a/app-text/multitail/multitail-6.4.1.ebuild b/app-text/multitail/multitail-6.4.1.ebuild
new file mode 100644
index 000000000000..b8a5c9220b2a
--- /dev/null
+++ b/app-text/multitail/multitail-6.4.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/multitail-6.4.1.ebuild,v 1.1 2015/05/09 09:01:18 jer Exp $
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tail with multiple windows"
+HOMEPAGE="http://www.vanheusden.com/multitail/"
+SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="debug examples unicode"
+
+RDEPEND="
+ sys-libs/ncurses[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+RESTRICT="test" # bug #492270
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-6.4.1-gentoo.patch
+
+ sed \
+ -e "/^DESTDIR/s:=.*$:=${EROOT}:g" \
+ -i Makefile || die
+
+ sed \
+ -e "s:/usr/bin/xclip:${EPREFIX}/usr/bin/xclip:g" \
+ -i xclip.c ${PN}.conf || die
+
+ tc-export CC PKG_CONFIG
+
+ use debug && append-flags "-D_DEBUG"
+}
+
+src_compile() {
+ emake UTF8_SUPPORT=$(usex unicode)
+}
+
+src_install () {
+ dobin multitail
+
+ insinto /etc
+ doins multitail.conf
+
+ DOCS=( readme.txt thanks.txt )
+ HTML_DOCS=( manual.html )
+ einstalldocs
+
+ doman multitail.1
+
+ if use examples; then
+ docinto examples
+ dodoc conversion-scripts/colors-example.{pl,sh} conversion-scripts/convert-{geoip,simple}.pl
+ fi
+}
+
+pkg_postinst() {
+ optfeature "send a buffer to the X clipboard" x11-misc/xclip
+}