summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-25 09:09:57 +0000
committerJustin Lecher <jlec@gentoo.org>2012-11-25 09:09:57 +0000
commit1195990b3501a6304a5a6efdf1beed71c11ab9fe (patch)
treeb180b56ed742b76fe53b1d408d11a4861660c9e0 /app-text/multitail/multitail-5.2.10.ebuild
parentRestore copyright notice in ChangeLog. (diff)
downloadgentoo-2-1195990b3501a6304a5a6efdf1beed71c11ab9fe.tar.gz
gentoo-2-1195990b3501a6304a5a6efdf1beed71c11ab9fe.tar.bz2
gentoo-2-1195990b3501a6304a5a6efdf1beed71c11ab9fe.zip
app-text/multitail: Version Bump
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'app-text/multitail/multitail-5.2.10.ebuild')
-rw-r--r--app-text/multitail/multitail-5.2.10.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-text/multitail/multitail-5.2.10.ebuild b/app-text/multitail/multitail-5.2.10.ebuild
new file mode 100644
index 000000000000..114d7847ee26
--- /dev/null
+++ b/app-text/multitail/multitail-5.2.10.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/multitail-5.2.10.ebuild,v 1.1 2012/11/25 09:09:57 jlec Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs eutils
+
+DESCRIPTION="Tail with multiple windows"
+HOMEPAGE="http://www.vanheusden.com/multitail/index.html"
+SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="debug doc examples"
+
+DEPEND="sys-libs/ncurses"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/5.2.2-as-needed.patch
+
+ use x86-interix && epatch "${FILESDIR}"/${PN}-5.2.6-interix.patch
+
+ sed -e '/gcc/d' -i Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+ use debug && append-flags "-D_DEBUG"
+ use prefix && sed "s:DESTDIR=/:DESTDIR=${EROOT}:g" -i Makefile
+}
+
+src_install () {
+ dobin multitail
+
+ insinto /etc
+ doins multitail.conf
+
+ dodoc Changes readme.txt thanks.txt
+ doman multitail.1
+
+ if use examples; then
+ docinto examples
+ dodoc colors-example.{pl,sh} convert-{geoip,simple}.pl
+ fi
+
+ if use doc; then
+ dohtml manual.html
+ fi
+}