summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-10-27 17:00:18 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-10-27 17:00:18 +0000
commit32c38523efb34a09fcc604ee391f44b88054179b (patch)
tree03d046ad73f018af8901719e78c2cefe25cd03a3 /app-text/multitail/multitail-3.7.3.ebuild
parentbump (diff)
downloadgentoo-2-32c38523efb34a09fcc604ee391f44b88054179b.tar.gz
gentoo-2-32c38523efb34a09fcc604ee391f44b88054179b.tar.bz2
gentoo-2-32c38523efb34a09fcc604ee391f44b88054179b.zip
Version bump.
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'app-text/multitail/multitail-3.7.3.ebuild')
-rw-r--r--app-text/multitail/multitail-3.7.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/multitail/multitail-3.7.3.ebuild b/app-text/multitail/multitail-3.7.3.ebuild
new file mode 100644
index 000000000000..1f42767055f9
--- /dev/null
+++ b/app-text/multitail/multitail-3.7.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/multitail/multitail-3.7.3.ebuild,v 1.1 2005/10/27 17:00:18 ka0ttic Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="Tail with multiple windows."
+HOMEPAGE="http://www.vanheusden.com/multitail/index.html"
+SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="debug"
+
+DEPEND="virtual/libc
+ sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # tail: '-100lf' option is obsolete; use '-f-n 100'
+ # since this will be removed in the future
+ sed -i 's/-%dlf/-fn%d/' mt.c || die "sed mt.c failed"
+}
+
+src_compile() {
+ append-flags "-D$(uname) -DVERSION=\\\"${PV}\\\""
+ use debug && append-flags "-g -D_DEBUG"
+ make all CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install () {
+ dobin multitail
+ insinto /etc
+ doins multitail.conf
+ dodoc Changes INSTALL license.txt readme.txt
+ dohtml manual.html
+ doman multitail.1
+}