summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Buisse <nattfodd@gentoo.org>2007-02-11 14:49:45 +0000
committerAlexandre Buisse <nattfodd@gentoo.org>2007-02-11 14:49:45 +0000
commit1d9b717e85e0e31e5f32afffae0586ca59a0ac53 (patch)
tree7512a1683fbff2839134ed49eaa331d7a07f3398 /app-text/mftrace
parentUnmask libmtp and amarok (diff)
downloadgentoo-2-1d9b717e85e0e31e5f32afffae0586ca59a0ac53.tar.gz
gentoo-2-1d9b717e85e0e31e5f32afffae0586ca59a0ac53.tar.bz2
gentoo-2-1d9b717e85e0e31e5f32afffae0586ca59a0ac53.zip
Bump to 1.2.9, requested in bug #163428.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'app-text/mftrace')
-rw-r--r--app-text/mftrace/ChangeLog9
-rw-r--r--app-text/mftrace/files/digest-mftrace-1.2.93
-rw-r--r--app-text/mftrace/mftrace-1.2.9.ebuild40
3 files changed, 50 insertions, 2 deletions
diff --git a/app-text/mftrace/ChangeLog b/app-text/mftrace/ChangeLog
index 9ffeea4b5f2c..eaeb57561d8a 100644
--- a/app-text/mftrace/ChangeLog
+++ b/app-text/mftrace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/mftrace
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/ChangeLog,v 1.33 2006/07/08 05:29:54 mr_bones_ Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/ChangeLog,v 1.34 2007/02/11 14:49:45 nattfodd Exp $
+
+*mftrace-1.2.9 (11 Feb 2007)
+
+ 11 Feb 2007; Alexandre Buisse <nattfodd@gentoo.org> +mftrace-1.2.9.ebuild:
+ Bump to 1.2.9, requested in bug #163428.
08 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org>
mftrace-1.1.16.ebuild, mftrace-1.1.17.ebuild:
diff --git a/app-text/mftrace/files/digest-mftrace-1.2.9 b/app-text/mftrace/files/digest-mftrace-1.2.9
new file mode 100644
index 000000000000..8a14f6bd4906
--- /dev/null
+++ b/app-text/mftrace/files/digest-mftrace-1.2.9
@@ -0,0 +1,3 @@
+MD5 29429e911d77b093ad3993bb84ca1327 mftrace-1.2.9.tar.gz 69284
+RMD160 99b9cebc05524dea4a0b3b20fff8dbefde12f08c mftrace-1.2.9.tar.gz 69284
+SHA256 c7db42529064922d02ff75b4d3a47bcfc7483efce27849d362c64cf9bbaf660b mftrace-1.2.9.tar.gz 69284
diff --git a/app-text/mftrace/mftrace-1.2.9.ebuild b/app-text/mftrace/mftrace-1.2.9.ebuild
new file mode 100644
index 000000000000..430b259dab16
--- /dev/null
+++ b/app-text/mftrace/mftrace-1.2.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/mftrace-1.2.9.ebuild,v 1.1 2007/02/11 14:49:45 nattfodd Exp $
+
+IUSE="truetype"
+inherit python multilib
+
+DESCRIPTION="traces TeX fonts to PFA or PFB fonts (formerly pktrace)"
+HOMEPAGE="http://lilypond.org/download/sources/mftrace/"
+SRC_URI="http://lilypond.org/download/sources/mftrace/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+# SLOT 1 was used in pktrace ebuild
+SLOT="1"
+
+DEPEND=">=dev-lang/python-2.2.2"
+
+RDEPEND="${DEPEND}
+ virtual/tetex
+ >=app-text/t1utils-1.25
+ || ( media-gfx/potrace >=media-gfx/autotrace-0.30 )
+ truetype? ( media-gfx/fontforge )"
+
+src_compile() {
+ python_version
+ econf --datadir=/usr/$(get_libdir)/python${PYVER}/site-packages || \
+ die "econf failed"
+ emake CFLAGS="-Wall ${CFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ python_version
+ make \
+ prefix=${D}/usr \
+ datadir=${D}/usr/$(get_libdir)/python${PYVER}/site-packages/mftrace \
+ mandir=${D}/usr/share/man \
+ install || die "make install failed"
+
+ dodoc README.txt ChangeLog
+}