summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-01-21 02:57:45 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-01-21 02:57:45 +0000
commit58e605d8066a64020da235b29d2ec0164bd2687f (patch)
treed14a65397df078169b3e0d39edb08bb1fd7205f9 /app-text/mecab
parentInitial import. (diff)
downloadgentoo-2-58e605d8066a64020da235b29d2ec0164bd2687f.tar.gz
gentoo-2-58e605d8066a64020da235b29d2ec0164bd2687f.tar.bz2
gentoo-2-58e605d8066a64020da235b29d2ec0164bd2687f.zip
Version bumped. Added static-libs USE flag.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'app-text/mecab')
-rw-r--r--app-text/mecab/ChangeLog9
-rw-r--r--app-text/mecab/mecab-0.991.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/app-text/mecab/ChangeLog b/app-text/mecab/ChangeLog
index 8c004b488cb2..f819bb42fcee 100644
--- a/app-text/mecab/ChangeLog
+++ b/app-text/mecab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/mecab
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.62 2010/05/02 11:01:57 aballier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.63 2012/01/21 02:57:45 matsuu Exp $
+
+*mecab-0.991 (21 Jan 2012)
+
+ 21 Jan 2012; MATSUU Takuto <matsuu@gentoo.org> +mecab-0.991.ebuild:
+ Version bumped. Added static-libs USE flag.
02 May 2010; Alexis Ballier <aballier@gentoo.org> mecab-0.98.ebuild,
+files/mecab-0.98-iconv.patch:
diff --git a/app-text/mecab/mecab-0.991.ebuild b/app-text/mecab/mecab-0.991.ebuild
new file mode 100644
index 000000000000..0bc37a0fe334
--- /dev/null
+++ b/app-text/mecab/mecab-0.991.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.991.ebuild,v 1.1 2012/01/21 02:57:45 matsuu Exp $
+
+EAPI="4"
+inherit autotools eutils
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="http://mecab.sourceforge.net/"
+SRC_URI="http://mecab.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="static-libs unicode"
+
+DEPEND="dev-lang/perl
+ virtual/libiconv"
+RDEPEND=""
+PDEPEND="|| (
+ >=app-dicts/mecab-ipadic-2.7.0.20070610[unicode=]
+ app-dicts/mecab-naist-jdic[unicode=]
+ )"
+
+src_prepare() {
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in || die
+ epatch "${FILESDIR}/${PN}-0.98-iconv.patch"
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${ED}" -name '*.la' -delete
+ fi
+
+ dodoc AUTHORS README
+ dohtml -r doc/*
+}