summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-04-21 00:06:37 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-04-21 00:06:37 +0000
commit409fc1975b236e0a45cdd309364db612cd6582be (patch)
tree2f8ba9acf155a785e469747170183ecee50debc3 /app-text/mecab
parentAdd patch for GCC 4.3, bug #213191. (diff)
downloadgentoo-2-409fc1975b236e0a45cdd309364db612cd6582be.tar.gz
gentoo-2-409fc1975b236e0a45cdd309364db612cd6582be.tar.bz2
gentoo-2-409fc1975b236e0a45cdd309364db612cd6582be.zip
Version bumped, bug #217642.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-text/mecab')
-rw-r--r--app-text/mecab/ChangeLog7
-rw-r--r--app-text/mecab/mecab-0.97.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-text/mecab/ChangeLog b/app-text/mecab/ChangeLog
index ce6b2f0f0866..838f7c0ab439 100644
--- a/app-text/mecab/ChangeLog
+++ b/app-text/mecab/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/mecab
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.45 2008/03/22 18:58:35 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/ChangeLog,v 1.46 2008/04/21 00:06:37 matsuu Exp $
+
+*mecab-0.97 (21 Apr 2008)
+
+ 21 Apr 2008; MATSUU Takuto <matsuu@gentoo.org> +mecab-0.97.ebuild:
+ Version bumped, bug #217642.
22 Mar 2008; Santiago M. Mola <coldwind@gentoo.org> mecab-0.95.ebuild:
amd64 stable
diff --git a/app-text/mecab/mecab-0.97.ebuild b/app-text/mecab/mecab-0.97.ebuild
new file mode 100644
index 000000000000..b83dc925c132
--- /dev/null
+++ b/app-text/mecab/mecab-0.97.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.97.ebuild,v 1.1 2008/04/21 00:06:37 matsuu Exp $
+
+IUSE="unicode"
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="http://mecab.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+RESTRICT="test"
+
+DEPEND="dev-lang/perl"
+PDEPEND=">=app-dicts/mecab-ipadic-2.7.0.20070610"
+
+src_compile() {
+
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf ${myconf} || die
+ emake || die
+
+}
+
+src_install() {
+
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README || die
+ dohtml -r doc || die
+
+}