summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-10-28 12:21:27 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-10-28 12:21:27 +0000
commit2464c90fdb72cbba0e919f2bfa62172b9b85e95f (patch)
treee5bc3a95ec76543d2c8db42744b01b746ad4865d /app-text/mecab/mecab-0.80.ebuild
parentarm/hppa/ia64/s390 stable for security (Manifest recommit) (diff)
downloadgentoo-2-2464c90fdb72cbba0e919f2bfa62172b9b85e95f.tar.gz
gentoo-2-2464c90fdb72cbba0e919f2bfa62172b9b85e95f.tar.bz2
gentoo-2-2464c90fdb72cbba0e919f2bfa62172b9b85e95f.zip
Version bumped.
Diffstat (limited to 'app-text/mecab/mecab-0.80.ebuild')
-rw-r--r--app-text/mecab/mecab-0.80.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-text/mecab/mecab-0.80.ebuild b/app-text/mecab/mecab-0.80.ebuild
new file mode 100644
index 000000000000..bbc9914e88cd
--- /dev/null
+++ b/app-text/mecab/mecab-0.80.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mecab/mecab-0.80.ebuild,v 1.1 2004/10/28 12:21:27 matsuu Exp $
+
+# need one of ipadic-2.4.4/2.5.0/2.5.1
+MY_IPADIC="ipadic-2.5.1"
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="http://chasen.org/~taku/software/mecab/"
+SRC_URI="http://chasen.org/~taku/software/mecab/src/${P}.tar.gz
+ http://chasen.aist-nara.ac.jp/stable/ipadic/${MY_IPADIC}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+IUSE="unicode"
+
+DEPEND="virtual/libc
+ dev-lang/perl"
+RDEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}/dic
+ unpack ${MY_IPADIC}.tar.gz
+}
+
+src_compile() {
+ local myconf
+
+ use unicode && myconf="${myconf} --with-charset=utf8"
+
+ econf ${myconf} || die
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}