summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-06-25 02:43:16 +0000
committerMike Frysinger <vapier@gentoo.org>2003-06-25 02:43:16 +0000
commitfad9f180cd3779c7baf01206dea3552d4bc95c3b (patch)
treee7b4a3985c61e487dcd436858dd8a00a06f4d7ca /app-text/manedit
parentold/unmask (diff)
downloadgentoo-2-fad9f180cd3779c7baf01206dea3552d4bc95c3b.tar.gz
gentoo-2-fad9f180cd3779c7baf01206dea3552d4bc95c3b.tar.bz2
gentoo-2-fad9f180cd3779c7baf01206dea3552d4bc95c3b.zip
version bump
Diffstat (limited to 'app-text/manedit')
-rw-r--r--app-text/manedit/ChangeLog7
-rw-r--r--app-text/manedit/Manifest4
-rw-r--r--app-text/manedit/files/digest-manedit-0.5.101
-rw-r--r--app-text/manedit/manedit-0.5.10.ebuild49
4 files changed, 59 insertions, 2 deletions
diff --git a/app-text/manedit/ChangeLog b/app-text/manedit/ChangeLog
index ae65595f2584..6f188c5d92e7 100644
--- a/app-text/manedit/ChangeLog
+++ b/app-text/manedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/manedit
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/manedit/ChangeLog,v 1.9 2003/04/13 20:19:33 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/manedit/ChangeLog,v 1.10 2003/06/25 02:43:13 vapier Exp $
+
+*manedit-0.5.10 (24 Jun 2003)
+
+ 24 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
*manedit-0.5.8 (27 Jan 2003)
diff --git a/app-text/manedit/Manifest b/app-text/manedit/Manifest
index 547ea1ab370c..65ef3a4308a6 100644
--- a/app-text/manedit/Manifest
+++ b/app-text/manedit/Manifest
@@ -1,3 +1,5 @@
+MD5 597965ae2db264334fb5d42025570902 files/digest-manedit-0.5.10 67
MD5 1390d92484758cbae2d6fd4745f62718 files/digest-manedit-0.5.8 66
+MD5 8139dab0fc9c19be9097a707f955edf3 manedit-0.5.10.ebuild 1392
MD5 643281a7582b7c01c6c2e2ea34a2cfb7 manedit-0.5.8.ebuild 1389
-MD5 be5ccab716be361523fe50bfea0f59df ChangeLog 1206
+MD5 31eef941835ef9479368ad6f7a9fbd52 ChangeLog 1306
diff --git a/app-text/manedit/files/digest-manedit-0.5.10 b/app-text/manedit/files/digest-manedit-0.5.10
new file mode 100644
index 000000000000..8728090b3c79
--- /dev/null
+++ b/app-text/manedit/files/digest-manedit-0.5.10
@@ -0,0 +1 @@
+MD5 a0d9ff519221fee53e3c7c8b10ddc7af manedit-0.5.10.tar.bz2 497324
diff --git a/app-text/manedit/manedit-0.5.10.ebuild b/app-text/manedit/manedit-0.5.10.ebuild
new file mode 100644
index 000000000000..f17424869768
--- /dev/null
+++ b/app-text/manedit/manedit-0.5.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/manedit/manedit-0.5.10.ebuild,v 1.1 2003/06/25 02:43:13 vapier Exp $
+
+DESCRIPTION="Man page editor using XML tags"
+SRC_URI="ftp://wolfpack.twu.net/users/wolfpack/${P}.tar.bz2"
+HOMEPAGE="http://wolfpack.twu.net/ManEdit/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ =x11-libs/gtk+-1*
+ sys-libs/zlib
+ sys-apps/bzip2"
+
+src_compile() {
+ # It autodetects x86 processors and adds the -march option itself
+ # but we don't actually want that.
+ env CFLAGS="${CFLAGS}" ./configure Linux \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --datadir=/usr/share \
+ --enable=bzip2 \
+ --enable=zlib \
+ --disable="arch-i486" \
+ --disable="arch-i586" \
+ --disable="arch-i686" \
+ --disable="arch-pentiumpro" || die "Bad Configure"
+ emake || die "Compile Error"
+}
+
+src_install() {
+ # fix strip error (tries to strip a shell script)
+ cp manedit/Makefile.install.UNIX{,.orig}
+ sed -e '/INST.*FLAGS.*-s$/s:-s::' \
+ manedit/Makefile.install.UNIX.orig > manedit/Makefile.install.UNIX
+
+ # set man dir too or FHS is violated (/usr/man)
+ make \
+ PREFIX=${D}/usr \
+ MAN_DIR=${D}/usr/share/man/man1 \
+ ICONS_DIR=${D}/usr/share/pixmaps \
+ install || die "make install failed."
+
+ dodoc AUTHORS LICENSE README
+}