summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-10-07 16:14:06 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-10-07 16:14:06 +0000
commit1be0ebdee7d3ccc562e318faf6659a69b5176c39 (patch)
treed94c4bc12b43e15f27e2435966268a2b514e2552 /app-text/lv
parentFixed dependency. Clean up. (diff)
downloadgentoo-2-1be0ebdee7d3ccc562e318faf6659a69b5176c39.tar.gz
gentoo-2-1be0ebdee7d3ccc562e318faf6659a69b5176c39.tar.bz2
gentoo-2-1be0ebdee7d3ccc562e318faf6659a69b5176c39.zip
Removed strip and clean up, bug #239874.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'app-text/lv')
-rw-r--r--app-text/lv/ChangeLog8
-rw-r--r--app-text/lv/files/lv-4.51-gentoo.patch40
-rw-r--r--app-text/lv/lv-4.51-r1.ebuild39
3 files changed, 86 insertions, 1 deletions
diff --git a/app-text/lv/ChangeLog b/app-text/lv/ChangeLog
index 41f6ed782ae4..acae4bf8f4f9 100644
--- a/app-text/lv/ChangeLog
+++ b/app-text/lv/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/lv
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/lv/ChangeLog,v 1.25 2008/03/21 11:29:02 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/lv/ChangeLog,v 1.26 2008/10/07 16:14:06 matsuu Exp $
+
+*lv-4.51-r1 (07 Oct 2008)
+
+ 07 Oct 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/lv-4.51-gentoo.patch, +lv-4.51-r1.ebuild:
+ Removed strip and clean up, bug #239874.
21 Mar 2008; Christian Faulhammer <opfer@gentoo.org> lv-4.51.ebuild:
PROVIDE for virtual/pager not needed anymore, there is a new-style virtual
diff --git a/app-text/lv/files/lv-4.51-gentoo.patch b/app-text/lv/files/lv-4.51-gentoo.patch
new file mode 100644
index 000000000000..90acab49fd16
--- /dev/null
+++ b/app-text/lv/files/lv-4.51-gentoo.patch
@@ -0,0 +1,40 @@
+diff -Naur lv451.orig/src/Makefile.in lv451/src/Makefile.in
+--- lv451.orig/src/Makefile.in 2004-01-06 16:22:17.000000000 +0900
++++ lv451/src/Makefile.in 2008-10-08 00:20:13.000000000 +0900
+@@ -25,6 +25,7 @@
+ LDFLAGS=@LDFLAGS@
+ INSTALL=@INSTALL@
+ PERL= @PERL@
++DESTDIR=
+
+ OBJS= itable.o ctable.o uty.o istr.o stream.o file.o guess.o decode.o \
+ encode.o escape.o iso2022.o iso8859.o iso2cn.o iso2jp.o iso2kr.o \
+@@ -64,18 +65,19 @@
+ #
+
+ install::
+- $(INSTALL) -s -m 555 lv $(bindir)
+- if test -f $(bindir)/lgrep; then \
+- /bin/rm -f $(bindir)/lgrep; \
++ if test ! -d $(DESTDIR)$(bindir); then \
++ mkdir -p $(DESTDIR)$(bindir); \
+ fi
+- (cd $(bindir); ln lv lgrep)
+- if test ! -d $(lvlibdir); then \
+- mkdir -p $(lvlibdir); \
++ $(INSTALL) -m 555 lv $(DESTDIR)$(bindir)
++ (cd $(DESTDIR)$(bindir); ln -s lv lgrep)
++ if test ! -d $(DESTDIR)$(lvlibdir); then \
++ mkdir -p $(DESTDIR)$(lvlibdir); \
+ fi
+- $(INSTALL) -m 444 $(srcdir)/../lv.hlp $(lvlibdir)
+- if test -d $(mandir) -a -d $(mandir)/man1; then \
+- $(INSTALL) -m 444 $(srcdir)/../lv.1 $(mandir)/man1; \
++ $(INSTALL) -m 444 $(srcdir)/../lv.hlp $(DESTDIR)$(lvlibdir)
++ if test ! -d $(DESTDIR)$(mandir)/man1; then \
++ mkdir -p $(DESTDIR)$(mandir)/man1; \
+ fi
++ $(INSTALL) -m 444 $(srcdir)/../lv.1 $(DESTDIR)$(mandir)/man1; \
+
+ uninstall::
+ for i in $(bindir)/lv $(bindir)/lgrep $(lvlibdir)/lv.hlp $(mandir)/man1/lv.1; do \
diff --git a/app-text/lv/lv-4.51-r1.ebuild b/app-text/lv/lv-4.51-r1.ebuild
new file mode 100644
index 000000000000..a82d375c559a
--- /dev/null
+++ b/app-text/lv/lv-4.51-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/lv/lv-4.51-r1.ebuild,v 1.1 2008/10/07 16:14:06 matsuu Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}${PV//./}"
+DESCRIPTION="Powerful Multilingual File Viewer"
+HOMEPAGE="http://www.ff.iij4u.or.jp/~nrt/lv/"
+SRC_URI="http://www.ff.iij4u.or.jp/~nrt/freeware/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ ECONF_SOURCE=src econf || die
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc README hello.sample
+ dohtml index.html relnote.html hello.sample.gif
+}