summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-01 15:25:14 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-01 15:25:14 +0000
commit9d298ab859232475bd83dc078f8102a3be83b00e (patch)
treeb007a33e47c1cef57fb7dd50700f685a8fc11dc9 /app-text/lout
parentBump to 0.28, fixes #221803 (diff)
downloadgentoo-2-9d298ab859232475bd83dc078f8102a3be83b00e.tar.gz
gentoo-2-9d298ab859232475bd83dc078f8102a3be83b00e.tar.bz2
gentoo-2-9d298ab859232475bd83dc078f8102a3be83b00e.zip
Bump to 3.38, closes #222733
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-text/lout')
-rw-r--r--app-text/lout/ChangeLog9
-rw-r--r--app-text/lout/lout-3.38.ebuild77
2 files changed, 84 insertions, 2 deletions
diff --git a/app-text/lout/ChangeLog b/app-text/lout/ChangeLog
index 2b0c9306c950..00933d8ca297 100644
--- a/app-text/lout/ChangeLog
+++ b/app-text/lout/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/lout
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/lout/ChangeLog,v 1.21 2008/01/22 21:32:11 grobian Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/lout/ChangeLog,v 1.22 2009/03/01 15:25:14 patrick Exp $
+
+*lout-3.38 (01 Mar 2009)
+
+ 01 Mar 2009; Patrick Lauer <patrick@gentoo.org> +lout-3.38.ebuild:
+ Bump to 3.38, closes #222733
22 Jan 2008; Fabian Groffen <grobian@gentoo.org> lout-3.31.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/app-text/lout/lout-3.38.ebuild b/app-text/lout/lout-3.38.ebuild
new file mode 100644
index 000000000000..a773933b0491
--- /dev/null
+++ b/app-text/lout/lout-3.38.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/lout/lout-3.38.ebuild,v 1.1 2009/03/01 15:25:14 patrick Exp $
+
+IUSE="zlib doc"
+
+DESCRIPTION="high-level language for document formatting"
+HOMEPAGE="http://lout.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lout/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ local myconf
+ use zlib && myconf="$myconf PDF_COMPRESSION=1 ZLIB=-lz"
+ emake BINDIR=/usr/bin \
+ LOUTLIBDIR=/usr/share/lout \
+ LOUTDOCDIR=/usr/share/doc/${P} \
+ MANDIR=/usr/share/man/man1 \
+ ${myconf} lout prg2lout || die "emake prg2lout lout failed"
+}
+
+compile_doc() {
+ #
+ # SYNOPSIS: compile_doc file times
+ #
+
+ einfo "${1}:"
+ # yes, it *is* necessary to run this 6 times...
+ for i in $(seq 1 $(expr $2 - 1)) ; do
+ einfo " pass $i"
+ lout all -o ${docdir}/$1 -e /dev/null
+ done
+ # in the last one, let errors be reported
+ einfo " final pass"
+ lout all -o ${docdir}/$1 || die "final pass failed"
+}
+
+src_install() {
+ local bindir libdir docdir mandir
+ bindir=${D}/usr/bin
+ libdir=${D}/usr/share/lout
+ docdir=${D}/usr/share/doc/${P}
+ mandir=${D}/usr/share/man/man1
+ export LOUTLIB=${libdir}
+ export PATH="${bindir}:${PATH}"
+
+ mkdir -p ${bindir} ${docdir} ${mandir}
+
+ make BINDIR=${bindir} \
+ LOUTLIBDIR=${libdir} \
+ LOUTDOCDIR=${docdir} \
+ MANDIR=${mandir} \
+ install installdoc installman || die "make install failed"
+
+ lout -x -s "${D}"/usr/share/lout/include/init || die "lout init failed"
+
+ mv ${docdir}/README{,.docs}
+ dodoc README READMEPDF blurb blurb.short whatsnew
+
+ if use doc ; then
+ einfo "building postscript documentation (may take a while)"
+ cd doc/user
+ compile_doc user.ps 6
+ cd ../design
+ compile_doc design.ps 3
+ cd ../expert
+ compile_doc expert.ps 4
+ cd ../slides
+ compile_doc slides.ps 2
+ fi
+}