summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-02-04 08:03:25 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-02-04 08:03:25 +0000
commit926801f049c9a951f34d44970ae1f281857fe9b2 (patch)
tree18a1d670671a879897823f04a9d121a43978c8de /app-text/lout
parentBump for #451740, clean up ebuild a bit (diff)
downloadgentoo-2-926801f049c9a951f34d44970ae1f281857fe9b2.tar.gz
gentoo-2-926801f049c9a951f34d44970ae1f281857fe9b2.tar.bz2
gentoo-2-926801f049c9a951f34d44970ae1f281857fe9b2.zip
Bump for #451722
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-text/lout')
-rw-r--r--app-text/lout/ChangeLog9
-rw-r--r--app-text/lout/lout-3.39.ebuild86
2 files changed, 93 insertions, 2 deletions
diff --git a/app-text/lout/ChangeLog b/app-text/lout/ChangeLog
index 3944ed115552..76b4ac23aaa7 100644
--- a/app-text/lout/ChangeLog
+++ b/app-text/lout/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/lout
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/lout/ChangeLog,v 1.34 2012/10/08 13:47:37 kensington Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/lout/ChangeLog,v 1.35 2013/02/04 08:03:25 patrick Exp $
+
+*lout-3.39 (04 Feb 2013)
+
+ 04 Feb 2013; Patrick Lauer <patrick@gentoo.org> +lout-3.39.ebuild:
+ Bump for #451722
08 Oct 2012; Michael Palimaka <kensington@gentoo.org> -lout-3.30.ebuild:
Remove old.
diff --git a/app-text/lout/lout-3.39.ebuild b/app-text/lout/lout-3.39.ebuild
new file mode 100644
index 000000000000..f7e8617f1510
--- /dev/null
+++ b/app-text/lout/lout-3.39.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/lout/lout-3.39.ebuild,v 1.1 2013/02/04 08:03:25 patrick Exp $
+
+EAPI=3
+
+inherit eutils toolchain-funcs
+
+IUSE="zlib doc"
+
+DESCRIPTION="high-level language for document formatting"
+HOMEPAGE="http://lout.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lout/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="zlib? ( >=sys-libs/zlib-1.1.4 )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3.38-makefile.patch"
+}
+
+src_compile() {
+ tc-export CC
+ local myconf
+ use zlib && myconf="$myconf PDF_COMPRESSION=1 ZLIB=-lz"
+ emake COPTS="${CFLAGS}" BINDIR="${EPREFIX}"/usr/bin \
+ LOUTLIBDIR="${EPREFIX}"/usr/share/lout \
+ LOUTDOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ MANDIR="${EPREFIX}"/usr/share/man/man1 \
+ ${myconf} lout prg2lout || die "emake prg2lout lout failed"
+}
+
+compile_doc() {
+ #
+ # SYNOPSIS: compile_doc file times
+ #
+
+ einfo "${1}:"
+ # yes, it *is* necessary to run this 6 times...
+ for i in $(seq 1 $(expr $2 - 1)) ; do
+ einfo " pass $i"
+ lout all -o ${docdir}/$1 -e /dev/null
+ done
+ # in the last one, let errors be reported
+ einfo " final pass"
+ lout all -o ${docdir}/$1 || die "final pass failed"
+}
+
+src_install() {
+ local bindir libdir docdir mandir
+ bindir=${ED}usr/bin
+ libdir=${ED}usr/share/lout
+ docdir=${ED}usr/share/doc/${PF}
+ mandir=${ED}usr/share/man/man1
+ export LOUTLIB=${libdir}
+ export PATH="${bindir}:${PATH}"
+
+ mkdir -p ${bindir} ${docdir} ${mandir}
+
+ make BINDIR=${bindir} \
+ LOUTLIBDIR=${libdir} \
+ LOUTDOCDIR=${docdir} \
+ MANDIR=${mandir} \
+ install installdoc installman || die "make install failed"
+
+ lout -x -s "${ED}"usr/share/lout/include/init || die "lout init failed"
+
+ mv ${docdir}/README{,.docs}
+ dodoc README READMEPDF blurb blurb.short whatsnew
+
+ if use doc ; then
+ einfo "building postscript documentation (may take a while)"
+ cd doc/user
+ compile_doc user.ps 6
+ cd ../design
+ compile_doc design.ps 3
+ cd ../expert
+ compile_doc expert.ps 4
+ cd ../slides
+ compile_doc slides.ps 2
+ fi
+}