summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-10-08 13:47:37 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-10-08 13:47:37 +0000
commit720239f0d25b4cb8daece863512840fe6971f85a (patch)
tree9beec3d23b3a08d1137d4e98d20f700aa7c75f7f /app-text/lout
parentadd patch to fix compilation error with uClibc by Joshua B. Kahlenberg wrt bu... (diff)
downloadgentoo-2-720239f0d25b4cb8daece863512840fe6971f85a.tar.gz
gentoo-2-720239f0d25b4cb8daece863512840fe6971f85a.tar.bz2
gentoo-2-720239f0d25b4cb8daece863512840fe6971f85a.zip
Remove old.
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'app-text/lout')
-rw-r--r--app-text/lout/ChangeLog6
-rw-r--r--app-text/lout/lout-3.30.ebuild79
2 files changed, 4 insertions, 81 deletions
diff --git a/app-text/lout/ChangeLog b/app-text/lout/ChangeLog
index d351b527e55e..3944ed115552 100644
--- a/app-text/lout/ChangeLog
+++ b/app-text/lout/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/lout
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/lout/ChangeLog,v 1.33 2012/07/29 16:53:28 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/lout/ChangeLog,v 1.34 2012/10/08 13:47:37 kensington Exp $
+
+ 08 Oct 2012; Michael Palimaka <kensington@gentoo.org> -lout-3.30.ebuild:
+ Remove old.
29 Jul 2012; Raúl Porcel <armin76@gentoo.org> lout-3.30.ebuild,
lout-3.38-r1.ebuild:
@@ -130,4 +133,3 @@
comments should well explained and written in clean English. The details about
writing correct changelogs are explained in the skel.ChangeLog file which you
can find in the root directory of the portage repository.
-
diff --git a/app-text/lout/lout-3.30.ebuild b/app-text/lout/lout-3.30.ebuild
deleted file mode 100644
index 7932a3646fe4..000000000000
--- a/app-text/lout/lout-3.30.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/lout/lout-3.30.ebuild,v 1.10 2012/07/29 16:53:28 armin76 Exp $
-
-inherit toolchain-funcs
-
-IUSE="zlib doc"
-
-DESCRIPTION="high-level language for document formatting"
-HOMEPAGE="http://lout.sourceforge.net/"
-SRC_URI="mirror://sourceforge/lout/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ppc x86"
-
-DEPEND="zlib? ( >=sys-libs/zlib-1.1.4 )"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- local myconf
- use zlib && myconf="$myconf PDF_COMPRESSION=1 ZLIB=/usr/lib/libz.a"
- emake CC=$(tc-getCC) BINDIR=/usr/bin \
- LIBDIR=/usr/share/lout \
- DOCDIR=/usr/share/doc/${P} \
- MANDIR=/usr/share/man/man1 \
- ${myconf} lout prg2lout || die "emake prg2lout lout failed"
-}
-
-compile_doc() {
- #
- # SYNOPSIS: compile_doc file times
- #
-
- einfo "${1}:"
- # yes, it *is* necessary to run this 6 times...
- for i in $(seq 1 $(expr $2 - 1)) ; do
- einfo " pass $i"
- lout all -o ${docdir}/$1 -e /dev/null
- done
- # in the last one, let errors be reported
- einfo " final pass"
- lout all -o ${docdir}/$1 || die "final pass failed"
-}
-
-src_install() {
- local bindir libdir docdir mandir
- bindir=${D}/usr/bin
- libdir=${D}/usr/share/lout
- docdir=${D}/usr/share/doc/${PF}
- mandir=${D}/usr/share/man/man1
- export LOUTLIB=${libdir}
- export PATH="${bindir}:${PATH}"
-
- mkdir -p ${bindir} ${docdir} ${mandir}
-
- emake BINDIR=${bindir} \
- LIBDIR=${libdir} \
- DOCDIR=${docdir} \
- MANDIR=${mandir} \
- install installdoc installman || die "make install failed"
-
- lout -x -s "${D}"/usr/share/lout/include/init || die "lout init failed"
-
- mv ${docdir}/README{,.docs}
- dodoc README READMEPDF blurb blurb.short whatsnew
-
- if use doc ; then
- einfo "building postscript documentation (may take a while)"
- cd doc/user
- compile_doc user.ps 6
- cd ../design
- compile_doc design.ps 3
- cd ../expert
- compile_doc expert.ps 4
- cd ../slides
- compile_doc slides.ps 2
- fi
-}