summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2012-05-10 15:25:13 +0000
committerAgostino Sarubbo <ago@gentoo.org>2012-05-10 15:25:13 +0000
commit7fd6bb0c799767d5a3e4ec99129bfdd818c2976b (patch)
treee572767b6d980971d8464b7f70b666c3f1f72a73 /app-text/lout/lout-3.31.ebuild
parentRemove old (diff)
downloadgentoo-2-7fd6bb0c799767d5a3e4ec99129bfdd818c2976b.tar.gz
gentoo-2-7fd6bb0c799767d5a3e4ec99129bfdd818c2976b.tar.bz2
gentoo-2-7fd6bb0c799767d5a3e4ec99129bfdd818c2976b.zip
Remove old
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-text/lout/lout-3.31.ebuild')
-rw-r--r--app-text/lout/lout-3.31.ebuild79
1 files changed, 0 insertions, 79 deletions
diff --git a/app-text/lout/lout-3.31.ebuild b/app-text/lout/lout-3.31.ebuild
deleted file mode 100644
index 24d58fe78cf3..000000000000
--- a/app-text/lout/lout-3.31.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/lout/lout-3.31.ebuild,v 1.5 2009/11/23 20:02:04 jer Exp $
-
-inherit toolchain-funcs
-
-IUSE="zlib doc"
-
-DESCRIPTION="high-level language for document formatting"
-HOMEPAGE="http://lout.sourceforge.net/"
-SRC_URI="mirror://sourceforge/lout/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-
-DEPEND="zlib? ( >=sys-libs/zlib-1.1.4 )"
-RDEPEND="${DEPEND}"
-
-src_compile() {
- local myconf
- use zlib && myconf="$myconf PDF_COMPRESSION=1 ZLIB=-lz"
- emake CC="$(tc-getCC)" BINDIR=/usr/bin \
- LIBDIR=/usr/share/lout \
- DOCDIR=/usr/share/doc/${P} \
- MANDIR=/usr/share/man/man1 \
- ${myconf} lout prg2lout || die "emake prg2lout lout failed"
-}
-
-compile_doc() {
- #
- # SYNOPSIS: compile_doc file times
- #
-
- einfo "${1}:"
- # yes, it *is* necessary to run this 6 times...
- for i in $(seq 1 $(expr $2 - 1)) ; do
- einfo " pass $i"
- lout all -o ${docdir}/$1 -e /dev/null
- done
- # in the last one, let errors be reported
- einfo " final pass"
- lout all -o ${docdir}/$1 || die "final pass failed"
-}
-
-src_install() {
- local bindir libdir docdir mandir
- bindir=${D}/usr/bin
- libdir=${D}/usr/share/lout
- docdir=${D}/usr/share/doc/${PF}
- mandir=${D}/usr/share/man/man1
- export LOUTLIB=${libdir}
- export PATH="${bindir}:${PATH}"
-
- mkdir -p ${bindir} ${docdir} ${mandir}
-
- emake BINDIR=${bindir} \
- LIBDIR=${libdir} \
- DOCDIR=${docdir} \
- MANDIR=${mandir} \
- install installdoc installman || die "make install failed"
-
- lout -x -s "${D}"/usr/share/lout/include/init || die "lout init failed"
-
- mv ${docdir}/README{,.docs}
- dodoc README READMEPDF blurb blurb.short whatsnew
-
- if use doc ; then
- einfo "building postscript documentation (may take a while)"
- cd doc/user
- compile_doc user.ps 6
- cd ../design
- compile_doc design.ps 3
- cd ../expert
- compile_doc expert.ps 4
- cd ../slides
- compile_doc slides.ps 2
- fi
-}