summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-27 15:54:33 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-27 15:54:33 +0000
commit227af5ecd6568526d6e9f5a31ef045a6822c107b (patch)
treef8b19606c098a4fca1ccea9b0a75214b4baf9e61 /app-text/libodfgen
parentConvert to python-single-r1. (diff)
downloadgentoo-2-227af5ecd6568526d6e9f5a31ef045a6822c107b.tar.gz
gentoo-2-227af5ecd6568526d6e9f5a31ef045a6822c107b.tar.bz2
gentoo-2-227af5ecd6568526d6e9f5a31ef045a6822c107b.zip
Version bump by Andreas Sturmlechner, bug 523570
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 84AD142F)
Diffstat (limited to 'app-text/libodfgen')
-rw-r--r--app-text/libodfgen/ChangeLog8
-rw-r--r--app-text/libodfgen/libodfgen-0.1.2.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/app-text/libodfgen/ChangeLog b/app-text/libodfgen/ChangeLog
index 385b92c5ca85..30669624c0d0 100644
--- a/app-text/libodfgen/ChangeLog
+++ b/app-text/libodfgen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/libodfgen
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/ChangeLog,v 1.14 2014/10/10 20:18:18 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/ChangeLog,v 1.15 2014/12/27 15:54:33 dilfridge Exp $
+
+*libodfgen-0.1.2 (27 Dec 2014)
+
+ 27 Dec 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libodfgen-0.1.2.ebuild:
+ Version bump by Andreas Sturmlechner, bug 523570
10 Oct 2014; Markus Meier <maekke@gentoo.org> libodfgen-0.1.1.ebuild:
add ~arm, bug #520692
diff --git a/app-text/libodfgen/libodfgen-0.1.2.ebuild b/app-text/libodfgen/libodfgen-0.1.2.ebuild
new file mode 100644
index 000000000000..df125e645b9e
--- /dev/null
+++ b/app-text/libodfgen/libodfgen-0.1.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libodfgen/libodfgen-0.1.2.ebuild,v 1.1 2014/12/27 15:54:33 dilfridge Exp $
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Library to generate ODF documents from libwpd and libwpg"
+HOMEPAGE="http://libwpd.sf.net"
+SRC_URI="mirror://sourceforge/libwpd/${P}.tar.xz"
+
+# git://git.code.sf.net/p/libwpd/libodfgen
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-werror \
+ --with-sharedptr=boost \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}