summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-11-15 10:14:42 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-11-15 10:14:42 +0000
commit650250ab04d37ffd719c11e60b4a1365852692b6 (patch)
tree1ed318650bbce7d8eaa6c2cb4b46ead1761ea80b /app-text/libmwaw
parentMask =app-emacs/emacs-common-gentoo-1.3-r4 by ulm's request (diff)
downloadgentoo-2-650250ab04d37ffd719c11e60b4a1365852692b6.tar.gz
gentoo-2-650250ab04d37ffd719c11e60b4a1365852692b6.tar.bz2
gentoo-2-650250ab04d37ffd719c11e60b4a1365852692b6.zip
Add limwaw 0.2.0 which will be required by lo 4.2, but is incompatible with 4.1.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/ChangeLog8
-rw-r--r--app-text/libmwaw/libmwaw-0.2.0.ebuild45
2 files changed, 52 insertions, 1 deletions
diff --git a/app-text/libmwaw/ChangeLog b/app-text/libmwaw/ChangeLog
index de54671adaf9..b503d194010b 100644
--- a/app-text/libmwaw/ChangeLog
+++ b/app-text/libmwaw/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/libmwaw
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/ChangeLog,v 1.8 2013/11/09 17:21:57 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/ChangeLog,v 1.9 2013/11/15 10:14:42 scarabeus Exp $
+
+*libmwaw-0.2.0 (15 Nov 2013)
+
+ 15 Nov 2013; Tomáš Chvátal <scarabeus@gentoo.org> +libmwaw-0.2.0.ebuild:
+ Add limwaw 0.2.0 which will be required by lo 4.2, but is incompatible with
+ 4.1.
09 Nov 2013; Andreas K. Huettel <dilfridge@gentoo.org> libmwaw-0.1.10.ebuild:
Specify exact version dependency of libwpd, bug 490858
diff --git a/app-text/libmwaw/libmwaw-0.2.0.ebuild b/app-text/libmwaw/libmwaw-0.2.0.ebuild
new file mode 100644
index 000000000000..8a8d87f3ed75
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/libmwaw/libmwaw-0.2.0.ebuild,v 1.1 2013/11/15 10:14:41 scarabeus Exp $
+
+EAPI=5
+
+inherit base eutils
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="http://sourceforge.net/p/libmwaw/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.9
+ app-text/libwpg:0.2
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-sharedptr=boost \
+ --enable-zip \
+ --disable-werror \
+ $(use_enable static-libs static) \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}