summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-01-06 00:16:45 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-01-06 00:16:45 +0000
commitc18a933a9a4657ce86e4d78db3ff11f7877863e2 (patch)
treed680d7df8870fead11dbe1f2a7dddc5dd28dca31 /app-text/keepnote
parentadd virtual/python-argparse to RDEPEND (diff)
downloadgentoo-2-c18a933a9a4657ce86e4d78db3ff11f7877863e2.tar.gz
gentoo-2-c18a933a9a4657ce86e4d78db3ff11f7877863e2.tar.bz2
gentoo-2-c18a933a9a4657ce86e4d78db3ff11f7877863e2.zip
revbump: migrate to distutils-r1
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'app-text/keepnote')
-rw-r--r--app-text/keepnote/ChangeLog9
-rw-r--r--app-text/keepnote/keepnote-0.7.9-r2.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/app-text/keepnote/ChangeLog b/app-text/keepnote/ChangeLog
index 9e3c18588f57..2d63fd99ae59 100644
--- a/app-text/keepnote/ChangeLog
+++ b/app-text/keepnote/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/keepnote
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/keepnote/ChangeLog,v 1.3 2012/09/26 12:14:16 hasufell Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/keepnote/ChangeLog,v 1.4 2013/01/06 00:16:45 hasufell Exp $
+
+*keepnote-0.7.9-r2 (06 Jan 2013)
+
+ 06 Jan 2013; Julian Ospald <hasufell@gentoo.org> +keepnote-0.7.9-r2.ebuild:
+ revbump: migrate to distutils-r1
*keepnote-0.7.9-r1 (26 Sep 2012)
diff --git a/app-text/keepnote/keepnote-0.7.9-r2.ebuild b/app-text/keepnote/keepnote-0.7.9-r2.ebuild
new file mode 100644
index 000000000000..615fb193411c
--- /dev/null
+++ b/app-text/keepnote/keepnote-0.7.9-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/keepnote/keepnote-0.7.9-r2.ebuild,v 1.1 2013/01/06 00:16:45 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_6 python2_7 )
+PYTHON_REQ_USE="sqlite,xml"
+
+inherit gnome2-utils distutils-r1
+
+DESCRIPTION="A note taking application"
+HOMEPAGE="http://keepnote.org/"
+SRC_URI="http://keepnote.org/download-test/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/pygobject:2
+ dev-python/pygtk:2
+ x11-misc/xdg-utils
+ virtual/python-argparse"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.7.8-desktopfile.patch )
+DOCS=( CHANGES )
+
+python_test() {
+ distutils-r1_python_test
+ "${PYTHON}" test/testing.py || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ einfo
+ elog "optional dependencies:"
+ elog " app-text/gtkspell:2 (spell checking)"
+ einfo
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}