summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-03-13 21:42:45 +0000
committerJohannes Huber <johu@gentoo.org>2014-03-13 21:42:45 +0000
commitebfc6bf621fbfb822f685134162e2d37f15445b4 (patch)
tree16de91831c78c6929bc4eee24457bec6354f6941 /app-text/kbibtex
parentFix LICENSE, add mirror and bindist restriction, bug 445750. (diff)
downloadgentoo-2-ebfc6bf621fbfb822f685134162e2d37f15445b4.tar.gz
gentoo-2-ebfc6bf621fbfb822f685134162e2d37f15445b4.tar.bz2
gentoo-2-ebfc6bf621fbfb822f685134162e2d37f15445b4.zip
Version bump wrt bug #498932.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'app-text/kbibtex')
-rw-r--r--app-text/kbibtex/ChangeLog10
-rw-r--r--app-text/kbibtex/files/kbibtex-0.5-build-fix.patch11
-rw-r--r--app-text/kbibtex/kbibtex-0.4.1.ebuild4
-rw-r--r--app-text/kbibtex/kbibtex-0.5.ebuild35
4 files changed, 56 insertions, 4 deletions
diff --git a/app-text/kbibtex/ChangeLog b/app-text/kbibtex/ChangeLog
index 4d8504bbeb72..d008a3218f71 100644
--- a/app-text/kbibtex/ChangeLog
+++ b/app-text/kbibtex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/kbibtex
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/ChangeLog,v 1.50 2013/03/17 18:16:30 kensington Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/ChangeLog,v 1.51 2014/03/13 21:42:45 johu Exp $
+
+*kbibtex-0.5 (13 Mar 2014)
+
+ 13 Mar 2014; Johannes Huber <johu@gentoo.org>
+ +files/kbibtex-0.5-build-fix.patch, +kbibtex-0.5.ebuild, kbibtex-0.4.1.ebuild:
+ Version bump wrt bug #498932.
17 Mar 2013; Michael Palimaka <kensington@gentoo.org> kbibtex-0.4.1.ebuild:
Drop poppler subslot since it links only to libpoppler-qt4.
diff --git a/app-text/kbibtex/files/kbibtex-0.5-build-fix.patch b/app-text/kbibtex/files/kbibtex-0.5-build-fix.patch
new file mode 100644
index 000000000000..07253354d3ae
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-0.5-build-fix.patch
@@ -0,0 +1,11 @@
+diff -urN kbibtex-0.5.old/src/program/docklets/referencepreview.h kbibtex-0.5/src/program/docklets/referencepreview.h
+--- kbibtex-0.5.old/src/program/docklets/referencepreview.h 2013-12-29 20:06:23.000000000 +0100
++++ kbibtex-0.5/src/program/docklets/referencepreview.h 2014-03-13 22:31:38.456418630 +0100
+@@ -23,6 +23,7 @@
+
+ #include <QWidget>
+ #include <QUrl>
++#include <KUrl>
+
+ class Element;
+ class File;
diff --git a/app-text/kbibtex/kbibtex-0.4.1.ebuild b/app-text/kbibtex/kbibtex-0.4.1.ebuild
index e4adc9782a00..a978b36e100e 100644
--- a/app-text/kbibtex/kbibtex-0.4.1.ebuild
+++ b/app-text/kbibtex/kbibtex-0.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/kbibtex-0.4.1.ebuild,v 1.5 2013/03/17 18:16:30 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/kbibtex-0.4.1.ebuild,v 1.6 2014/03/13 21:42:45 johu Exp $
EAPI=5
diff --git a/app-text/kbibtex/kbibtex-0.5.ebuild b/app-text/kbibtex/kbibtex-0.5.ebuild
new file mode 100644
index 000000000000..64a7267f8cbe
--- /dev/null
+++ b/app-text/kbibtex/kbibtex-0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/kbibtex-0.5.ebuild,v 1.1 2014/03/13 21:42:45 johu Exp $
+
+EAPI=5
+
+inherit versionator kde4-base
+
+DESCRIPTION="BibTeX editor for KDE to edit bibliographies used with LaTeX"
+HOMEPAGE="http://home.gna.org/kbibtex/"
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="http://download.gna.org/${PN}/$(get_version_component_range 1-2)/${P/_/-}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+else
+ ESVN_REPO_URI="svn://svn.gna.org/svn/${PN}/trunk"
+ ESVN_PROJECT="${PN}"
+ KEYWORDS=""
+fi
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ app-text/poppler[qt4]
+ dev-libs/libxml2
+ dev-libs/libxslt
+ virtual/tex-base
+"
+RDEPEND="${DEPEND}
+ dev-tex/bibtex2html"
+
+PATCHES=( "${FILESDIR}/${P}-build-fix.patch" )
+
+S=${WORKDIR}/${P/_/-}