summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2007-03-15 08:53:41 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2007-03-15 08:53:41 +0000
commit2528c54b38ccf203c2f682b2e4885030a07ba426 (patch)
treeeb955cd78292251e009949e4ef506942c179d561 /app-text/kbibtex
parentStable on x86 (#170417) (diff)
downloadgentoo-2-2528c54b38ccf203c2f682b2e4885030a07ba426.tar.gz
gentoo-2-2528c54b38ccf203c2f682b2e4885030a07ba426.tar.bz2
gentoo-2-2528c54b38ccf203c2f682b2e4885030a07ba426.zip
Patched to fix compilation issue, thanks to Andreas Ntaflos <daff@dword.org> for the patch. Closes bug 171004. Also cleaned out old version.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-text/kbibtex')
-rw-r--r--app-text/kbibtex/ChangeLog10
-rw-r--r--app-text/kbibtex/files/digest-kbibtex-0.1.53
-rw-r--r--app-text/kbibtex/files/kbibtex-0.1.5-compile-fix.patch13
-rw-r--r--app-text/kbibtex/kbibtex-0.1.5-r1.ebuild11
-rw-r--r--app-text/kbibtex/kbibtex-0.1.5.ebuild22
5 files changed, 25 insertions, 34 deletions
diff --git a/app-text/kbibtex/ChangeLog b/app-text/kbibtex/ChangeLog
index e65ce4e81adc..631bf5359f7a 100644
--- a/app-text/kbibtex/ChangeLog
+++ b/app-text/kbibtex/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/kbibtex
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/ChangeLog,v 1.16 2006/11/14 17:54:12 caleb Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/ChangeLog,v 1.17 2007/03/15 08:53:41 cryos Exp $
+
+ 15 Mar 2007; Marcus D. Hanwell <cryos@gentoo.org>
+ +files/kbibtex-0.1.5-compile-fix.patch, -kbibtex-0.1.5.ebuild,
+ kbibtex-0.1.5-r1.ebuild:
+ Patched to fix compilation issue, thanks to Andreas Ntaflos <daff@dword.org>
+ for the patch. Closes bug 171004. Also cleaned out old version.
*kbibtex-0.1.5-r1 (14 Nov 2006)
diff --git a/app-text/kbibtex/files/digest-kbibtex-0.1.5 b/app-text/kbibtex/files/digest-kbibtex-0.1.5
deleted file mode 100644
index c1bbfb4304e4..000000000000
--- a/app-text/kbibtex/files/digest-kbibtex-0.1.5
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 83a8c1cade06837431b6ebe79d13ef7b kbibtex-0.1.5.tar.bz2 556109
-RMD160 7a7c6ce9ff4b392104e0b35eb888eaa7e7a20383 kbibtex-0.1.5.tar.bz2 556109
-SHA256 588cbd5055c0baea950263c8d768c13c69ef72c54543137dea4d88fb7e4f8f13 kbibtex-0.1.5.tar.bz2 556109
diff --git a/app-text/kbibtex/files/kbibtex-0.1.5-compile-fix.patch b/app-text/kbibtex/files/kbibtex-0.1.5-compile-fix.patch
new file mode 100644
index 000000000000..9f961e083227
--- /dev/null
+++ b/app-text/kbibtex/files/kbibtex-0.1.5-compile-fix.patch
@@ -0,0 +1,13 @@
+# Patch from Andreas Ntaflos <daff@dword.org> to fix compilation issue
+# 15 Mar 2007 Marcus D. Hanwell <cryos@gentoo.org> from bug 171004.
+--- src/fileimporter.h 2007-03-15 05:55:41.000000000 +0100
++++ src/fileimporter.h.new 2007-03-15 05:56:45.000000000 +0100
+@@ -39,7 +39,7 @@
+ ~FileImporter();
+
+ File* load ( const QString& text );
+- virtual File* load( QIODevice *iodevice ) = NULL;
++ virtual File* load( QIODevice *iodevice ) = 0;
+
+ static bool guessCanDecode( const QString & ) { return FALSE; };
+
diff --git a/app-text/kbibtex/kbibtex-0.1.5-r1.ebuild b/app-text/kbibtex/kbibtex-0.1.5-r1.ebuild
index 243052f147ad..c1cb6fab5c77 100644
--- a/app-text/kbibtex/kbibtex-0.1.5-r1.ebuild
+++ b/app-text/kbibtex/kbibtex-0.1.5-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/kbibtex-0.1.5-r1.ebuild,v 1.1 2006/11/14 17:54:12 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/kbibtex-0.1.5-r1.ebuild,v 1.2 2007/03/15 08:53:41 cryos Exp $
inherit kde eutils
@@ -21,8 +21,5 @@ RDEPEND="${DEPEND}
need-kde 3.3
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/kbibtex-0.1.5-viewdocument.patch
-}
+PATCHES="${FILESDIR}/kbibtex-0.1.5-viewdocument.patch
+ ${FILESDIR}/kbibtex-0.1.5-compile-fix.patch"
diff --git a/app-text/kbibtex/kbibtex-0.1.5.ebuild b/app-text/kbibtex/kbibtex-0.1.5.ebuild
deleted file mode 100644
index 7abf8e8094b7..000000000000
--- a/app-text/kbibtex/kbibtex-0.1.5.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/kbibtex/kbibtex-0.1.5.ebuild,v 1.1 2006/10/07 01:54:38 cryos Exp $
-
-inherit kde eutils
-
-DESCRIPTION="BibTeX editor for KDE"
-HOMEPAGE="http://www.unix-ag.uni-kl.de/~fischer/kbibtex/"
-SRC_URI="http://www.unix-ag.uni-kl.de/~fischer/kbibtex/download/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=dev-libs/libxml2-2.6.22
- >=dev-libs/libxslt-1.1.15"
-RDEPEND="${DEPEND}
- virtual/tetex
- >=dev-tex/bibtex2html-1.70"
-
-need-kde 3.3