summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-06-03 20:00:04 +0000
committerPacho Ramos <pacho@gentoo.org>2013-06-03 20:00:04 +0000
commit8bba13f6ded84ce6986b29a8805df327212fb09a (patch)
tree04a0957ba62d633eb8a85796ee159f62a74ee793 /app-text/iso-codes
parentwww-client/httrack: Remove cruft (diff)
downloadgentoo-2-8bba13f6ded84ce6986b29a8805df327212fb09a.tar.gz
gentoo-2-8bba13f6ded84ce6986b29a8805df327212fb09a.tar.bz2
gentoo-2-8bba13f6ded84ce6986b29a8805df327212fb09a.zip
Version bump, drop old (#471954 by Ivan Atienza)
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'app-text/iso-codes')
-rw-r--r--app-text/iso-codes/ChangeLog8
-rw-r--r--app-text/iso-codes/iso-codes-3.37.ebuild46
-rw-r--r--app-text/iso-codes/iso-codes-3.42.ebuild48
3 files changed, 55 insertions, 47 deletions
diff --git a/app-text/iso-codes/ChangeLog b/app-text/iso-codes/ChangeLog
index 6a5e6a57d2cf..26e59796a3d2 100644
--- a/app-text/iso-codes/ChangeLog
+++ b/app-text/iso-codes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/iso-codes
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.144 2013/05/10 22:14:20 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/ChangeLog,v 1.145 2013/06/03 20:00:04 pacho Exp $
+
+*iso-codes-3.42 (03 Jun 2013)
+
+ 03 Jun 2013; Pacho Ramos <pacho@gentoo.org> +iso-codes-3.42.ebuild,
+ -iso-codes-3.37.ebuild:
+ Version bump, drop old (#471954 by Ivan Atienza)
10 May 2013; Gilles Dartiguelongue <eva@gentoo.org> iso-codes-3.40.ebuild:
Fix linguas stripping logic, bug #463958.
diff --git a/app-text/iso-codes/iso-codes-3.37.ebuild b/app-text/iso-codes/iso-codes-3.37.ebuild
deleted file mode 100644
index 0fb9fccd1a95..000000000000
--- a/app-text/iso-codes/iso-codes-3.37.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.37.ebuild,v 1.10 2012/10/28 15:23:48 armin76 Exp $
-
-EAPI="4"
-
-inherit eutils
-
-DESCRIPTION="Provides the list of country and language names"
-HOMEPAGE="http://alioth.debian.org/projects/pkg-isocodes/"
-SRC_URI="http://pkg-isocodes.alioth.debian.org/downloads/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-IUSE=""
-
-RDEPEND=""
-DEPEND="sys-devel/gettext"
-
-# This ebuild does not install any binaries
-RESTRICT="binchecks strip"
-
-src_prepare() {
- local linguas_bak=${LINGUAS}
- local mylinguas=""
-
- for norm in iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3; do
- einfo "Preparing ${norm}"
-
- mylinguas=""
- LINGUAS=${linguas_bak}
- strip-linguas -i "${S}/${norm}"
-
- for loc in ${LINGUAS}; do
- mylinguas="${mylinguas} ${loc}.po"
- done
-
- if [ -n "${mylinguas}" ]; then
- sed -e "s:pofiles =.*:pofiles = ${mylinguas}:" \
- -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo}:" \
- -i "${S}/${norm}/Makefile.am" "${S}/${norm}/Makefile.in" \
- || die "sed in ${norm} folder failed"
- fi
- done
-}
diff --git a/app-text/iso-codes/iso-codes-3.42.ebuild b/app-text/iso-codes/iso-codes-3.42.ebuild
new file mode 100644
index 000000000000..cf096540424d
--- /dev/null
+++ b/app-text/iso-codes/iso-codes-3.42.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/iso-codes/iso-codes-3.42.ebuild,v 1.1 2013/06/03 20:00:04 pacho Exp $
+
+EAPI="5"
+inherit eutils
+
+DESCRIPTION="ISO language, territory, currency, script codes and their translations"
+HOMEPAGE="http://pkg-isocodes.alioth.debian.org/"
+SRC_URI="http://pkg-isocodes.alioth.debian.org/downloads/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ app-arch/xz-utils
+ sys-devel/gettext
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ local linguas_bak=${LINGUAS}
+ local mylinguas=""
+
+ [[ -z ${LINGUAS} ]] && return
+
+ for norm in iso_15924 iso_3166 iso_3166_2 iso_4217 iso_639 iso_639_3; do
+ einfo "Preparing ${norm}"
+
+ mylinguas=""
+ LINGUAS=${linguas_bak}
+ strip-linguas -i "${S}/${norm}"
+
+ for loc in ${LINGUAS}; do
+ mylinguas="${mylinguas} ${loc}.po"
+ done
+
+ sed -e "s:pofiles =.*:pofiles = ${mylinguas} ${NULL}:" \
+ -e "s:mofiles =.*:mofiles = ${mylinguas//.po/.mo} ${NULL}:" \
+ -i "${S}/${norm}/Makefile.am" "${S}/${norm}/Makefile.in" \
+ || die "sed in ${norm} folder failed"
+ done
+}