summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-03-22 16:41:43 +0000
committerMike Gilbert <floppym@gentoo.org>2012-03-22 16:41:43 +0000
commitd16a229b46ba29dada367be85fdde265ef33614d (patch)
tree6f05fcc430aae77dea9ff532d0d22739dff14c74 /app-text/html2text
parentVersion bump by Michael (kensington) <gentoo@scribeofthenile.com> wrt bug #40... (diff)
downloadgentoo-2-d16a229b46ba29dada367be85fdde265ef33614d.tar.gz
gentoo-2-d16a229b46ba29dada367be85fdde265ef33614d.tar.bz2
gentoo-2-d16a229b46ba29dada367be85fdde265ef33614d.zip
Point SRC_URI at new location. Adjust HOMEPAGE. EAPI=4. Fix bug 144497.
(Portage version: 2.2.0_alpha93/cvs/Linux x86_64)
Diffstat (limited to 'app-text/html2text')
-rw-r--r--app-text/html2text/ChangeLog11
-rw-r--r--app-text/html2text/files/html2text-1.3.2a-compiler.patch13
-rw-r--r--app-text/html2text/files/html2text-1.3.2a-urlistream-get.patch11
-rw-r--r--app-text/html2text/html2text-1.3.2a.ebuild39
4 files changed, 72 insertions, 2 deletions
diff --git a/app-text/html2text/ChangeLog b/app-text/html2text/ChangeLog
index 35cdc544883b..9a27e4f79654 100644
--- a/app-text/html2text/ChangeLog
+++ b/app-text/html2text/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/html2text
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/html2text/ChangeLog,v 1.36 2010/01/02 11:22:49 fauli Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/html2text/ChangeLog,v 1.37 2012/03/22 16:41:43 floppym Exp $
+
+*html2text-1.3.2a (22 Mar 2012)
+
+ 22 Mar 2012; Mike Gilbert <floppym@gentoo.org>
+ +files/html2text-1.3.2a-compiler.patch,
+ +files/html2text-1.3.2a-urlistream-get.patch, +html2text-1.3.2a.ebuild:
+ Point SRC_URI at new location. Adjust HOMEPAGE. EAPI=4. Fix bug 144497.
02 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
html2text-1.3.2-r1.ebuild:
diff --git a/app-text/html2text/files/html2text-1.3.2a-compiler.patch b/app-text/html2text/files/html2text-1.3.2a-compiler.patch
new file mode 100644
index 000000000000..19a1341209d4
--- /dev/null
+++ b/app-text/html2text/files/html2text-1.3.2a-compiler.patch
@@ -0,0 +1,13 @@
+--- a/configure
++++ b/configure
+@@ -38,8 +38,8 @@
+ return 0;
+ }
+ EOF
+-CXX=unknown;
+-for i in "CC" "g++" "cc" "$CC"; do
++CXX=${CXX-unknown}
++for i in "$CXX" "CC" "g++" "cc"; do
+ if $i -c $tmp_file.C 2>/dev/null; then
+ CXX="$i";
+ break;
diff --git a/app-text/html2text/files/html2text-1.3.2a-urlistream-get.patch b/app-text/html2text/files/html2text-1.3.2a-urlistream-get.patch
new file mode 100644
index 000000000000..949d8958a449
--- /dev/null
+++ b/app-text/html2text/files/html2text-1.3.2a-urlistream-get.patch
@@ -0,0 +1,11 @@
+--- a/urlistream.C
++++ b/urlistream.C
+@@ -362,7 +362,7 @@
+ int
+ urlistream::get()
+ {
+- char ch;
++ unsigned char ch;
+ int ret = ::read(fd_, &ch, 1);
+ return (ret > 0 ? ch : -1);
+ }
diff --git a/app-text/html2text/html2text-1.3.2a.ebuild b/app-text/html2text/html2text-1.3.2a.ebuild
new file mode 100644
index 000000000000..ac8dcba605cd
--- /dev/null
+++ b/app-text/html2text/html2text-1.3.2a.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/html2text/html2text-1.3.2a.ebuild,v 1.1 2012/03/22 16:41:43 floppym Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A HTML to text converter"
+HOMEPAGE="http://www.mbayer.de/html2text/"
+SRC_URI="http://www.mbayer.de/html2text/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-compiler.patch
+ epatch "${FILESDIR}"/${P}-urlistream-get.patch
+}
+
+src_configure() {
+ tc-export CXX
+ default
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" DEBUG="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin html2text
+ doman html2text.1.gz html2textrc.5.gz
+ dodoc CHANGES CREDITS KNOWN_BUGS README TODO
+}