summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-09-21 19:31:38 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-09-21 19:31:38 +0000
commit9064f861e0ea94c6d1c90092c50d0f138e099ace (patch)
treec2b44dbc192e3e264f0d05e469c1cfdb8d7a71fb /app-text/html-xml-utils
parentCorrected xpm check - no fix if use X was no... (diff)
downloadgentoo-2-9064f861e0ea94c6d1c90092c50d0f138e099ace.tar.gz
gentoo-2-9064f861e0ea94c6d1c90092c50d0f138e099ace.tar.bz2
gentoo-2-9064f861e0ea94c6d1c90092c50d0f138e099ace.zip
Fixes #6160.
Diffstat (limited to 'app-text/html-xml-utils')
-rw-r--r--app-text/html-xml-utils/ChangeLog7
-rw-r--r--app-text/html-xml-utils/files/digest-html-xml-utils-2.3-r11
-rw-r--r--app-text/html-xml-utils/html-xml-utils-2.3-r1.ebuild28
-rw-r--r--app-text/html-xml-utils/html-xml-utils-2.3.ebuild11
4 files changed, 45 insertions, 2 deletions
diff --git a/app-text/html-xml-utils/ChangeLog b/app-text/html-xml-utils/ChangeLog
index f941c9618534..7ef8e945e3ed 100644
--- a/app-text/html-xml-utils/ChangeLog
+++ b/app-text/html-xml-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/html-xml-utils
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/html-xml-utils/ChangeLog,v 1.3 2002/08/02 17:42:49 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/html-xml-utils/ChangeLog,v 1.4 2002/09/21 19:31:38 karltk Exp $
+
+*html-xml-utils-2.3 (21 Sep 2002)
+
+ 21 Sep 2002; Karl Trygve Kalleberg <karltk@gentoo.org> html-xml-utils-2.3.ebuild :
+ Workaround to make it compile with gcc-3.2, fixes #6160.
*html-xml-utils-2.3 (16 Mar 2002)
diff --git a/app-text/html-xml-utils/files/digest-html-xml-utils-2.3-r1 b/app-text/html-xml-utils/files/digest-html-xml-utils-2.3-r1
new file mode 100644
index 000000000000..4dc322525755
--- /dev/null
+++ b/app-text/html-xml-utils/files/digest-html-xml-utils-2.3-r1
@@ -0,0 +1 @@
+MD5 1904a710e9fc6b2597f2f1a1a7f8029a html-xml-utils-2.3.tar.gz 169305
diff --git a/app-text/html-xml-utils/html-xml-utils-2.3-r1.ebuild b/app-text/html-xml-utils/html-xml-utils-2.3-r1.ebuild
new file mode 100644
index 000000000000..073214b34ed2
--- /dev/null
+++ b/app-text/html-xml-utils/html-xml-utils-2.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/html-xml-utils/html-xml-utils-2.3-r1.ebuild,v 1.1 2002/09/21 19:31:38 karltk Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A number of simple utilities for manipulating HTML and XML files."
+SRC_URI="http://www.w3.org/Tools/HTML-XML-utils/${P}.tar.gz"
+HOMEPAGE="http://www.w3.org/Tools/HTML-XML-utils/"
+KEYWORDS="x86 sparc sparc64"
+SLOT="0"
+LICENSE="W3C"
+
+DEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp heap.c heap.c.orig
+ sed -e "s/#define FILE.*/#define FILE __FILE__/" \
+ -e "s/#define LINE.*/#define LINE __LINE__/" \
+ < heap.c.orig > heap.c || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog COPYING NEWS README TODO
+}
diff --git a/app-text/html-xml-utils/html-xml-utils-2.3.ebuild b/app-text/html-xml-utils/html-xml-utils-2.3.ebuild
index 6f28bb5ec389..ce41bf372992 100644
--- a/app-text/html-xml-utils/html-xml-utils-2.3.ebuild
+++ b/app-text/html-xml-utils/html-xml-utils-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-text/html-xml-utils/html-xml-utils-2.3.ebuild,v 1.5 2002/08/16 02:42:01 murphy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/html-xml-utils/html-xml-utils-2.3.ebuild,v 1.6 2002/09/21 19:31:38 karltk Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A number of simple utilities for manipulating HTML and XML files."
@@ -12,6 +12,15 @@ LICENSE="W3C"
DEPEND="virtual/glibc"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp heap.c heap.c.orig
+ sed -e "s/#define FILE.*/#define FILE __FILE__/" \
+ -e "s/#define LINE.*/#define LINE __LINE__/" \
+ < heap.c.orig > heap.c || die
+}
+
src_install () {
make DESTDIR=${D} install || die