summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2006-11-22 11:05:33 +0000
committerMarinus Schraal <foser@gentoo.org>2006-11-22 11:05:33 +0000
commit07cf9fffee4a44bb0cf15c8309ff62da0709a20a (patch)
tree3b34bd91381670e1838064b7be78e83857e8dca6 /app-text/gtkspell
parentRevisited WANT_AUTO*, removed bad bad bad versions. Added nice version. (diff)
downloadgentoo-2-07cf9fffee4a44bb0cf15c8309ff62da0709a20a.tar.gz
gentoo-2-07cf9fffee4a44bb0cf15c8309ff62da0709a20a.tar.bz2
gentoo-2-07cf9fffee4a44bb0cf15c8309ff62da0709a20a.zip
add patch to support non-nls systems (#134467)
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-text/gtkspell')
-rw-r--r--app-text/gtkspell/ChangeLog6
-rw-r--r--app-text/gtkspell/files/gtkspell-2.0.11-nonls.patch21
-rw-r--r--app-text/gtkspell/gtkspell-2.0.11-r1.ebuild4
3 files changed, 29 insertions, 2 deletions
diff --git a/app-text/gtkspell/ChangeLog b/app-text/gtkspell/ChangeLog
index dda881bef4dc..713aba4d4f29 100644
--- a/app-text/gtkspell/ChangeLog
+++ b/app-text/gtkspell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/gtkspell
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.49 2006/11/17 18:11:02 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/ChangeLog,v 1.50 2006/11/22 11:05:33 foser Exp $
+
+ 22 Nov 2006; Marinus Schraal <foser@gentoo.org> gtkspell-2.0.11-r1.ebuild,
+ gtkspell-2.0.11-nonls.patch :
+ Add patch to build on systems without nls (#134467), patch by Yuri Vasilevski
17 Nov 2006; Daniel Gryniewicz <dang@gentoo.org>
-files/gtkspell-2.0.10-enchant.patch, -gtkspell-2.0.11.ebuild,
diff --git a/app-text/gtkspell/files/gtkspell-2.0.11-nonls.patch b/app-text/gtkspell/files/gtkspell-2.0.11-nonls.patch
new file mode 100644
index 000000000000..ba964abe7001
--- /dev/null
+++ b/app-text/gtkspell/files/gtkspell-2.0.11-nonls.patch
@@ -0,0 +1,21 @@
+diff -Naurp gtkspell-2.0.11.orig/gtkspell/gtkspell.c gtkspell-2.0.11/gtkspell/gtkspell.c
+--- gtkspell-2.0.11.orig/gtkspell/gtkspell.c 2006-05-26 20:59:21 -0500
++++ gtkspell-2.0.11/gtkspell/gtkspell.c 2006-05-26 21:03:04 -0500
+@@ -5,12 +5,16 @@
+ /* vim: set ts=4 sw=4 wm=5 : */
+
+ #include <gtk/gtk.h>
+-#include <libintl.h>
+ #include <locale.h>
+ #include "../config.h"
+ #include "gtkspell.h"
+
++#ifdef ENABLE_NLS
++#include <libintl.h>
+ #define _(String) dgettext (PACKAGE, String)
++#else
++#define _(String) String
++#endif
+
+ #define GTKSPELL_MISSPELLED_TAG "gtkspell-misspelled"
+
diff --git a/app-text/gtkspell/gtkspell-2.0.11-r1.ebuild b/app-text/gtkspell/gtkspell-2.0.11-r1.ebuild
index 14533575aeb3..1d3c68c30cef 100644
--- a/app-text/gtkspell/gtkspell-2.0.11-r1.ebuild
+++ b/app-text/gtkspell/gtkspell-2.0.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.11-r1.ebuild,v 1.3 2006/11/17 18:11:02 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gtkspell/gtkspell-2.0.11-r1.ebuild,v 1.4 2006/11/22 11:05:33 foser Exp $
inherit libtool eutils
@@ -30,6 +30,8 @@ src_unpack() {
# use enchant as backend
epatch ${FILESDIR}/${PN}-2.0.11-enchant.patch
+ # build on systems without nls (#134467)
+ epatch ${FILESDIR}/${PN}-2.0.11-nonls.patch
autoconf || die
libtoolize --copy --force