summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-08-13 17:25:30 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-08-13 17:25:30 +0000
commitf6e40d0ed8725b7eff7aacb272490ae3b686e5d1 (patch)
treeddbdc6c2a9cd912cdcd1d0586326e2f4055c897d /app-text/gonzui
parentBug #233006, block sys-libs/db:4.7 properly. Patch from Arfrever Frehtes Taif... (diff)
downloadgentoo-2-f6e40d0ed8725b7eff7aacb272490ae3b686e5d1.tar.gz
gentoo-2-f6e40d0ed8725b7eff7aacb272490ae3b686e5d1.tar.bz2
gentoo-2-f6e40d0ed8725b7eff7aacb272490ae3b686e5d1.zip
Fixed bug #226697.
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-text/gonzui')
-rw-r--r--app-text/gonzui/ChangeLog10
-rw-r--r--app-text/gonzui/files/gonzui-1.2-gentoo.patch34
-rw-r--r--app-text/gonzui/gonzui-1.2-r1.ebuild49
3 files changed, 91 insertions, 2 deletions
diff --git a/app-text/gonzui/ChangeLog b/app-text/gonzui/ChangeLog
index 133ac595b5de..348e5814c0ea 100644
--- a/app-text/gonzui/ChangeLog
+++ b/app-text/gonzui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/gonzui
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gonzui/ChangeLog,v 1.8 2007/01/28 05:48:44 genone Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gonzui/ChangeLog,v 1.9 2008/08/13 17:25:30 matsuu Exp $
+
+*gonzui-1.2-r1 (13 Aug 2008)
+
+ 13 Aug 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/gonzui-1.2-gentoo.patch, +gonzui-1.2-r1.ebuild:
+ Fixed bug @226697.
28 Jan 2007; Marius Mauch <genone@gentoo.org> gonzui-1.2.ebuild:
Replacing einfo with elog
diff --git a/app-text/gonzui/files/gonzui-1.2-gentoo.patch b/app-text/gonzui/files/gonzui-1.2-gentoo.patch
new file mode 100644
index 000000000000..5aa22e8e3094
--- /dev/null
+++ b/app-text/gonzui/files/gonzui-1.2-gentoo.patch
@@ -0,0 +1,34 @@
+diff -Naur gonzui-1.2.orig/Makefile.am gonzui-1.2/Makefile.am
+--- gonzui-1.2.orig/Makefile.am 2005-03-25 18:00:20.000000000 +0900
++++ gonzui-1.2/Makefile.am 2008-08-14 02:17:18.000000000 +0900
+@@ -28,7 +28,7 @@
+ gonzui.rb.in > gonzui.rb
+ chmod -w gonzui.rb
+
+-gonzuirc.sample.in: gonzuirc.sample.in.in
++gonzuirc.sample.in: gonzui.rb gonzuirc.sample.in.in
+ ruby gonzui-db --gonzuirc gonzuirc.sample.in.in --dump-config \
+ > gonzuirc.sample.in
+
+diff -Naur gonzui-1.2.orig/configure.ac gonzui-1.2/configure.ac
+--- gonzui-1.2.orig/configure.ac 2005-07-05 00:07:52.000000000 +0900
++++ gonzui-1.2/configure.ac 2008-08-14 02:04:17.000000000 +0900
+@@ -9,7 +9,6 @@
+ AC_PROG_CC
+ AC_PROG_INSTALL
+ AC_PROG_MAKE_SET
+-AM_MAINTAINER_MODE
+ AM_PATH_RUBY
+ AM_RUN_LOG_DIRS
+ AM_USER_GROUP
+diff -Naur gonzui-1.2.orig/langscan/Makefile.am gonzui-1.2/langscan/Makefile.am
+--- gonzui-1.2.orig/langscan/Makefile.am 2005-07-05 00:07:57.000000000 +0900
++++ gonzui-1.2/langscan/Makefile.am 2008-08-14 02:17:58.000000000 +0900
+@@ -26,6 +26,7 @@
+ brainfuck.rb \
+ c.rb \
+ css.rb \
++ ebuild.rb \
+ elisp.rb \
+ java.rb \
+ javascript.rb \
diff --git a/app-text/gonzui/gonzui-1.2-r1.ebuild b/app-text/gonzui/gonzui-1.2-r1.ebuild
new file mode 100644
index 000000000000..e767812f040e
--- /dev/null
+++ b/app-text/gonzui/gonzui-1.2-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gonzui/gonzui-1.2-r1.ebuild,v 1.1 2008/08/13 17:25:30 matsuu Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit autotools eutils ruby
+
+USE_RUBY="ruby18 ruby19"
+
+DESCRIPTION="source code search engine"
+HOMEPAGE="http://gonzui.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gonzui/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ocaml perl"
+RESTRICT="test"
+
+DEPEND=">=virtual/ruby-1.8.2
+ >=sys-libs/db-4.2
+ >=dev-ruby/ruby-bdb-0.5.2
+ dev-ruby/ruby-progressbar
+ ocaml? ( dev-lang/ocaml )
+ perl? ( dev-perl/PPI )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ cp "${FILESDIR}"/ebuild.rb "${S}"/langscan/ || die
+ eautoreconf
+}
+
+src_install() {
+ ruby_src_install
+ mv "${D}"/etc/gonzuirc.sample "${D}"/etc/gonzuirc
+ doinitd "${FILESDIR}"/gonzui || die
+ keepdir /var/lib/gonzui
+ keepdir /var/log/gonzui
+}
+
+pkg_postinst() {
+ elog "The database (gonzui.db) format has become incompatible with"
+ elog "older versions."
+ elog "Please restructure the database if you already have it."
+}