summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-06-29 14:57:40 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-06-29 14:57:40 +0000
commitb19ca266da26e74332ccaa8bb6a5f843f9b9dc2d (patch)
tree541003a5a6ddd199de8ba4ee46a95a8c594fbd03 /app-text/gocr
parentversion bump (diff)
downloadgentoo-2-b19ca266da26e74332ccaa8bb6a5f843f9b9dc2d.tar.gz
gentoo-2-b19ca266da26e74332ccaa8bb6a5f843f9b9dc2d.tar.bz2
gentoo-2-b19ca266da26e74332ccaa8bb6a5f843f9b9dc2d.zip
sandbox violation fix
Diffstat (limited to 'app-text/gocr')
-rw-r--r--app-text/gocr/ChangeLog9
-rw-r--r--app-text/gocr/files/digest-gocr-0.3.6-r11
-rw-r--r--app-text/gocr/gocr-0.3.6-r1.ebuild84
3 files changed, 93 insertions, 1 deletions
diff --git a/app-text/gocr/ChangeLog b/app-text/gocr/ChangeLog
index 450ec0e11703..976e982b5a3d 100644
--- a/app-text/gocr/ChangeLog
+++ b/app-text/gocr/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/gocr
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.2 2002/06/28 18:19:07 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.3 2002/06/29 14:57:40 seemant Exp $
+
+*gocr-0.3.6-r1 (29 Jun 2002)
+
+ 29 Jun 2002; Seemant Kulleen <seeamnt@gentoo.org> gocr-0.3.6-r1.ebuild
+ files/digest-gocr-0.3.6-r1 :
+
+ sandbox violation fix.
*gocr-0.3.6 (28 Jun 2002)
diff --git a/app-text/gocr/files/digest-gocr-0.3.6-r1 b/app-text/gocr/files/digest-gocr-0.3.6-r1
new file mode 100644
index 000000000000..9dfd2823000b
--- /dev/null
+++ b/app-text/gocr/files/digest-gocr-0.3.6-r1
@@ -0,0 +1 @@
+MD5 47dadd37fe434c9e33443288119878a5 gocr-0.3.6.tar.gz 668653
diff --git a/app-text/gocr/gocr-0.3.6-r1.ebuild b/app-text/gocr/gocr-0.3.6-r1.ebuild
new file mode 100644
index 000000000000..3be424178213
--- /dev/null
+++ b/app-text/gocr/gocr-0.3.6-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.3.6-r1.ebuild,v 1.1 2002/06/29 14:57:40 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Converts PNM to ASCII"
+SRC_URI="mirror://sourceforge/jocr/${P}.tar.gz"
+HOMEPAGE="http://altmark.nat.uni-magdeburg.de/~jschulen/ocr/"
+
+DEPEND="virtual/glibc
+ app-text/tetex
+ app-text/ghostscript
+ >=media-libs/netpbm-9.12-r1"
+
+RDEPEND="virtual/glibc
+ >=media-libs/netpbm-9.12-r1"
+
+
+SLOT=""
+LICENSE="GPL"
+
+src_unpack() {
+
+ unpack ${A}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff
+ cd ${S}
+ autoconf
+ cd ${S}/doc
+ cp Makefile.in Makefile.orig
+ sed -e "s:\$(DVIPS) \$?:\$(DVIPS) -o \$(OCRDOC).ps \$?:" \
+ Makefile.orig > Makefile.in
+ cd ../bin
+ mv gocr.tcl gocr.orig
+ sed -e "s:\.\./examples:/usr/share/gocr/fonts:" \
+ gocr.orig > gocr.tcl
+ cd ../src
+ cp database.c database.orig
+ sed -e "s:\./db/:${D}/usr/share/gocr/db/:" database.orig > database.c
+ cd ../examples
+ cp Makefile Makefile.orig
+ sed -e "s:polish.pbm man.pbm:polish.pbm:" Makefile.orig > Makefile
+
+}
+
+src_compile() {
+
+ export CFLAGS="${CFLAGS} -I/usr/include/pbm"
+ ./configure --prefix=/usr --host=${CHOST} || die
+ make src frontend database
+ use tetex && (\
+ addwrite "/usr/share/texmf"
+ make \
+ prefix=${D}/usr \
+ sysconfdir=/${D}/etc \
+ mandir=${D}/usr/share/man \
+ datadir=${D}/usr/share \
+ doc || die
+ )
+}
+
+src_install () {
+
+ dobin bin/gocr
+ exeinto /usr/bin
+ doexe bin/gocr.tcl
+ dolib.a src/libPgm2asc.a
+ a
+ insinto /usr/include
+ doins src/gocr.h
+ insinto /usr/share/gocr/db
+ doins db/*
+ doman man/man1/gocr.1
+ dodoc AUTHORS BUGS CREDITS HISTORY README* REMARK.txt REVIEW TODO gpl.html
+ docinto txt
+ dodoc doc/*.txt
+
+ use tetex && ( \
+ insinto /usr/share/gocr/db
+ docinto ps
+ dodoc doc/ocr.ps
+ )
+
+}
+