summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-01-11 20:31:12 +0000
committerPacho Ramos <pacho@gentoo.org>2011-01-11 20:31:12 +0000
commitd69ad4eeead3c1a7efb075fe3ccc91e097fbceda (patch)
tree60e29780a9b3764e58e3d74b556a4cd200aa1918 /app-text/gnome-doc-utils
parentppc stable wrt #338934, keyword ~ppc64 wrt #279241 (diff)
downloadgentoo-2-d69ad4eeead3c1a7efb075fe3ccc91e097fbceda.tar.gz
gentoo-2-d69ad4eeead3c1a7efb075fe3ccc91e097fbceda.tar.bz2
gentoo-2-d69ad4eeead3c1a7efb075fe3ccc91e097fbceda.zip
Version bump: Use /bin/bash in gnome-doc-tool, add xml:lang attribute to translated Mallard pages, handle title and desc elements in Mallard tables, updated translations.
(Portage version: 2.1.9.30/cvs/Linux x86_64)
Diffstat (limited to 'app-text/gnome-doc-utils')
-rw-r--r--app-text/gnome-doc-utils/ChangeLog11
-rw-r--r--app-text/gnome-doc-utils/gnome-doc-utils-0.20.4.ebuild86
2 files changed, 95 insertions, 2 deletions
diff --git a/app-text/gnome-doc-utils/ChangeLog b/app-text/gnome-doc-utils/ChangeLog
index 57b0f3adcdf0..eac20d6a8a50 100644
--- a/app-text/gnome-doc-utils/ChangeLog
+++ b/app-text/gnome-doc-utils/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/gnome-doc-utils
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-doc-utils/ChangeLog,v 1.176 2010/12/31 23:50:12 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-doc-utils/ChangeLog,v 1.177 2011/01/11 20:31:12 pacho Exp $
+
+*gnome-doc-utils-0.20.4 (11 Jan 2011)
+
+ 11 Jan 2011; Pacho Ramos <pacho@gentoo.org> +gnome-doc-utils-0.20.4.ebuild:
+ Version bump: Use /bin/bash in gnome-doc-tool, add xml:lang attribute to
+ translated Mallard pages, handle title and desc elements in Mallard tables,
+ updated translations.
31 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
gnome-doc-utils-0.20.2.ebuild, gnome-doc-utils-0.20.3.ebuild:
diff --git a/app-text/gnome-doc-utils/gnome-doc-utils-0.20.4.ebuild b/app-text/gnome-doc-utils/gnome-doc-utils-0.20.4.ebuild
new file mode 100644
index 000000000000..486f2f314ef5
--- /dev/null
+++ b/app-text/gnome-doc-utils/gnome-doc-utils-0.20.4.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gnome-doc-utils/gnome-doc-utils-0.20.4.ebuild,v 1.1 2011/01/11 20:31:12 pacho Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND="2:2.4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit gnome2 python
+
+DESCRIPTION="A collection of documentation utilities for the Gnome project"
+HOMEPAGE="http://live.gnome.org/GnomeDocUtils"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/libxml2-2.6.12[python]
+ >=dev-libs/libxslt-1.1.8
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ ~app-text/docbook-xml-dtd-4.4
+ app-text/scrollkeeper-dtd"
+# dev-libs/glib needed for eautofoo, bug #255114.
+
+# FIXME: Highly broken with parallel make, see bug #286889
+MAKEOPTS="${MAKEOPTS} -j1"
+
+# If there is a need to reintroduce eautomake or eautoreconf, make sure
+# to AT_M4DIR="tools m4", bug #224609 (m4 removes glib build time dep)
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ G2CONF="${G2CONF} --disable-scrollkeeper"
+ python_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_execute_function -s gnome2_src_configure
+}
+
+src_compile() {
+ python_execute_function -d -s
+}
+
+src_test() {
+ python_execute_function -d -s
+}
+
+src_install() {
+ installation() {
+ gnome2_src_install
+ python_convert_shebangs $(python_get_version) "${ED}"usr/bin/xml2po
+ mv "${ED}"usr/bin/xml2po "${ED}"usr/bin/xml2po-$(python_get_version)
+ }
+ python_execute_function -s installation
+ python_clean_installation_image
+
+ python_generate_wrapper_scripts -E -f "${ED}"usr/bin/xml2po
+}
+
+pkg_postinst() {
+ python_mod_optimize xml2po
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ python_mod_cleanup xml2po
+ gnome2_pkg_postrm
+}