summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-12-27 19:16:44 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-12-27 19:16:44 +0000
commitf48adb303e7607b3b87983dccbed7f15b3b98fee (patch)
treea02f5c50982f0a827522a743aaaccba2b52da0ad /app-text/glark/glark-1.7.2.ebuild
parentMoved from app-sci/geda to sci-electronics/geda (diff)
downloadgentoo-2-f48adb303e7607b3b87983dccbed7f15b3b98fee.tar.gz
gentoo-2-f48adb303e7607b3b87983dccbed7f15b3b98fee.tar.bz2
gentoo-2-f48adb303e7607b3b87983dccbed7f15b3b98fee.zip
New version, bug #75814. Now with bash-completion goodness.
Diffstat (limited to 'app-text/glark/glark-1.7.2.ebuild')
-rw-r--r--app-text/glark/glark-1.7.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/glark/glark-1.7.2.ebuild b/app-text/glark/glark-1.7.2.ebuild
new file mode 100644
index 000000000000..465468912346
--- /dev/null
+++ b/app-text/glark/glark-1.7.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/glark/glark-1.7.2.ebuild,v 1.1 2004/12/27 19:16:44 ciaranm Exp $
+
+inherit bash-completion
+
+DESCRIPTION="File searcher similar to grep but with fancy output"
+HOMEPAGE="http://glark.sourceforge.net/"
+SRC_URI="mirror://sourceforge/glark/${P}.tar.gz"
+
+KEYWORDS="~x86 ~sparc ~ppc ~mips ~amd64"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE=""
+
+# perl dep is for pod2man
+DEPEND="virtual/ruby
+ dev-lang/perl"
+RDEPEND="virtual/ruby"
+
+src_compile() {
+ emake
+ # force the manpage to be rebuilt
+ rm ${PN}.1
+ make ${PN}.1
+}
+
+src_install () {
+ make DESTDIR=${D} install
+ dobashcompletion ${FILESDIR}/${PV}/glark-completion ${PN}
+}
+