summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-12-14 19:13:36 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-12-14 19:13:36 +0000
commit0fa2c402c6ff8e2614cb2d04ccef501b9efb9822 (patch)
tree6d0824abb969424898dd51a75958a93a73a40df0 /app-text/ghostscript-gpl
parentDrop hotplug support in favour of udev, bug 158114, also add missing vim depe... (diff)
downloadgentoo-2-0fa2c402c6ff8e2614cb2d04ccef501b9efb9822.tar.gz
gentoo-2-0fa2c402c6ff8e2614cb2d04ccef501b9efb9822.tar.bz2
gentoo-2-0fa2c402c6ff8e2614cb2d04ccef501b9efb9822.zip
Add hacked up djvu fix for -gpl for bug 158079
(Portage version: 2.1.2_rc3-r5)
Diffstat (limited to 'app-text/ghostscript-gpl')
-rw-r--r--app-text/ghostscript-gpl/ChangeLog6
-rw-r--r--app-text/ghostscript-gpl/files/djvu-gs-gpl.patch74
-rw-r--r--app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild3
3 files changed, 81 insertions, 2 deletions
diff --git a/app-text/ghostscript-gpl/ChangeLog b/app-text/ghostscript-gpl/ChangeLog
index 5f3cb7568c4d..be5fb9d8343d 100644
--- a/app-text/ghostscript-gpl/ChangeLog
+++ b/app-text/ghostscript-gpl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/ghostscript-gpl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ChangeLog,v 1.8 2006/12/12 23:36:44 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ChangeLog,v 1.9 2006/12/14 19:13:36 genstef Exp $
+
+ 14 Dec 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/djvu-gs-gpl.patch, ghostscript-gpl-8.54.ebuild:
+ Add hacked up djvu fix for -gpl for bug 158079
12 Dec 2006; Stefan Schweizer <genstef@gentoo.org>
ghostscript-gpl-8.54.ebuild:
diff --git a/app-text/ghostscript-gpl/files/djvu-gs-gpl.patch b/app-text/ghostscript-gpl/files/djvu-gs-gpl.patch
new file mode 100644
index 000000000000..590f65813543
--- /dev/null
+++ b/app-text/ghostscript-gpl/files/djvu-gs-gpl.patch
@@ -0,0 +1,74 @@
+diff -ur ghostscript-8.54-gpl.orig/gsdjvu ghostscript-8.54-gpl/gsdjvu
+--- ghostscript-8.54-gpl.orig/gsdjvu 2006-12-14 19:14:43.000000000 +0100
++++ ghostscript-8.54-gpl/gsdjvu 2006-12-14 19:23:16.000000000 +0100
+@@ -56,4 +56,4 @@
+ # Step 2 -- execute ghostscript
+
+ gsdir="$progdir"
+-GS_LIB="$gsdir/lib:$gsdir/fonts:$gsdir" exec "$gsdir/bin/gs" "$@"
++GS_LIB="$gsdir/lib:$gsdir/fonts:$gsdir" exec "/usr/bin/gs" "$@"
+diff -ur ghostscript-8.54-gpl.orig/src/gdevdjvu.c ghostscript-8.54-gpl/src/gdevdjvu.c
+--- ghostscript-8.54-gpl.orig/src/gdevdjvu.c 2006-12-14 19:14:17.000000000 +0100
++++ ghostscript-8.54-gpl/src/gdevdjvu.c 2006-12-14 19:20:17.000000000 +0100
+@@ -133,7 +133,7 @@
+ private void
+ lbassertfail(const char *file, int line)
+ {
+- fprintf(stderr,"Internal error at %s:%d\n", file, line);
++ //printf("Internal error at %s:%d\n", file, line);
+ abort();
+ }
+
+@@ -164,6 +164,8 @@
+ #define p2mem_log2_align log2_obj_align_mod
+ #define p2mem_align obj_align_mod
+
++gs_memory_t *gs_memory_t_default;
++#define gs_memory_default (*gs_memory_t_default)
+ /* Parent allocator */
+ #define p2mem_parent_alloc(size) \
+ (void *)gs_alloc_bytes_immovable(&gs_memory_default, size, "p2mem")
+@@ -4920,12 +4922,6 @@
+ 0, cdev->width-1, 0, cdev->height-1, comment);
+ if (code < 0) return code;
+ }
+- /* Print message */
+- if (! cdev->quiet) {
+- fprintf(stdout,"Page %dx%d (%s )\n",
+- cdev->width, cdev->height, comment);
+- fflush(stdout);
+- }
+ /* Terminate */
+ runmap_free(fgmap);
+ #ifdef DEBUG
+@@ -5322,12 +5318,6 @@
+ if (code < 0)
+ return code;
+ }
+- /* Print message */
+- if (! cdev->quiet) {
+- fprintf(stdout,"Page %dx%d (%s )\n",
+- cdev->width, cdev->height, comment);
+- fflush(stdout);
+- }
+ /* Terminate */
+ runmap_free(fgmap);
+ #ifdef DEBUG
+@@ -5383,7 +5373,7 @@
+ push(1);
+ glyph = gs_text_current_glyph(osenum);
+ if (glyph != gs_no_glyph)
+- glyph_ref(glyph, op);
++ glyph_ref(imemory, glyph, op);
+ else
+ make_int(op, gs_text_current_char(osenum));
+ return 0;
+@@ -5498,7 +5488,7 @@
+ /* Check argument types */
+ check_op(5);
+ if ( (code = num_params(op, 4, xy)) < 0 ||
+- (code = obj_string_data(op - 4, &utf8, &utf8len)) < 0 )
++ (code = obj_string_data(imemory, op - 4, &utf8, &utf8len)) < 0 )
+ return code;
+ /* Check that current device is djvusep */
+ dev = gs_currentdevice(igs);
diff --git a/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild b/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild
index da5f893da842..48dc3a4a03cb 100644
--- a/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild
+++ b/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild,v 1.8 2006/12/12 23:36:44 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/ghostscript-gpl/ghostscript-gpl-8.54.ebuild,v 1.9 2006/12/14 19:13:36 genstef Exp $
WANT_AUTOMAKE=1.6
@@ -84,6 +84,7 @@ src_unpack() {
unpack gsdjvu-${GSDJVU_PV}.tar.gz
cp gsdjvu-${GSDJVU_PV}/gsdjvu ${S}
cp gsdjvu-${GSDJVU_PV}/gdevdjvu.c ${S}/src
+ epatch ${FILESDIR}/djvu-gs-gpl.patch
cp gsdjvu-${GSDJVU_PV}/ps2utf8.ps ${S}/lib
cp ${S}/src/contrib.mak ${S}/src/contrib.mak.gsdjvu
grep -q djvusep ${S}/src/contrib.mak || \