summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-16 18:23:25 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-12-16 18:23:25 +0000
commita81421250fe379e1490f9b324184d0714b1aca16 (patch)
tree9c00b023131c3a525f6cf942c9c53d09f99d59a0 /app-text/evince
parentDrop last live ebuild chunk. (diff)
downloadgentoo-2-a81421250fe379e1490f9b324184d0714b1aca16.tar.gz
gentoo-2-a81421250fe379e1490f9b324184d0714b1aca16.tar.bz2
gentoo-2-a81421250fe379e1490f9b324184d0714b1aca16.zip
Update to EAPI5, modernize ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'app-text/evince')
-rw-r--r--app-text/evince/ChangeLog5
-rw-r--r--app-text/evince/evince-3.6.1.ebuild57
2 files changed, 25 insertions, 37 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index 14fa11801f27..b9624db6edac 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/evince
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.253 2012/12/16 13:02:34 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.254 2012/12/16 18:23:25 tetromino Exp $
+
+ 16 Dec 2012; Alexandre Rostovtsev <tetromino@gentoo.org> evince-3.6.1.ebuild:
+ Update to EAPI5, modernize ebuild.
*evince-3.6.1 (16 Dec 2012)
diff --git a/app-text/evince/evince-3.6.1.ebuild b/app-text/evince/evince-3.6.1.ebuild
index 52c00569e8ec..a8460ab2b31d 100644
--- a/app-text/evince/evince-3.6.1.ebuild
+++ b/app-text/evince/evince-3.6.1.ebuild
@@ -1,28 +1,21 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-3.6.1.ebuild,v 1.1 2012/12/16 13:02:34 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-3.6.1.ebuild,v 1.2 2012/12/16 18:23:25 tetromino Exp $
-EAPI="4"
+EAPI="5"
GCONF_DEBUG="yes"
GNOME2_LA_PUNT="yes"
inherit eutils gnome2
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
DESCRIPTION="Simple document viewer for GNOME"
HOMEPAGE="http://www.gnome.org/projects/evince/"
-LICENSE="GPL-2+"
-SLOT="0"
+LICENSE="GPL-2+ CCPL-Attribution-ShareAlike-3.0"
+# subslot = evd3.(suffix of libevdocument3)-evv3.(suffix of libevview3)
+SLOT="0/evd3.4-evv3.3"
IUSE="dbus debug djvu dvi gnome-keyring +introspection nautilus +postscript t1lib tiff xps"
-if [[ ${PV} = 9999 ]]; then
- IUSE="${IUSE} doc"
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
-fi
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
# Since 2.26.2, can handle poppler without cairo support. Make it optional ?
# not mature enough
@@ -33,29 +26,29 @@ RDEPEND="
dev-libs/atk
>=dev-libs/glib-2.33:2
>=dev-libs/libxml2-2.5:2
- sys-libs/zlib
+ sys-libs/zlib:=
x11-libs/gdk-pixbuf:2
>=x11-libs/gtk+-3.0.2:3[introspection?]
- x11-libs/libX11
- >=x11-libs/libSM-1
- x11-libs/libICE
+ x11-libs/libX11:=
+ >=x11-libs/libSM-1:=
+ x11-libs/libICE:=
gnome-base/gsettings-desktop-schemas
|| (
>=x11-themes/gnome-icon-theme-2.17.1
>=x11-themes/hicolor-icon-theme-0.10 )
- >=x11-libs/cairo-1.10
- >=app-text/poppler-0.20[cairo]
- djvu? ( >=app-text/djvu-3.5.17 )
+ >=x11-libs/cairo-1.10:=
+ >=app-text/poppler-0.20:=[cairo]
+ djvu? ( >=app-text/djvu-3.5.17:= )
dvi? (
virtual/tex-base
- dev-libs/kpathsea
- t1lib? ( >=media-libs/t1lib-5 ) )
+ dev-libs/kpathsea:=
+ t1lib? ( >=media-libs/t1lib-5:= ) )
gnome-keyring? ( >=gnome-base/gnome-keyring-2.22 )
introspection? ( >=dev-libs/gobject-introspection-1 )
nautilus? ( >=gnome-base/nautilus-2.91.4[introspection?] )
- postscript? ( >=app-text/libspectre-0.2.0 )
- tiff? ( >=media-libs/tiff-3.6:0 )
- xps? ( >=app-text/libgxps-0.2.1 )
+ postscript? ( >=app-text/libspectre-0.2.0:= )
+ tiff? ( >=media-libs/tiff-3.6:0= )
+ xps? ( >=app-text/libgxps-0.2.1:= )
"
DEPEND="${RDEPEND}
app-text/docbook-xml-dtd:4.3
@@ -64,19 +57,13 @@ DEPEND="${RDEPEND}
>=dev-util/intltool-0.35
virtual/pkgconfig"
-if [[ ${PV} = 9999 ]]; then
- DEPEND="${DEPEND}
- app-text/yelp-tools
- doc? ( >=dev-util/gtk-doc-1.13 )"
-fi
-
ELTCONF="--portage"
# Needs dogtail and pyspi from http://fedorahosted.org/dogtail/
# Releases: http://people.redhat.com/zcerza/dogtail/releases/
RESTRICT="test"
-pkg_setup() {
+src_prepare() {
G2CONF="${G2CONF}
--disable-static
--disable-tests
@@ -94,12 +81,10 @@ pkg_setup() {
$(use_enable postscript ps)
$(use_enable t1lib)
$(use_enable tiff)
- $(use_enable xps)"
- [[ ${PV} != 9999 ]] && G2CONF="${G2CONF} ITSTOOL=$(type -P true)"
+ $(use_enable xps)
+ ITSTOOL=$(type -P true)"
DOCS="AUTHORS ChangeLog NEWS README TODO"
-}
-src_prepare() {
# Fix .desktop file so menu item shows up
epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch