summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-08-16 22:43:46 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-08-16 22:43:46 +0000
commit3255020524940a662fbb069b8d7ee53e624d5267 (patch)
tree5df035ceef61ac45fa59fb3a0fd632b86953e6ef /app-text/evince
parentVersion bump (bug #363425). (diff)
downloadgentoo-2-3255020524940a662fbb069b8d7ee53e624d5267.tar.gz
gentoo-2-3255020524940a662fbb069b8d7ee53e624d5267.tar.bz2
gentoo-2-3255020524940a662fbb069b8d7ee53e624d5267.zip
Bump to 3.0.2, from gnome overlay for GNOME 3
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'app-text/evince')
-rw-r--r--app-text/evince/ChangeLog9
-rw-r--r--app-text/evince/evince-3.0.2.ebuild104
-rw-r--r--app-text/evince/files/evince-2.91.5-fix-evinceview-introspection.patch18
3 files changed, 130 insertions, 1 deletions
diff --git a/app-text/evince/ChangeLog b/app-text/evince/ChangeLog
index 005e3f913e01..6fc40879e65f 100644
--- a/app-text/evince/ChangeLog
+++ b/app-text/evince/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/evince
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.226 2011/08/13 16:32:31 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/ChangeLog,v 1.227 2011/08/16 22:43:46 nirbheek Exp $
+
+*evince-3.0.2 (16 Aug 2011)
+
+ 16 Aug 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +files/evince-2.91.5-fix-evinceview-introspection.patch,
+ +evince-3.0.2.ebuild:
+ Bump to 3.0.2, from gnome overlay for GNOME 3
13 Aug 2011; Raúl Porcel <armin76@gentoo.org> evince-2.32.0-r3.ebuild:
alpha/ia64/sparc stable wrt #369909
diff --git a/app-text/evince/evince-3.0.2.ebuild b/app-text/evince/evince-3.0.2.ebuild
new file mode 100644
index 000000000000..f5dd6085ab0b
--- /dev/null
+++ b/app-text/evince/evince-3.0.2.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/evince/evince-3.0.2.ebuild,v 1.1 2011/08/16 22:43:46 nirbheek Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Simple document viewer for GNOME"
+HOMEPAGE="http://www.gnome.org/projects/evince/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="dbus debug djvu doc dvi gnome-keyring +introspection nautilus t1lib tiff"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x64-solaris"
+
+# Since 2.26.2, can handle poppler without cairo support. Make it optional ?
+# not mature enough
+RDEPEND="
+ >=app-text/libspectre-0.2.0
+ >=dev-libs/glib-2.25.11:2
+ >=dev-libs/libxml2-2.5:2
+ >=x11-libs/gtk+-3.0.2:3[introspection?]
+ >=x11-libs/libSM-1
+ x11-libs/libICE
+ gnome-base/gsettings-desktop-schemas
+ || (
+ >=x11-themes/gnome-icon-theme-2.17.1
+ >=x11-themes/hicolor-icon-theme-0.10 )
+ >=x11-libs/cairo-1.10.0
+ >=app-text/poppler-0.16[cairo]
+ djvu? ( >=app-text/djvu-3.5.17 )
+ dvi? (
+ virtual/tex-base
+ t1lib? ( >=media-libs/t1lib-5.0.0 ) )
+ gnome-keyring? ( >=gnome-base/gnome-keyring-2.22.0 )
+ introspection? ( >=dev-libs/gobject-introspection-0.6 )
+ nautilus? ( >=gnome-base/nautilus-2.91.4[introspection?] )
+ tiff? ( >=media-libs/tiff-3.6 )
+"
+DEPEND="${RDEPEND}
+ app-text/scrollkeeper
+ >=app-text/gnome-doc-utils-0.3.2
+ ~app-text/docbook-xml-dtd-4.1.2
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/gtk-doc-am-1.13
+ doc? ( >=dev-util/gtk-doc-1.13 )"
+
+ELTCONF="--portage"
+
+# Needs dogtail and pyspi from http://fedorahosted.org/dogtail/
+# Releases: http://people.redhat.com/zcerza/dogtail/releases/
+RESTRICT="test"
+
+pkg_setup() {
+ # Passing --disable-help would drop offline help, that would be inconsistent
+ # with helps of the most of Gnome apps that doesn't require network for that.
+ #
+ # FIXME: XPS support needs >=libgxps-0.0.1
+ # http://git.gnome.org/browse/libgxps <-- no releases
+ G2CONF="${G2CONF}
+ --disable-maintainer-mode
+ --disable-schemas-compile
+ --disable-scrollkeeper
+ --disable-static
+ --disable-tests
+ --enable-pdf
+ --enable-comics
+ --enable-thumbnailer
+ --with-smclient=xsmp
+ --with-platform=gnome
+ --enable-help
+ $(use_enable dbus)
+ $(use_enable djvu)
+ $(use_enable dvi)
+ $(use_with gnome-keyring keyring)
+ $(use_enable introspection)
+ $(use_enable nautilus)
+ $(use_enable t1lib)
+ $(use_enable tiff)
+ --disable-xps"
+ DOCS="AUTHORS ChangeLog NEWS README TODO"
+}
+
+src_prepare() {
+ # Do not depend on gnome-icon-theme, bug #326855
+ sed 's/gnome-icon-theme//' -i configure.ac || die "sed failed"
+
+ # Fix .desktop file so menu item shows up
+ epatch "${FILESDIR}"/${PN}-0.7.1-display-menu.patch
+
+ # Fix building of EvinceView-3.0.gir, needs eautoreconf
+ epatch "${FILESDIR}"/${PN}-2.91.5-fix-evinceview-introspection.patch
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+
+ gnome2_src_prepare
+}
diff --git a/app-text/evince/files/evince-2.91.5-fix-evinceview-introspection.patch b/app-text/evince/files/evince-2.91.5-fix-evinceview-introspection.patch
new file mode 100644
index 000000000000..539384348363
--- /dev/null
+++ b/app-text/evince/files/evince-2.91.5-fix-evinceview-introspection.patch
@@ -0,0 +1,18 @@
+Fix building of EvinceView-3.0.gir
+
+* Without the library-path directive, it cannot find libevdocument3
+* The devs missed it because it tries to pick up the system libevdocument3
+ - That's wrong too, because it'll build the current version's introspection
+ against the previous version's library, etc.
+
+---
+--- libview/Makefile.am
++++ libview/Makefile.am
+@@ -122,6 +122,7 @@
+ $(AM_V_GEN) PKG_CONFIG_PATH=$(top_builddir):$$PKG_CONFIG_PATH \
+ $(G_IR_SCANNER) -v --namespace EvinceView \
+ --add-include-path=$(top_builddir)/libdocument \
++ --library-path=$(top_builddir)/libdocument \
+ --strip-prefix=Ev \
+ --nsversion=$(EV_API_VERSION) \
+ --include=GLib-2.0 \