summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2009-02-17 21:23:39 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2009-02-17 21:23:39 +0000
commitb3b550924612f2f72c9d01ebe07cd400f9a8eab2 (patch)
treeedad89eace68628301ae1f00ad75d2d0dab3c330 /app-text/epstool
parentRemoved obsolete version. (diff)
downloadgentoo-2-b3b550924612f2f72c9d01ebe07cd400f9a8eab2.tar.gz
gentoo-2-b3b550924612f2f72c9d01ebe07cd400f9a8eab2.tar.bz2
gentoo-2-b3b550924612f2f72c9d01ebe07cd400f9a8eab2.zip
Fix for gcc 4.3 and newer (bug #259305).
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r4 i686)
Diffstat (limited to 'app-text/epstool')
-rw-r--r--app-text/epstool/ChangeLog6
-rw-r--r--app-text/epstool/epstool-3.08.ebuild12
-rw-r--r--app-text/epstool/files/gcc43.patch20
3 files changed, 35 insertions, 3 deletions
diff --git a/app-text/epstool/ChangeLog b/app-text/epstool/ChangeLog
index 11de2db939b8..e630078ffa23 100644
--- a/app-text/epstool/ChangeLog
+++ b/app-text/epstool/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/epstool
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/epstool/ChangeLog,v 1.24 2009/02/17 21:14:13 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/epstool/ChangeLog,v 1.25 2009/02/17 21:23:39 phosphan Exp $
+
+ 17 Feb 2009; Patrick Kursawe <phosphan@gentoo.org> +files/gcc43.patch,
+ epstool-3.08.ebuild:
+ Fix for gcc 4.3 and newer (bug #259305).
17 Feb 2009; Patrick Kursawe <phosphan@gentoo.org> -epstool-3.06.ebuild:
Removed obsolete version.
diff --git a/app-text/epstool/epstool-3.08.ebuild b/app-text/epstool/epstool-3.08.ebuild
index d169811760e8..cd1456f63c61 100644
--- a/app-text/epstool/epstool-3.08.ebuild
+++ b/app-text/epstool/epstool-3.08.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/epstool/epstool-3.08.ebuild,v 1.9 2008/01/22 19:16:47 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/epstool/epstool-3.08.ebuild,v 1.10 2009/02/17 21:23:39 phosphan Exp $
DESCRIPTION="Creates or extracts preview images in EPS files, fixes bounding boxes,converts to bitmaps."
HOMEPAGE="http://www.cs.wisc.edu/~ghost/gsview/epstool.htm"
@@ -12,6 +12,14 @@ IUSE=""
DEPEND="virtual/ghostscript
!=app-text/gsview-4.6"
+inherit eutils
+
+src_unpack() {
+ unpack ${A}
+ cd "${$}"
+ epatch "${FILESDIR}/gcc43.patch"
+}
+
src_compile() {
make epstool || die
}
diff --git a/app-text/epstool/files/gcc43.patch b/app-text/epstool/files/gcc43.patch
new file mode 100644
index 000000000000..398ce08c5182
--- /dev/null
+++ b/app-text/epstool/files/gcc43.patch
@@ -0,0 +1,20 @@
+--- epstool-3.08.orig/src/epstool.c 2005-06-10 04:41:00.000000000 -0500
++++ epstool-3.08/src/epstool.c 2009-02-16 20:55:43.186140029 -0600
+@@ -2824,7 +2824,7 @@
+ code = -1;
+ }
+ if ((code==0) && stdout_name && (hChildStdoutWr == -1)) {
+- handle = open(stdout_name, O_WRONLY | O_CREAT);
++ handle = open(stdout_name, O_WRONLY | O_CREAT, 0644);
+ hChildStdoutWr = dup2(handle, 1);
+ if (handle != -1)
+ close(handle);
+@@ -2832,7 +2832,7 @@
+ code = -1;
+ }
+ if ((code==0) && stderr_name && (hChildStderrWr == -1)) {
+- handle = open(stderr_name, O_WRONLY | O_CREAT);
++ handle = open(stderr_name, O_WRONLY | O_CREAT, 0644);
+ hChildStderrWr = dup2(handle, 2);
+ if (handle != -1)
+ close(handle);