summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-02 10:47:43 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-02 10:47:43 +0000
commitabc659e2c40572d106ca49ebc14b07a5d58b4431 (patch)
treef338d1fd51de3a88c7e5b2332e28004ee5e4cea3 /app-text/enscript
parentFix dodoc statement, bug 369763. Bump EAPI to 4. (diff)
downloadgentoo-2-abc659e2c40572d106ca49ebc14b07a5d58b4431.tar.gz
gentoo-2-abc659e2c40572d106ca49ebc14b07a5d58b4431.tar.bz2
gentoo-2-abc659e2c40572d106ca49ebc14b07a5d58b4431.zip
Add patch for php syntax highlighting, bug 244334
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'app-text/enscript')
-rw-r--r--app-text/enscript/ChangeLog10
-rw-r--r--app-text/enscript/enscript-1.6.5.2-r1.ebuild52
-rw-r--r--app-text/enscript/files/enscript-1.6.5.2-php.st.patch11
3 files changed, 71 insertions, 2 deletions
diff --git a/app-text/enscript/ChangeLog b/app-text/enscript/ChangeLog
index 206f38c6e4aa..f9dcd88bb1dd 100644
--- a/app-text/enscript/ChangeLog
+++ b/app-text/enscript/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/enscript
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/ChangeLog,v 1.60 2010/06/10 16:01:47 jer Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/ChangeLog,v 1.61 2011/06/02 10:47:43 dilfridge Exp $
+
+*enscript-1.6.5.2-r1 (02 Jun 2011)
+
+ 02 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +enscript-1.6.5.2-r1.ebuild, +files/enscript-1.6.5.2-php.st.patch:
+ Add patch for php syntax highlighting, bug 244334
*enscript-1.6.5.2 (10 Jun 2010)
diff --git a/app-text/enscript/enscript-1.6.5.2-r1.ebuild b/app-text/enscript/enscript-1.6.5.2-r1.ebuild
new file mode 100644
index 000000000000..8f8c37eceb4c
--- /dev/null
+++ b/app-text/enscript/enscript-1.6.5.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/enscript-1.6.5.2-r1.ebuild,v 1.1 2011/06/02 10:47:43 dilfridge Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="powerful text-to-postscript converter"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/enscript/enscript.html"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-3"
+IUSE="nls ruby"
+
+DEPEND="
+ sys-devel/flex
+ sys-devel/bison
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="nls? ( virtual/libintl )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/enscript-1.6.3-language.patch
+ epatch "${FILESDIR}"/enscript-1.6.4-ebuild.st.patch
+ epatch "${FILESDIR}"/enscript-1.6.5.2-php.st.patch
+ use ruby && epatch "${FILESDIR}"/enscript-1.6.2-ruby.patch
+}
+
+src_configure() {
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO || die "dodoc failed"
+
+ insinto /usr/share/enscript/hl
+ doins "${FILESDIR}"/ebuild.st || die "doins ebuild.st failed"
+
+ if use ruby ; then
+ insinto /usr/share/enscript/hl
+ doins "${FILESDIR}"/ruby.st || die "doins ruby.st failed"
+ fi
+}
+
+pkg_postinst() {
+ elog "Now, customize /etc/enscript.cfg."
+}
diff --git a/app-text/enscript/files/enscript-1.6.5.2-php.st.patch b/app-text/enscript/files/enscript-1.6.5.2-php.st.patch
new file mode 100644
index 000000000000..b146d998ee41
--- /dev/null
+++ b/app-text/enscript/files/enscript-1.6.5.2-php.st.patch
@@ -0,0 +1,11 @@
+diff -ruN enscript-1.6.5.2.orig/states/hl/enscript.st enscript-1.6.5.2/states/hl/enscript.st
+--- enscript-1.6.5.2.orig/states/hl/enscript.st 2010-06-02 00:17:49.000000000 +0200
++++ enscript-1.6.5.2/states/hl/enscript.st 2011-06-02 12:43:13.869855504 +0200
+@@ -510,6 +510,7 @@
+ /\.tex$/ tex;
+ /\.wmlscript$/ wmlscript;
+ /\.wmls$/ wmlscript;
++ /\.php$/ php;
+ /^.*$/ passthrough;
+ }
+