summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2012-01-31 06:17:38 +0000
committerLars Wendler <polynomial-c@gentoo.org>2012-01-31 06:17:38 +0000
commit59c13ac8a29879f8ba96478458e838afd0d20847 (patch)
tree394f3beaec47aca4d2dbc48217647c6d1bcb6989 /app-text/dos2unix
parentVersion bump. Masked as it's an alpha. Also EAPI bumped. (diff)
downloadgentoo-2-59c13ac8a29879f8ba96478458e838afd0d20847.tar.gz
gentoo-2-59c13ac8a29879f8ba96478458e838afd0d20847.tar.bz2
gentoo-2-59c13ac8a29879f8ba96478458e838afd0d20847.zip
Version bump. Removed old. Fixed debug build with patch from upstream (bug #400769)
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/ChangeLog10
-rw-r--r--app-text/dos2unix/dos2unix-5.3.1.ebuild4
-rw-r--r--app-text/dos2unix/dos2unix-5.3.2.ebuild (renamed from app-text/dos2unix/dos2unix-5.3.ebuild)14
-rw-r--r--app-text/dos2unix/files/dos2unix-5.3.1-fix_debug_build.patch46
-rw-r--r--app-text/dos2unix/files/dos2unix-5.3.2-fix_debug_build.patch54
5 files changed, 119 insertions, 9 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index a64c91c719cd..21bd30c853f3 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-text/dos2unix
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.75 2012/01/24 09:50:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.76 2012/01/31 06:17:38 polynomial-c Exp $
+
+*dos2unix-5.3.2 (31 Jan 2012)
+
+ 31 Jan 2012; Lars Wendler <polynomial-c@gentoo.org> -dos2unix-5.3.ebuild,
+ dos2unix-5.3.1.ebuild, +files/dos2unix-5.3.1-fix_debug_build.patch,
+ +dos2unix-5.3.2.ebuild, +files/dos2unix-5.3.2-fix_debug_build.patch:
+ non-maintainer commit: Version bump. Removed old. Fixed debug build with
+ patch from upstream (bug #400769).
24 Jan 2012; Justin Lecher <jlec@gentoo.org> dos2unix-5.3.1.ebuild:
EAPI BUMP to 4
diff --git a/app-text/dos2unix/dos2unix-5.3.1.ebuild b/app-text/dos2unix/dos2unix-5.3.1.ebuild
index 65943187fc9a..906366496346 100644
--- a/app-text/dos2unix/dos2unix-5.3.1.ebuild
+++ b/app-text/dos2unix/dos2unix-5.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.3.1.ebuild,v 1.2 2012/01/24 09:50:28 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.3.1.ebuild,v 1.3 2012/01/31 06:17:38 polynomial-c Exp $
EAPI=4
@@ -26,6 +26,8 @@ DEPEND="
dev-lang/perl"
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.3.1-fix_debug_build.patch
+
sed \
-e '/^LDFLAGS/s|=|+=|' \
-e '/^CC/s|=|?=|' \
diff --git a/app-text/dos2unix/dos2unix-5.3.ebuild b/app-text/dos2unix/dos2unix-5.3.2.ebuild
index b29e42b86bcf..65ba7251fc1f 100644
--- a/app-text/dos2unix/dos2unix-5.3.ebuild
+++ b/app-text/dos2unix/dos2unix-5.3.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.3.ebuild,v 1.1 2011/04/26 23:10:48 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-5.3.2.ebuild,v 1.1 2012/01/31 06:17:38 polynomial-c Exp $
-EAPI="3"
+EAPI=4
inherit eutils toolchain-funcs
@@ -26,6 +26,8 @@ DEPEND="
dev-lang/perl"
src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.3.2-fix_debug_build.patch
+
sed \
-e '/^LDFLAGS/s|=|+=|' \
-e '/^CC/s|=|?=|' \
@@ -44,12 +46,10 @@ lintl() {
src_compile() {
emake prefix="${EPREFIX}/usr" \
- $(use nls && echo "LDFLAGS_EXTRA=$(lintl)" || echo "ENABLE_NLS=") \
- || die
+ $(use nls && echo "LDFLAGS_EXTRA=$(lintl)" || echo "ENABLE_NLS=")
}
src_install() {
emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
- $(use nls || echo "ENABLE_NLS=") install \
- || die "emake install failed"
+ $(use nls || echo "ENABLE_NLS=") install
}
diff --git a/app-text/dos2unix/files/dos2unix-5.3.1-fix_debug_build.patch b/app-text/dos2unix/files/dos2unix-5.3.1-fix_debug_build.patch
new file mode 100644
index 000000000000..32e3caa66a24
--- /dev/null
+++ b/app-text/dos2unix/files/dos2unix-5.3.1-fix_debug_build.patch
@@ -0,0 +1,46 @@
+--- dos2unix-5.3.1/dos2unix.c
++++ dos2unix-5.3.1/dos2unix.c
+@@ -60,8 +60,6 @@
+ */
+
+
+-#define VER_AUTHOR "Erwin Waterlander"
+-
+ /* #define DEBUG 1 */
+
+ #include "common.h"
+--- dos2unix-5.3.1/Makefile
++++ dos2unix-5.3.1/Makefile
+@@ -194,9 +194,14 @@
+
+ EXTRA_CFLAGS = -DVER_REVISION=\"$(DOS2UNIX_VERSION)\" \
+ -DVER_DATE=\"$(DOS2UNIX_DATE)\" \
++ -DVER_AUTHOR=\"$(DOS2UNIX_AUTHOR)\" \
+ -DDEBUG=$(DEBUG) \
+ $(CFLAGS_OS)
+
++ifeq ($(DEBUG), 1)
++ EXTRA_CFLAGS += -g
++endif
++
+ ifdef STATIC
+ EXTRA_CFLAGS += -static
+ endif
+--- dos2unix-5.3.1/unix2dos.c
++++ dos2unix-5.3.1/unix2dos.c
+@@ -50,8 +50,6 @@
+ */
+
+
+-#define VER_AUTHOR "Erwin Waterlander"
+-
+ /* #define DEBUG 1 */
+
+ #include "common.h"
+--- dos2unix-5.3.1/version.mk
++++ dos2unix-5.3.1/version.mk
+@@ -1,3 +1,4 @@
+ DOS2UNIX_VERSION = 5.3.1
+ DOS2UNIX_VERSION_SHORT = 531
+ DOS2UNIX_DATE = 2011-08-09
++DOS2UNIX_AUTHOR = 'Erwin Waterlander'
diff --git a/app-text/dos2unix/files/dos2unix-5.3.2-fix_debug_build.patch b/app-text/dos2unix/files/dos2unix-5.3.2-fix_debug_build.patch
new file mode 100644
index 000000000000..123bfcc62c2e
--- /dev/null
+++ b/app-text/dos2unix/files/dos2unix-5.3.2-fix_debug_build.patch
@@ -0,0 +1,54 @@
+Index: Makefile
+===================================================================
+--- Makefile (revision 349)
++++ Makefile (working copy)
+@@ -204,9 +204,14 @@
+
+ EXTRA_CFLAGS = -DVER_REVISION=\"$(DOS2UNIX_VERSION)\" \
+ -DVER_DATE=\"$(DOS2UNIX_DATE)\" \
++ -DVER_AUTHOR=\"$(DOS2UNIX_AUTHOR)\" \
+ -DDEBUG=$(DEBUG) \
+ $(CFLAGS_OS)
+
++ifeq ($(DEBUG), 1)
++ EXTRA_CFLAGS += -g
++endif
++
+ ifdef STATIC
+ EXTRA_CFLAGS += -static
+ endif
+Index: dos2unix.c
+===================================================================
+--- dos2unix.c (revision 347)
++++ dos2unix.c (working copy)
+@@ -60,8 +60,6 @@
+ */
+
+
+-#define VER_AUTHOR "Erwin Waterlander"
+-
+ /* #define DEBUG 1 */
+
+ #include "common.h"
+Index: unix2dos.c
+===================================================================
+--- unix2dos.c (revision 347)
++++ unix2dos.c (working copy)
+@@ -50,8 +50,6 @@
+ */
+
+
+-#define VER_AUTHOR "Erwin Waterlander"
+-
+ /* #define DEBUG 1 */
+
+ #include "common.h"
+Index: version.mk
+===================================================================
+--- version.mk (revision 347)
++++ version.mk (working copy)
+@@ -1,3 +1,4 @@
+ DOS2UNIX_VERSION = 5.3.2
+ DOS2UNIX_VERSION_SHORT = 532
+ DOS2UNIX_DATE = 2012-01-27
++DOS2UNIX_AUTHOR = 'Erwin Waterlander'