summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-05 03:08:54 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-05 03:08:54 +0000
commit0a7c7a601df9979df80d7790ba46f0e000938ed6 (patch)
treec0068dcc282f01d2d69e4cbcea65754502afd50d /app-text/djvu/djvu-3.5.22.ebuild
parentUpdate vdpau dependency #299398 by Fabio Erculiani. (diff)
downloadgentoo-2-0a7c7a601df9979df80d7790ba46f0e000938ed6.tar.gz
gentoo-2-0a7c7a601df9979df80d7790ba46f0e000938ed6.tar.bz2
gentoo-2-0a7c7a601df9979df80d7790ba46f0e000938ed6.zip
Drop Qt3 support, bug 283429. Use app-text/djview4 instead of old bundled djview, bug 298293.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'app-text/djvu/djvu-3.5.22.ebuild')
-rw-r--r--app-text/djvu/djvu-3.5.22.ebuild43
1 files changed, 11 insertions, 32 deletions
diff --git a/app-text/djvu/djvu-3.5.22.ebuild b/app-text/djvu/djvu-3.5.22.ebuild
index a6215e2e5fc5..04b122d35e58 100644
--- a/app-text/djvu/djvu-3.5.22.ebuild
+++ b/app-text/djvu/djvu-3.5.22.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.22.ebuild,v 1.2 2009/10/28 09:50:48 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/djvu/djvu-3.5.22.ebuild,v 1.3 2010/01/05 03:08:54 yngwin Exp $
EAPI=1
-inherit fdo-mime nsplugins flag-o-matic eutils multilib toolchain-funcs confutils
+inherit fdo-mime flag-o-matic eutils multilib toolchain-funcs
MY_P="${PN}libre-${PV#*_p}"
-DESCRIPTION="DjVu viewers, encoders and utilities."
+DESCRIPTION="DjVu viewers, encoders and utilities"
HOMEPAGE="http://djvu.sourceforge.net"
SRC_URI="mirror://sourceforge/djvu/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="xml qt3 jpeg tiff debug nls nsplugin kde doc"
+IUSE="xml jpeg tiff debug nls kde doc"
RDEPEND="jpeg? ( >=media-libs/jpeg-6b-r2 )
- tiff? ( media-libs/tiff )
- qt3? ( x11-libs/qt:3 )"
-DEPEND="${RDEPEND}
- qt3? ( nsplugin? ( x11-libs/libXt ) )"
+ tiff? ( media-libs/tiff )"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
@@ -29,17 +27,6 @@ for X in ${LANGS}; do
IUSE="${IUSE} linguas_${X}"
done
-pkg_setup() {
- if ! use qt3; then
- ewarn
- ewarn "The standalone djvu viewer, djview, will not be compiled."
- ewarn "Add \"qt3\" to your USE flags if you want it."
- ewarn
- fi
-
- confutils_use_depend_all nsplugin qt3
-}
-
src_compile() {
local I18N
if use nls; then
@@ -58,19 +45,16 @@ src_compile() {
I18N="--disable-i18n"
fi
- # We install all desktop files by hand.
+ # We install all desktop files by hand and Qt3 is deprecated
econf --disable-desktopfiles \
- $(use_with qt3 qt) \
+ --without- qt \
$(use_enable xml xmltools) \
$(use_with jpeg) \
$(use_with tiff) \
"${I18N}" \
- $(use_enable debug) \
- ${QTCONF}
+ $(use_enable debug)
- if ! use nsplugin; then
- sed -e 's:nsdejavu::' -i "${S}"/gui/Makefile || die
- fi
+ sed -e 's:nsdejavu::' -i "${S}"/gui/Makefile || die
emake || die "emake failed"
}
@@ -93,11 +77,6 @@ src_install() {
cp "${D}"/usr/share/mimelnk/image/{vnd.djvu.desktop,x-djvu.desktop}
sed -i -e 's:image/vnd.djvu:image/x-djvu:' "${D}"/usr/share/mimelnk/image/x-djvu.desktop
fi
-
- if use qt3 ; then
- insinto /usr/share/icons/hicolor/32x32/apps && newins hi32-djview3.png djvulibre-djview3.png || die
- insinto /usr/share/applications/ && doins djvulibre-djview3.desktop || die
- fi
}
pkg_postinst() {