summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-10-09 15:31:07 +0000
committerMichael Januszewski <spock@gentoo.org>2008-10-09 15:31:07 +0000
commitc8ddff0ba55eee079e6540ce22fe85ff2c2a0324 (patch)
tree80b86324fb94eea6244d1eb88d9a1e57de431b67 /app-text/clara
parentSet CFLAGS in src_compile instead of src_unpack. (diff)
downloadgentoo-2-c8ddff0ba55eee079e6540ce22fe85ff2c2a0324.tar.gz
gentoo-2-c8ddff0ba55eee079e6540ce22fe85ff2c2a0324.tar.bz2
gentoo-2-c8ddff0ba55eee079e6540ce22fe85ff2c2a0324.zip
Respect both user's CFLAGS and LDFLAGS.
(Portage version: 2.2_rc11/cvs/Linux 2.6.27-rc8 x86_64)
Diffstat (limited to 'app-text/clara')
-rw-r--r--app-text/clara/ChangeLog5
-rw-r--r--app-text/clara/clara-20031214.ebuild9
2 files changed, 11 insertions, 3 deletions
diff --git a/app-text/clara/ChangeLog b/app-text/clara/ChangeLog
index 988fda38e279..2f391470ae39 100644
--- a/app-text/clara/ChangeLog
+++ b/app-text/clara/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/clara
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/clara/ChangeLog,v 1.16 2008/10/09 15:21:53 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/clara/ChangeLog,v 1.17 2008/10/09 15:31:07 spock Exp $
+
+ 09 Oct 2008; Michał Januszewski <spock@gentoo.org> clara-20031214.ebuild:
+ Respect both user's CFLAGS and LDFLAGS.
09 Oct 2008; Michał Januszewski <spock@gentoo.org> clara-20031214.ebuild:
Set CFLAGS in src_compile instead of src_unpack.
diff --git a/app-text/clara/clara-20031214.ebuild b/app-text/clara/clara-20031214.ebuild
index 0909558f0979..19a2cb8d9669 100644
--- a/app-text/clara/clara-20031214.ebuild
+++ b/app-text/clara/clara-20031214.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/clara/clara-20031214.ebuild,v 1.18 2008/10/09 15:21:53 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/clara/clara-20031214.ebuild,v 1.19 2008/10/09 15:31:07 spock Exp $
DESCRIPTION="An OCR (Optical Character Recognition) program"
SRC_URI="http://www.geocities.com/claraocr/clara-20031214.tar.gz"
@@ -13,8 +13,13 @@ IUSE=""
DEPEND="x11-libs/libX11"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -re "s/(C|LD)FLAGS =/\1FLAGS +=/" Makefile
+}
+
src_compile() {
- sed -i -e "s/CFLAGS = \(.*\)/CFLAGS = ${CFLAGS} \1/" Makefile
emake || die
emake doc || die
}