summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-09-15 10:26:22 +0000
committerFabian Groffen <grobian@gentoo.org>2010-09-15 10:26:22 +0000
commita919b470a82a5aac59367ef3c38ff50dfaca9c2e (patch)
tree8b75156aff31711d434a52d62fa29faa62bfc804 /app-text/catdoc/catdoc-0.94.2-r2.ebuild
parentHonour Gentoo LDFLAGS, rationalizing Makefile - see bug #337411. (diff)
downloadgentoo-2-a919b470a82a5aac59367ef3c38ff50dfaca9c2e.tar.gz
gentoo-2-a919b470a82a5aac59367ef3c38ff50dfaca9c2e.tar.bz2
gentoo-2-a919b470a82a5aac59367ef3c38ff50dfaca9c2e.zip
Make ebuild completely Prefix aware (instead of half), fix wordview logic (inverted) and configure argument, marked ~x86-solaris
(Portage version: 2.2.01.15553-prefix/cvs/SunOS i386)
Diffstat (limited to 'app-text/catdoc/catdoc-0.94.2-r2.ebuild')
-rw-r--r--app-text/catdoc/catdoc-0.94.2-r2.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/app-text/catdoc/catdoc-0.94.2-r2.ebuild b/app-text/catdoc/catdoc-0.94.2-r2.ebuild
index 843b1b62d7ed..74378129fe94 100644
--- a/app-text/catdoc/catdoc-0.94.2-r2.ebuild
+++ b/app-text/catdoc/catdoc-0.94.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/catdoc/catdoc-0.94.2-r2.ebuild,v 1.1 2010/05/03 21:43:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/catdoc/catdoc-0.94.2-r2.ebuild,v 1.2 2010/09/15 10:26:22 grobian Exp $
EAPI=3
WANT_AUTOMAKE=none
@@ -14,7 +14,7 @@ LICENSE="GPL-2"
IUSE="tk"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-solaris"
DEPEND="tk? ( >=dev-lang/tk-8.1 )"
@@ -33,19 +33,19 @@ src_prepare() {
src_configure() {
econf --with-install-root="${D}" \
$(use_with tk wish "${EPREFIX}"/usr/bin/wish) \
- $(use_with !tk wordview)
+ $(use_enable tk wordview)
}
src_compile() {
- emake LIB_DIR=/usr/share/catdoc || die
+ emake LIB_DIR="${EPREFIX}"/usr/share/catdoc || die
}
src_install() {
emake -j1 mandir="${EPREFIX}"/usr/share/man/man1 install || die
- if [[ -e ${D}/usr/bin/xls2csv ]]; then
+ if [[ -e ${ED}/usr/bin/xls2csv ]]; then
einfo "Renaming xls2csv to xls2csv-${PN} because of bug 314657."
- mv -vf "${D}"/usr/bin/xls2csv "${D}"/usr/bin/xls2csv-${PN} || die
+ mv -vf "${ED}"/usr/bin/xls2csv "${ED}"/usr/bin/xls2csv-${PN} || die
fi
dodoc ${DOCS}