summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-04-28 09:14:35 +0000
committerJustin Lecher <jlec@gentoo.org>2012-04-28 09:14:35 +0000
commitd591388ebec38eb73edf13beaa8c8b24cccf4ec3 (patch)
tree9eddb54f0ce18fb5bc1f306652914b3f61f58a39 /app-text/bibus
parentRemove mask on app-text/bibus, noreason for that, #408247 (diff)
downloadgentoo-2-d591388ebec38eb73edf13beaa8c8b24cccf4ec3.tar.gz
gentoo-2-d591388ebec38eb73edf13beaa8c8b24cccf4ec3.tar.bz2
gentoo-2-d591388ebec38eb73edf13beaa8c8b24cccf4ec3.zip
app-text/bibus: Version Bump including detection of libreoffice, #394537 thanks Bjoern Olausson; multi py ABI installation
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'app-text/bibus')
-rw-r--r--app-text/bibus/ChangeLog11
-rw-r--r--app-text/bibus/bibus-1.5.1.ebuild20
-rw-r--r--app-text/bibus/bibus-1.5.2.ebuild82
-rw-r--r--app-text/bibus/files/bibus-1.5.2-install.patch110
-rw-r--r--app-text/bibus/metadata.xml2
5 files changed, 214 insertions, 11 deletions
diff --git a/app-text/bibus/ChangeLog b/app-text/bibus/ChangeLog
index 69d87c6498ee..2c6997774d66 100644
--- a/app-text/bibus/ChangeLog
+++ b/app-text/bibus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/bibus
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibus/ChangeLog,v 1.32 2011/07/07 07:30:09 hwoarang Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibus/ChangeLog,v 1.33 2012/04/28 09:14:35 jlec Exp $
+
+*bibus-1.5.2 (28 Apr 2012)
+
+ 28 Apr 2012; Justin Lecher <jlec@gentoo.org> bibus-1.5.1.ebuild,
+ +bibus-1.5.2.ebuild, +files/bibus-1.5.2-install.patch, metadata.xml:
+ Version Bump including detection of libreoffice, #394537 thanks Bjoern
+ Olausson; multi py ABI installation
07 Jul 2011; Markos Chandras <hwoarang@gentoo.org>
-files/bibus-1.4.3.1-install.patch:
diff --git a/app-text/bibus/bibus-1.5.1.ebuild b/app-text/bibus/bibus-1.5.1.ebuild
index 1c6457a06913..308a2c842547 100644
--- a/app-text/bibus/bibus-1.5.1.ebuild
+++ b/app-text/bibus/bibus-1.5.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibus/bibus-1.5.1.ebuild,v 1.8 2011/06/28 20:02:03 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibus/bibus-1.5.1.ebuild,v 1.9 2012/04/28 09:14:35 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -18,16 +18,18 @@ IUSE="mysql"
# Most of this mess is designed to give the choice of sqlite or mysql
# but prefer sqlite. We also need to default to sqlite if neither is requested.
+# Cannot depend on virtual/ooo
# bibus fails to start with app-office/openoffice-bin (bug #288232).
-RDEPEND="|| ( app-office/libreoffice app-office/openoffice )
+RDEPEND="
+ || ( app-office/libreoffice app-office/openoffice )
=dev-python/wxpython-2.8*
dev-python/pysqlite
dev-db/sqliteodbc
+ dev-db/unixODBC
mysql? (
dev-python/mysql-python
dev-db/myodbc
- )
- dev-db/unixODBC"
+ )"
DEPEND="${RDEPEND}"
pkg_setup() {
@@ -36,9 +38,11 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.5.0-install.patch
- epatch "${FILESDIR}"/${PN}-1.5.0-pysqlite.patch
- sed -e "s:gentoo-python:python$(python_get_version):g" \
+ epatch \
+ "${FILESDIR}"/${PN}-1.5.0-install.patch \
+ "${FILESDIR}"/${PN}-1.5.0-pysqlite.patch
+ sed \
+ -e "s:gentoo-python:python$(python_get_version):g" \
-i Makefile Setup/Makefile Setup/bibus.cfg Setup/bibus.sh \
|| die "Failed to adjust python paths"
diff --git a/app-text/bibus/bibus-1.5.2.ebuild b/app-text/bibus/bibus-1.5.2.ebuild
new file mode 100644
index 000000000000..1a3ec3f14885
--- /dev/null
+++ b/app-text/bibus/bibus-1.5.2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibus/bibus-1.5.2.ebuild,v 1.1 2012/04/28 09:14:35 jlec Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-pypy-*"
+
+inherit eutils fdo-mime multilib python versionator
+
+DESCRIPTION="Bibliographic and reference management software, integrates with L/OO.o and MS Word"
+HOMEPAGE="http://bibus-biblio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}-biblio/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql"
+
+# Most of this mess is designed to give the choice of sqlite or mysql
+# but prefer sqlite. We also need to default to sqlite if neither is requested.
+# Cannot depend on virtual/ooo
+# bibus fails to start with app-office/openoffice-bin (bug #288232).
+RDEPEND="
+ || ( app-office/libreoffice app-office/openoffice )
+ =dev-python/wxpython-2.8*
+ dev-python/pysqlite
+ dev-db/sqliteodbc
+ dev-db/unixODBC
+ mysql? (
+ dev-python/mysql-python
+ dev-db/myodbc
+ )"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ python_pkg_setup
+ if [[ -d "/usr/$(get_libdir)/openoffice" ]] ; then
+ OFFICESUITE="/usr/$(get_libdir)/openoffice"
+ else
+ OFFICESUITE="/usr/$(get_libdir)/libreoffice"
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-install.patch \
+ "${FILESDIR}"/${PN}-1.5.0-pysqlite.patch
+}
+
+src_compile() { :; }
+
+src_install() {
+ einfo "Installing for ${OFFICESUITE}"
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ prefix="${EPREFIX}/usr" \
+ oopath="${OFFICESUITE}/program" \
+ ooure="${OFFICESUITE}/ure-link/lib" \
+ oobasis="${OFFICESUITE}/program" \
+ sysconfdir="${EPREFIX}/etc" \
+ pythondir="$(python_get_sitedir)" \
+ python=$(PYTHON -a) \
+ install install-doc-en
+ }
+ python_execute_function installation
+}
+
+pkg_postinst() {
+ python_mod_optimize bibus
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
+
+pkg_postrm() {
+ python_mod_cleanup bibus
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/app-text/bibus/files/bibus-1.5.2-install.patch b/app-text/bibus/files/bibus-1.5.2-install.patch
new file mode 100644
index 000000000000..5225fcd6c3d8
--- /dev/null
+++ b/app-text/bibus/files/bibus-1.5.2-install.patch
@@ -0,0 +1,110 @@
+ Makefile | 62 ++++++++++++++++++++++++--------------------------------------
+ 1 files changed, 24 insertions(+), 38 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d41b12d..b07cdff 100755
+--- a/Makefile
++++ b/Makefile
+@@ -14,62 +14,60 @@ mandir = $(prefix)/share/man
+ man1dir = $(mandir)/man1
+
+ define install-files
+- install -d $(datadir)/bibus
+- install -m644 *.py MySQL_Bibus.ini $(datadir)/bibus/
++ install -d $(DESTDIR)$(pythondir)/bibus
++ install -m644 *.py MySQL_Bibus.ini $(DESTDIR)/$(pythondir)/bibus/
+ #
+ for dir in Export Format Import StyleEditor FirstStart bibOOo db_models Pixmaps Data LyX Utilities; do \
+- find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(datadir)/bibus/'{}' ';' ; \
++ find $$dir ! -wholename '*CVS*' -a -type f -exec install -m644 '{}' -D $(DESTDIR)/$(pythondir)/bibus/'{}' ';' ; \
+ done
+- install -m644 Setup/UnoConnectionListener.odg -D $(datadir)/bibus/Setup/UnoConnectionListener.odg
++ install -m644 Setup/UnoConnectionListener.odg -D $(DESTDIR)/$(datadir)/bibus/Setup/UnoConnectionListener.odg
+ # locale files. We look for all the directory in locale/
+ for dir in $(wildcard locale/*); do \
+ if [ -d $$dir ] && [ $$dir != "locale/CVS" ]; then \
+- install -m644 $$dir/LC_MESSAGES/bibus.mo -D $(datadir)/$$dir/LC_MESSAGES/bibus.mo ; \
++ install -m644 $$dir/LC_MESSAGES/bibus.mo -D $(DESTDIR)/$(datadir)/$$dir/LC_MESSAGES/bibus.mo ; \
+ fi; \
+ done
+ # bibus.config in /etc
+- install -m644 bibus.config -D $(sysconfdir)/bibus.config
++ install -m644 bibus.config -D $(DESTDIR)/$(sysconfdir)/bibus.config
+ # man page
+- install -m644 Setup/bibus.1 -D $(man1dir)/bibus.1
++ install -m644 Setup/bibus.1 -D $(DESTDIR)/$(man1dir)/bibus.1
+
+ # freedesktop icon and shortcut
+- install -m644 Pixmaps/bibus.png -D $(datadir)/icons/hicolor/48x48/apps/bibus.png
+- install -m644 Setup/bibus.desktop -D $(datadir)/applications/bibus.desktop
++ install -m644 Pixmaps/bibus.png -D $(DESTDIR)$(datadir)/pixmaps/bibus.png
++ install -m644 Setup/bibus.desktop -D $(DESTDIR)/$(datadir)/applications/bibus.desktop
+ # The following lines are presumably not needed since icons/desktop are in standard locations
+ #echo 'Exec=$(bindir)/bibus' >> $(datadir)/applications/bibus.desktop
+ #echo 'Icon=$(datadir)/icons/hicolor/48x48/apps/bibus.png' >> $(datadir)/applications/bibus.desktop
+
+ # bibus command
+- install -d $(bindir)
+- ln -sf $(datadir)/bibus/bibusStart.py $(bindir)/bibus
+- chmod 755 $(datadir)/bibus/bibusStart.py
++ install -d $(DESTDIR)/$(bindir)
++ ln -sf $(pythondir)/bibus/bibusStart.py $(DESTDIR)/$(bindir)/bibus
++ chmod 755 $(DESTDIR)$(pythondir)/bibus/bibusStart.py
+
+ # basic doc files
+- install -m755 -d $(datadir)/doc/bibus
+- install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(datadir)/doc/bibus
++ install -m755 -d $(DESTDIR)/$(datadir)/doc/${PF}
++ install -m644 Docs/*.txt Docs/CHANGELOG Docs/copying $(DESTDIR)/$(datadir)/doc/${PF}
+
+ # generating bibus.cfg file
+- echo '[PATH]' > $(datadir)/bibus/bibus.cfg
+- echo 'python = $(python)' >> $(datadir)/bibus/bibus.cfg
+- echo 'oopath = $(oopath)' >> $(datadir)/bibus/bibus.cfg
+- echo 'ooure = $(ooure)' >> $(datadir)/bibus/bibus.cfg
+- echo 'oobasis = $(oobasis)' >> $(datadir)/bibus/bibus.cfg
+- echo 'docdir = $(datadir)/doc/bibus/html' >> $(datadir)/bibus/bibus.cfg
+- echo 'licence = $(datadir)/doc/bibus/copying' >> $(datadir)/bibus/bibus.cfg
+- echo 'localedir = $(datadir)/locale' >> $(datadir)/bibus/bibus.cfg
+- echo 'systemconf = $(sysconfdir)/bibus.config' >> $(datadir)/bibus/bibus.cfg
++ echo '[PATH]' > $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'python = $(python)' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'oopath = $(oopath)' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'ooure = $(ooure)' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'oobasis = $(oobasis)' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'docdir = $(datadir)/doc/${PF}/html' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'localedir = $(datadir)/locale' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
++ echo 'systemconf = $(sysconfdir)/bibus.config' >> $(DESTDIR)/$(pythondir)/bibus/bibus.cfg
+ endef
+
+ define install-doc-en
+ # copying docs in from Docs/html/en/ for bibus-doc-en
+ cd Docs;\
+- find html/en/* -type f -exec install -m644 '{}' -D $(datadir)/doc/bibus/'{}' ';'
++ find html/en/* -type f -exec install -m644 '{}' -D $(DESTDIR)/$(datadir)/doc/${PF}/'{}' ';'
+ endef
+
+ define compile
+ # compile recursively all the python files located in $(datadir)/bibus
+- $(python) -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
+- $(python) -O -c "import compileall ; compileall.compile_dir('$(datadir)/bibus')"
++ echo "No compilation"
+ endef
+
+ install-files:
+@@ -83,15 +81,3 @@ install:
+ $(install-doc-en)
+ $(compile)
+
+- # write uninstaller in $(datadir)/bibus/Setup/uninstall.sh
+- echo "#!/bin/sh" > $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm -rf $(datadir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(bindir)/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "find $(datadir)/locale -name bibus.mo -exec rm -f {} \;" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(sysconfdir)/bibus.config" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(man1dir)/bibus.1" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm -rf $(datadir)/doc/bibus" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(datadir)/applications/bibus.desktop" >> $(datadir)/bibus/Setup/uninstall.sh
+- echo "rm $(datadir)/icons/hicolor/48x48/apps/bibus.png" >> $(datadir)/bibus/Setup/uninstall.sh
+- chmod 744 $(datadir)/bibus/Setup/uninstall.sh
+- # end uninstaller
diff --git a/app-text/bibus/metadata.xml b/app-text/bibus/metadata.xml
index b229aec85b8f..d369d068ffb8 100644
--- a/app-text/bibus/metadata.xml
+++ b/app-text/bibus/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
+ <herd>sci</herd>
</pkgmetadata>