summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 21:12:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-04 21:12:12 +0000
commitb57652dad8b19832127768182a3d5cabc3fa8ebf (patch)
treed6abb92d554a2502bdbd6be2967e2cf275727e24 /app-text/bibus
parentx86 stable, bug #314899 (diff)
downloadgentoo-2-b57652dad8b19832127768182a3d5cabc3fa8ebf.tar.gz
gentoo-2-b57652dad8b19832127768182a3d5cabc3fa8ebf.tar.bz2
gentoo-2-b57652dad8b19832127768182a3d5cabc3fa8ebf.zip
Use Python 2.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'app-text/bibus')
-rw-r--r--app-text/bibus/ChangeLog6
-rw-r--r--app-text/bibus/bibus-1.5.0.ebuild18
2 files changed, 18 insertions, 6 deletions
diff --git a/app-text/bibus/ChangeLog b/app-text/bibus/ChangeLog
index eb61d3f1aa8e..90d0af10305f 100644
--- a/app-text/bibus/ChangeLog
+++ b/app-text/bibus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/bibus
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibus/ChangeLog,v 1.19 2010/06/04 20:56:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibus/ChangeLog,v 1.20 2010/06/04 21:12:12 arfrever Exp $
+
+ 04 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ bibus-1.5.0.ebuild:
+ Use Python 2.
04 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
bibus-1.4.3.2-r1.ebuild, bibus-1.5.0.ebuild:
diff --git a/app-text/bibus/bibus-1.5.0.ebuild b/app-text/bibus/bibus-1.5.0.ebuild
index 2c22eacd1474..df6bbfd1f853 100644
--- a/app-text/bibus/bibus-1.5.0.ebuild
+++ b/app-text/bibus/bibus-1.5.0.ebuild
@@ -1,18 +1,21 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bibus/bibus-1.5.0.ebuild,v 1.3 2010/06/04 20:56:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bibus/bibus-1.5.0.ebuild,v 1.4 2010/06/04 21:12:12 arfrever Exp $
-EAPI="2"
+EAPI="3"
+PYTHON_DEPEND="2"
-inherit python multilib eutils versionator
+inherit multilib eutils python versionator
DESCRIPTION="Bibliographic and reference management software, integrates with OO.o and MS Word"
HOMEPAGE="http://bibus-biblio.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}-biblio/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="mysql"
+
# Most of this mess is designed to give the choice of sqlite or mysql
# but prefer sqlite. We also need to default to sqlite if neither is requested.
RDEPEND="virtual/ooo
@@ -26,6 +29,11 @@ RDEPEND="virtual/ooo
dev-db/unixODBC"
DEPEND="${RDEPEND}"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
epatch "${FILESDIR}"/${P}-install.patch
epatch "${FILESDIR}"/${P}-pysqlite.patch
@@ -50,9 +58,9 @@ src_install() {
}
pkg_postinst() {
- python_mod_optimize $(python_get_sitedir)/bibus
+ python_mod_optimize bibus
}
pkg_postrm() {
- python_mod_cleanup $(python_get_sitedir)/bibus
+ python_mod_cleanup bibus
}