summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-03-17 13:20:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-03-17 13:20:05 +0000
commita46ea17b18892253f9e433a769a910a23bfc8ed1 (patch)
treea2691763e230a6549e8cb0acfa67dcf4336dfc2d /app-text/apvlv
parentamd64/x86 stable (diff)
downloadgentoo-2-a46ea17b18892253f9e433a769a910a23bfc8ed1.tar.gz
gentoo-2-a46ea17b18892253f9e433a769a910a23bfc8ed1.tar.bz2
gentoo-2-a46ea17b18892253f9e433a769a910a23bfc8ed1.zip
old
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'app-text/apvlv')
-rw-r--r--app-text/apvlv/ChangeLog7
-rw-r--r--app-text/apvlv/apvlv-0.1.2-r1.ebuild57
-rw-r--r--app-text/apvlv/files/apvlv-0.1.0-poppler-0.16.patch11
-rw-r--r--app-text/apvlv/files/apvlv-0.1.2-poppler-0.18.patch151
4 files changed, 6 insertions, 220 deletions
diff --git a/app-text/apvlv/ChangeLog b/app-text/apvlv/ChangeLog
index 33e246165e13..27f2bf49318b 100644
--- a/app-text/apvlv/ChangeLog
+++ b/app-text/apvlv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/apvlv
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/apvlv/ChangeLog,v 1.23 2013/03/17 13:19:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/apvlv/ChangeLog,v 1.24 2013/03/17 13:20:04 ssuominen Exp $
+
+ 17 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
+ -files/apvlv-0.1.0-poppler-0.16.patch, -apvlv-0.1.2-r1.ebuild,
+ -files/apvlv-0.1.2-poppler-0.18.patch:
+ old
17 Mar 2013; Samuli Suominen <ssuominen@gentoo.org> apvlv-0.1.4.ebuild:
amd64/x86 stable
diff --git a/app-text/apvlv/apvlv-0.1.2-r1.ebuild b/app-text/apvlv/apvlv-0.1.2-r1.ebuild
deleted file mode 100644
index d24d62a501f8..000000000000
--- a/app-text/apvlv/apvlv-0.1.2-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/apvlv/apvlv-0.1.2-r1.ebuild,v 1.6 2012/08/08 16:57:17 dilfridge Exp $
-
-EAPI=4
-
-inherit eutils cmake-utils
-
-MY_P="${P}-Source"
-DESCRIPTION="Alf's PDF Viewer Like Vim"
-HOMEPAGE="http://naihe2010.github.com/apvlv/"
-SRC_URI="mirror://github/naihe2010/${PN}/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug djvu"
-
-RDEPEND=">=x11-libs/gtk+-2.10.4:2
- >=app-text/poppler-0.18[cairo,xpdf-headers(+)]
- djvu? ( app-text/djvu )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # bug #349979
- EPATCH_OPTS="-l" epatch \
- "${FILESDIR}"/${PN}-0.1.0-poppler-0.16.patch \
- "${FILESDIR}"/${PN}-0.1.2-poppler-0.18.patch
-
- # Remove prefixes so it works with the cmake-utils eclass
- sed -i -e "s:APVLV_::" CMakeLists.txt src/CMakeLists.txt || die
-
- # Don't install tex file
- sed -i -e "s:Startup.tex::" CMakeLists.txt || die
-}
-
-src_configure() {
- mycmakeargs=(
- -DSYSCONFDIR=/etc/${PN}
- -DDOCDIR=/usr/share/${PN}
- -DMANDIR=/usr/share/man
- -DWITH_UMD=OFF
- $(cmake-utils_use_enable debug)
- $(cmake-utils_use_with djvu)
- )
- cmake-utils_src_configure
-}
-
-src_install() {
- cmake-utils_src_install
- dodoc AUTHORS NEWS README THANKS TODO
- newicon icons/pdf.png ${PN}.png
- make_desktop_entry ${PN} "Alf's PDF Viewer Like Vim" ${PN} "Office;Viewer"
-}
diff --git a/app-text/apvlv/files/apvlv-0.1.0-poppler-0.16.patch b/app-text/apvlv/files/apvlv-0.1.0-poppler-0.16.patch
deleted file mode 100644
index 3c7df684b3fa..000000000000
--- a/app-text/apvlv/files/apvlv-0.1.0-poppler-0.16.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- apvlv-0.1.0-Source/src/ApvlvFile.cpp.orig
-+++ apvlv-0.1.0-Source/src/ApvlvFile.cpp
-@@ -285,7 +285,7 @@
- {
- PopplerRectangle rect = { x1, y1, x2, y2 };
- PopplerPage *page = poppler_document_get_page (mDoc, pn);
-- *out = poppler_page_get_text (page, POPPLER_SELECTION_WORD, &rect);
-+ *out = poppler_page_get_selected_text (page, POPPLER_SELECTION_WORD, &rect);
- if (*out != NULL)
- {
- return true;
diff --git a/app-text/apvlv/files/apvlv-0.1.2-poppler-0.18.patch b/app-text/apvlv/files/apvlv-0.1.2-poppler-0.18.patch
deleted file mode 100644
index 44331aec7bb2..000000000000
--- a/app-text/apvlv/files/apvlv-0.1.2-poppler-0.18.patch
+++ /dev/null
@@ -1,151 +0,0 @@
-http://bugs.gentoo.org/385057
-http://projects.archlinux.org/svntogit/community.git/tree/trunk/poppler-gdk.patch?h=packages/apvlv
-
---- src/ApvlvFile.cpp
-+++ src/ApvlvFile.cpp
-@@ -29,6 +29,10 @@
- #include "ApvlvUtil.hpp"
- #include "ApvlvView.hpp"
-
-+#ifndef POPPLER_WITH_GDK
-+#include "poppler-gdk.h"
-+#endif
-+
- #ifdef HAVE_LIBUMD
- #define LIBUMD_ENABLE_GTK
- #include <umd.h>
---- src/poppler-gdk.h
-+++ src/poppler-gdk.h
-@@ -0,0 +1,132 @@
-+#include <goo/gtypes.h>
-+
-+static void
-+copy_cairo_surface_to_pixbuf (cairo_surface_t *surface,
-+ GdkPixbuf *pixbuf)
-+{
-+ int cairo_width, cairo_height, cairo_rowstride;
-+ unsigned char *pixbuf_data, *dst, *cairo_data;
-+ int pixbuf_rowstride, pixbuf_n_channels;
-+ unsigned int *src;
-+ int x, y;
-+
-+ cairo_width = cairo_image_surface_get_width (surface);
-+ cairo_height = cairo_image_surface_get_height (surface);
-+ cairo_rowstride = cairo_image_surface_get_stride (surface);
-+ cairo_data = cairo_image_surface_get_data (surface);
-+
-+ pixbuf_data = gdk_pixbuf_get_pixels (pixbuf);
-+ pixbuf_rowstride = gdk_pixbuf_get_rowstride (pixbuf);
-+ pixbuf_n_channels = gdk_pixbuf_get_n_channels (pixbuf);
-+
-+ if (cairo_width > gdk_pixbuf_get_width (pixbuf))
-+ cairo_width = gdk_pixbuf_get_width (pixbuf);
-+ if (cairo_height > gdk_pixbuf_get_height (pixbuf))
-+ cairo_height = gdk_pixbuf_get_height (pixbuf);
-+ for (y = 0; y < cairo_height; y++)
-+ {
-+ src = (unsigned int *) (cairo_data + y * cairo_rowstride);
-+ dst = pixbuf_data + y * pixbuf_rowstride;
-+ for (x = 0; x < cairo_width; x++)
-+ {
-+ dst[0] = (*src >> 16) & 0xff;
-+ dst[1] = (*src >> 8) & 0xff;
-+ dst[2] = (*src >> 0) & 0xff;
-+ if (pixbuf_n_channels == 4)
-+ dst[3] = (*src >> 24) & 0xff;
-+ dst += pixbuf_n_channels;
-+ src++;
-+ }
-+ }
-+}
-+
-+static void
-+_poppler_page_render_to_pixbuf (PopplerPage *page,
-+ int src_x, int src_y,
-+ int src_width, int src_height,
-+ double scale,
-+ int rotation,
-+ GBool printing,
-+ GdkPixbuf *pixbuf)
-+{
-+ cairo_t *cr;
-+ cairo_surface_t *surface;
-+
-+ surface = cairo_image_surface_create (CAIRO_FORMAT_ARGB32,
-+ src_width, src_height);
-+ cr = cairo_create (surface);
-+ cairo_save (cr);
-+ switch (rotation) {
-+ case 90:
-+ cairo_translate (cr, src_x + src_width, -src_y);
-+ break;
-+ case 180:
-+ cairo_translate (cr, src_x + src_width, src_y + src_height);
-+ break;
-+ case 270:
-+ cairo_translate (cr, -src_x, src_y + src_height);
-+ break;
-+ default:
-+ cairo_translate (cr, -src_x, -src_y);
-+ }
-+
-+ if (scale != 1.0)
-+ cairo_scale (cr, scale, scale);
-+
-+ if (rotation != 0)
-+ cairo_rotate (cr, rotation * G_PI / 180.0);
-+
-+ if (printing)
-+ poppler_page_render_for_printing (page, cr);
-+ else
-+ poppler_page_render (page, cr);
-+ cairo_restore (cr);
-+
-+ cairo_set_operator (cr, CAIRO_OPERATOR_DEST_OVER);
-+ cairo_set_source_rgb (cr, 1., 1., 1.);
-+ cairo_paint (cr);
-+
-+ cairo_destroy (cr);
-+
-+ copy_cairo_surface_to_pixbuf (surface, pixbuf);
-+ cairo_surface_destroy (surface);
-+}
-+
-+/**
-+ * poppler_page_render_to_pixbuf:
-+ * @page: the page to render from
-+ * @src_x: x coordinate of upper left corner
-+ * @src_y: y coordinate of upper left corner
-+ * @src_width: width of rectangle to render
-+ * @src_height: height of rectangle to render
-+ * @scale: scale specified as pixels per point
-+ * @rotation: rotate the document by the specified degree
-+ * @pixbuf: pixbuf to render into
-+ *
-+ * First scale the document to match the specified pixels per point,
-+ * then render the rectangle given by the upper left corner at
-+ * (src_x, src_y) and src_width and src_height.
-+ * This function is for rendering a page that will be displayed.
-+ * If you want to render a page that will be printed use
-+ * poppler_page_render_to_pixbuf_for_printing() instead
-+ *
-+ * Deprecated: 0.16
-+ **/
-+void
-+poppler_page_render_to_pixbuf (PopplerPage *page,
-+ int src_x, int src_y,
-+ int src_width, int src_height,
-+ double scale,
-+ int rotation,
-+ GdkPixbuf *pixbuf)
-+{
-+ g_return_if_fail (POPPLER_IS_PAGE (page));
-+ g_return_if_fail (scale > 0.0);
-+ g_return_if_fail (pixbuf != NULL);
-+
-+ _poppler_page_render_to_pixbuf (page, src_x, src_y,
-+ src_width, src_height,
-+ scale, rotation,
-+ gFalse,
-+ pixbuf);
-+}