summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-05 22:52:33 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-05 22:52:33 +0000
commitfc95a6c5954df62380884f26815e3826f62407f2 (patch)
treee2aa02d3457ef8f1acbd56ef40a50c643764b923 /app-shells
parentMarked 0.40 stable on x86; removed 0.37. (diff)
downloadgentoo-2-fc95a6c5954df62380884f26815e3826f62407f2.tar.gz
gentoo-2-fc95a6c5954df62380884f26815e3826f62407f2.tar.bz2
gentoo-2-fc95a6c5954df62380884f26815e3826f62407f2.zip
Fix from upstream for pipe code when PGRP_PIPE is enabled #92349 by Harald van Dijk.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash/ChangeLog9
-rw-r--r--app-shells/bash/bash-3.0-r12.ebuild162
-rw-r--r--app-shells/bash/files/bash-3.0-pgrp-pipe-fix.patch20
-rw-r--r--app-shells/bash/files/digest-bash-3.0-r1218
4 files changed, 208 insertions, 1 deletions
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
index aae49de41029..201cb0a6f4c7 100644
--- a/app-shells/bash/ChangeLog
+++ b/app-shells/bash/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.68 2005/06/27 21:54:54 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.69 2005/07/05 22:52:33 vapier Exp $
+
+*bash-3.0-r12 (05 Jul 2005)
+
+ 05 Jul 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/bash-3.0-pgrp-pipe-fix.patch, +bash-3.0-r12.ebuild:
+ Fix from upstream for pipe code when PGRP_PIPE is enabled #92349 by Harald
+ van Dijk.
27 Jun 2005; Aron Griffis <agriffis@gentoo.org>
+files/bash-3.0-parallel.patch, bash-3.0-r11.ebuild:
diff --git a/app-shells/bash/bash-3.0-r12.ebuild b/app-shells/bash/bash-3.0-r12.ebuild
new file mode 100644
index 000000000000..03848ef90eaf
--- /dev/null
+++ b/app-shells/bash/bash-3.0-r12.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.0-r12.ebuild,v 1.1 2005/07/05 22:52:33 vapier Exp $
+
+inherit eutils flag-o-matic toolchain-funcs
+
+# Official patchlevel
+# See ftp://ftp.cwru.edu/pub/bash/bash-3.0-patches/
+PLEVEL=16
+
+DESCRIPTION="The standard GNU Bourne again shell"
+HOMEPAGE="http://cnswww.cns.cwru.edu/~chet/bash/bashtop.html"
+# Hit the GNU mirrors before hitting Chet's site
+SRC_URI="mirror://gnu/bash/${P}.tar.gz
+ ftp://ftp.cwru.edu/pub/bash/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${PV} ${PV/\.} ${i}
+ printf 'mirror://gnu/bash/bash-%s-patches/bash%s-%03d\n' \
+ ${PV} ${PV/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE="nls build bashlogger"
+
+# we link statically with ncurses
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${DISTDIR}"/${P}-gentoo.diff.bz2
+
+ # Remove autoconf dependency
+ sed -i -e "/&& autoconf/d" Makefile.in
+
+ # Include official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${PV/\.}-$(printf '%03d' ${i})
+ done
+
+ # Patch readline's bind.c so that /etc/inputrc is read as a last resort
+ # following ~/.inputrc. This is better than putting INPUTRC in
+ # the environment because INPUTRC will override even after the
+ # user creates a ~/.inputrc
+ epatch "${FILESDIR}"/${P}-etc-inputrc.patch
+ # Fix network tests on Darwin #79124
+ epatch "${FILESDIR}"/${P}-darwin-conn.patch
+ # A bunch of fixes from fedora
+ epatch "${FILESDIR}"/${P}-{afs,crash,jobs,manpage,pwd,read-e-segfault,ulimit}.patch
+ # Fix read-builtin and the -u pipe option #87093
+ epatch "${FILESDIR}"/${P}-read-builtin-pipe.patch
+ # Don't barf on handled signals in scripts
+ epatch "${FILESDIR}"/${P}-trap-fg-signals.patch
+ # Fix a problem when using pipes and PGRP_PIPE #92349
+ epatch "${FILESDIR}"/${P}-pgrp-pipe-fix.patch
+ # Log bash commands to syslog #91327
+ if use bashlogger ; then
+ echo
+ ewarn "The logging patch should ONLY be used in restricted (i.e. honeypot) envs."
+ ewarn "This will log ALL output you enter into the shell, you have been warned."
+ ebeep
+ epause
+ epatch "${FILESDIR}"/${P}-bash-logger.patch
+ fi
+
+ # Enable SSH_SOURCE_BASHRC (#24762)
+ echo '#define SSH_SOURCE_BASHRC' >> config-top.h
+ # Enable system-wide bashrc (#26952)
+ echo '#define SYS_BASHRC "/etc/bash/bashrc"' >> config-top.h
+ # Enable system-wide logout (#90488)
+ echo '#define SYS_BASH_LOGOUT "/etc/bash/bash_logout"' >> config-top.h
+
+ # Force pgrp synchronization
+ # (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81653)
+ #
+ # The session will hang cases where you 'su' (not 'su -') and
+ # then run a piped command in emacs.
+ # This problem seem to happen due to scheduler changes kernel
+ # side - although reproduceble with later 2.4 kernels, it is
+ # especially easy with 2.6 kernels.
+ echo '#define PGRP_PIPE 1' >> config-bot.h
+
+ sed -i 's:-lcurses:-lncurses:' configure || die "sed configure"
+}
+
+src_compile() {
+ filter-flags -malign-double
+
+ local myconf=
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #use readline && myconf="--with-installed-readline"
+
+ # Don't even think about building this statically without
+ # reading Bug 7714 first. If you still build it statically,
+ # don't come crying to use with bugs ;).
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ echo 'int main(){}' > "${T}"/term-test.c
+ if ! $(tc-getCC) -static -lncurses "${T}"/term-test.c 2> /dev/null ; then
+ export bash_cv_termcap_lib=gnutermcap
+ else
+ export bash_cv_termcap_lib=libcurses
+ myconf="${myconf} --with-ncurses"
+ fi
+
+ econf \
+ --disable-profiling \
+ --without-gnu-malloc \
+ ${myconf} || die
+ # Make sure we always link statically with ncurses
+ sed -i "/^TERMCAP_LIB/s:-lncurses:-Wl,-Bstatic -lncurses -Wl,-Bdynamic:" Makefile || die "sed failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv "${D}"/usr/bin/bash "${D}"/bin/
+ [[ ${USERLAND} != "BSD" ]] && dosym bash /bin/sh
+ dosym bash /bin/rbash
+
+ insinto /etc/bash
+ doins "${FILESDIR}"/{bashrc,bash_logout}
+ insinto /etc/skel
+ for f in bash{_logout,_profile,rc} ; do
+ newins "${FILESDIR}"/dot-${f} .${f}
+ done
+
+ if use build ; then
+ rm -rf "${D}"/usr
+ else
+ doman doc/*.1
+ dodoc README NEWS AUTHORS CHANGES COMPAT Y2K doc/FAQ doc/INTRO
+ dosym bash.info.gz /usr/share/info/bashref.info.gz
+ fi
+}
+
+pkg_preinst() {
+ if [[ -e ${ROOT}/etc/bashrc ]] && [[ ! -d ${ROOT}/etc/bash ]] ; then
+ mkdir -p "${ROOT}"/etc/bash
+ mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
+ fi
+
+ # our bash_logout is just a place holder so dont
+ # force users to go through etc-update all the time
+ if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
+ rm -f "${D}"/etc/bash/bash_logout
+ fi
+}
diff --git a/app-shells/bash/files/bash-3.0-pgrp-pipe-fix.patch b/app-shells/bash/files/bash-3.0-pgrp-pipe-fix.patch
new file mode 100644
index 000000000000..35b0b7d05924
--- /dev/null
+++ b/app-shells/bash/files/bash-3.0-pgrp-pipe-fix.patch
@@ -0,0 +1,20 @@
+Fix an error when using pipes and PGRP_PIPE is enabled.
+( exec 3>&1; : `echo >&3` )
+bash: 3: Bad file descriptor
+
+http://bugs.gentoo.org/92349
+
+Patch from upstream
+
+*** jobs.c Wed Sep 8 11:08:16 2004
+--- jobs.c Thu Jun 30 17:21:26 2005
+***************
+*** 3456,3459 ****
+--- 3901,3907 ----
+ stop_making_children ();
+ start_pipeline ();
++ #if defined (PGRP_PIPE)
++ pipe_close (pgrp_pipe);
++ #endif
+ delete_all_jobs (0);
+ set_job_control (0);
diff --git a/app-shells/bash/files/digest-bash-3.0-r12 b/app-shells/bash/files/digest-bash-3.0-r12
new file mode 100644
index 000000000000..3f6ecc696328
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-3.0-r12
@@ -0,0 +1,18 @@
+MD5 26c4d642e29b3533d8d754995bc277b3 bash-3.0.tar.gz 2418293
+MD5 220cdd45dc060fd41c2bd7c46e8a9064 bash-3.0-gentoo.diff.bz2 2423
+MD5 24a83f78a44a6029024371f02da174dd bash30-001 4999
+MD5 6f4cf2aa975a1fcc0cb43a406bd47ca5 bash30-002 2119
+MD5 c8bf41e78cda16d391b9099eeba01386 bash30-003 4669
+MD5 c069dffbb3f442aac3660b883ddd97f5 bash30-004 3372
+MD5 ad06309c623ff8e1b9f039d3b7eb97c2 bash30-005 1776
+MD5 f162bf93a76759bab37b29509a4a6e20 bash30-006 4258
+MD5 89903d92ca620921aecb3f1f30c05ebe bash30-007 1808
+MD5 9a295c02f46bc867fc096862c7380a88 bash30-008 1220
+MD5 786c7e2af1dca5104af92bbdc60f7474 bash30-009 2828
+MD5 f2d90d06ed445a285c8406016e9d9c13 bash30-010 3193
+MD5 9506c56968c58332489986633319a186 bash30-011 2635
+MD5 2753d4de0b57fc8890488463c5e86d3f bash30-012 1395
+MD5 5de5be8289764c11a3206b06351d81a6 bash30-013 1963
+MD5 d4b531e02b6a0287cffdbf527134ca29 bash30-014 1165
+MD5 adc1ab952b42ed0c0f53d1c308a32101 bash30-015 1480
+MD5 a3bb09a185e4c6a813227f3e84e4f6e5 bash30-016 2453