summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2015-02-19 16:00:12 +0000
committerChristoph Junghans <ottxor@gentoo.org>2015-02-19 16:00:12 +0000
commitf13f863024356aa76ff3a82ddd5d2579f3acec3d (patch)
tree6e44eb76cd91758b0b8efb3432451c8551af5b00 /app-shells
parentRemove reference to non-existent upgrade guide, bug #540584. (diff)
downloadgentoo-2-f13f863024356aa76ff3a82ddd5d2579f3acec3d.tar.gz
gentoo-2-f13f863024356aa76ff3a82ddd5d2579f3acec3d.tar.bz2
gentoo-2-f13f863024356aa76ff3a82ddd5d2579f3acec3d.zip
fixed build without examples (bug #540592)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/mpibash/ChangeLog6
-rw-r--r--app-shells/mpibash/mpibash-1.1.ebuild28
-rw-r--r--app-shells/mpibash/mpibash-1.2.ebuild16
-rw-r--r--app-shells/mpibash/mpibash-9999.ebuild16
4 files changed, 21 insertions, 45 deletions
diff --git a/app-shells/mpibash/ChangeLog b/app-shells/mpibash/ChangeLog
index e5c775b5a593..a53902ced73a 100644
--- a/app-shells/mpibash/ChangeLog
+++ b/app-shells/mpibash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-shells/mpibash
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/ChangeLog,v 1.3 2015/02/17 23:21:14 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/ChangeLog,v 1.4 2015/02/19 16:00:12 ottxor Exp $
+
+ 19 Feb 2015; Christoph Junghans <ottxor@gentoo.org> -mpibash-1.1.ebuild,
+ mpibash-1.2.ebuild, mpibash-9999.ebuild:
+ fixed build without examples (bug #540592)
*mpibash-1.2 (17 Feb 2015)
diff --git a/app-shells/mpibash/mpibash-1.1.ebuild b/app-shells/mpibash/mpibash-1.1.ebuild
deleted file mode 100644
index 700b9784ad70..000000000000
--- a/app-shells/mpibash/mpibash-1.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/mpibash-1.1.ebuild,v 1.1 2015/02/13 23:26:09 ottxor Exp $
-
-EAPI=5
-
-DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
-HOMEPAGE="https://github.com/losalamos/MPI-Bash"
-SRC_URI="https://github.com/losalamos/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="examples"
-
-DEPEND="virtual/mpi
- >=app-shells/bash-4.2[plugins]
- sys-cluster/libcircle"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- econf --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
-}
-
-src_install() {
- default
- use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
-}
diff --git a/app-shells/mpibash/mpibash-1.2.ebuild b/app-shells/mpibash/mpibash-1.2.ebuild
index daa43915d129..6122adfc8897 100644
--- a/app-shells/mpibash/mpibash-1.2.ebuild
+++ b/app-shells/mpibash/mpibash-1.2.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/mpibash-1.2.ebuild,v 1.1 2015/02/17 23:21:14 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/mpibash-1.2.ebuild,v 1.2 2015/02/19 16:00:12 ottxor Exp $
EAPI=5
-inherit autotools multilib
+inherit autotools-utils multilib
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="git://github.com/losalamos/MPI-Bash.git http://github.com/losalamos/MPI-Bash.git"
inherit git-r3
KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
else
SRC_URI="https://github.com/losalamos/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
@@ -27,17 +28,16 @@ DEPEND="virtual/mpi
sys-cluster/libcircle"
RDEPEND="${DEPEND}"
-src_prepare() {
- [[ "${PV}" = 9999 ]] && eautoreconf
-}
-
src_configure() {
- econf --with-bashdir="${EPREFIX}"/usr/include/bash-plugins \
+ local myeconfargs=(
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
--with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
+ )
+ autotools-utils_src_configure
}
src_install() {
- default
+ autotools-utils_src_install
sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
}
diff --git a/app-shells/mpibash/mpibash-9999.ebuild b/app-shells/mpibash/mpibash-9999.ebuild
index 56644f654c2d..f2754f59f3ba 100644
--- a/app-shells/mpibash/mpibash-9999.ebuild
+++ b/app-shells/mpibash/mpibash-9999.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/mpibash-9999.ebuild,v 1.1 2015/02/17 23:10:31 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/mpibash/mpibash-9999.ebuild,v 1.2 2015/02/19 16:00:12 ottxor Exp $
EAPI=5
-inherit autotools multilib
+inherit autotools-utils multilib
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="git://github.com/losalamos/MPI-Bash.git http://github.com/losalamos/MPI-Bash.git"
inherit git-r3
KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
else
SRC_URI="https://github.com/losalamos/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
KEYWORDS="~amd64"
@@ -27,17 +28,16 @@ DEPEND="virtual/mpi
sys-cluster/libcircle"
RDEPEND="${DEPEND}"
-src_prepare() {
- [[ "${PV}" = 9999 ]] && eautoreconf
-}
-
src_configure() {
- econf --with-bashdir="${EPREFIX}"/usr/include/bash-plugins \
+ local myeconfargs=(
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
--with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
+ )
+ autotools-utils_src_configure
}
src_install() {
- default
+ autotools-utils_src_install
sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
}