summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-11 20:50:08 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-11 20:50:08 +0000
commiteff0b65944f2af8dd06a2a46284ce2c900f5cf15 (patch)
tree0bfcb129ea519611babe90a3336dca9018c24f63 /app-shells
parentadd ~alpha (diff)
downloadgentoo-2-eff0b65944f2af8dd06a2a46284ce2c900f5cf15.tar.gz
gentoo-2-eff0b65944f2af8dd06a2a46284ce2c900f5cf15.tar.bz2
gentoo-2-eff0b65944f2af8dd06a2a46284ce2c900f5cf15.zip
moved bash from sys-apps to app-shells
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/bash-completion-20021017.ebuild4
-rw-r--r--app-shells/bash-completion/bash-completion-20021221.ebuild4
-rw-r--r--app-shells/bash-completion/bash-completion-20021231.ebuild4
-rw-r--r--app-shells/bash-completion/bash-completion-20030209.ebuild4
-rw-r--r--app-shells/bash/ChangeLog99
-rw-r--r--app-shells/bash/bash-2.05a-r3.ebuild77
-rw-r--r--app-shells/bash/bash-2.05b-r3.ebuild77
-rw-r--r--app-shells/bash/files/config-top.h.diff12
-rw-r--r--app-shells/bash/files/digest-bash-2.05a-r31
-rw-r--r--app-shells/bash/files/digest-bash-2.05b-r35
10 files changed, 279 insertions, 8 deletions
diff --git a/app-shells/bash-completion/bash-completion-20021017.ebuild b/app-shells/bash-completion/bash-completion-20021017.ebuild
index d70d9a86ca35..f89e1296d1c4 100644
--- a/app-shells/bash-completion/bash-completion-20021017.ebuild
+++ b/app-shells/bash-completion/bash-completion-20021017.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021017.ebuild,v 1.5 2003/02/13 09:28:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021017.ebuild,v 1.6 2003/03/11 20:50:08 seemant Exp $
S=${WORKDIR}/${PN/-/_}
@@ -12,7 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
DEPEND="sys-apps/tar sys-apps/bzip2"
-RDEPEND=">=sys-apps/bash-2.05a"
+RDEPEND=">=app-shells/bash-2.05a"
src_install() {
insinto /etc
diff --git a/app-shells/bash-completion/bash-completion-20021221.ebuild b/app-shells/bash-completion/bash-completion-20021221.ebuild
index 58733c33cd0d..31d11d6bbdbf 100644
--- a/app-shells/bash-completion/bash-completion-20021221.ebuild
+++ b/app-shells/bash-completion/bash-completion-20021221.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021221.ebuild,v 1.3 2003/02/13 09:28:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021221.ebuild,v 1.4 2003/03/11 20:50:08 seemant Exp $
S=${WORKDIR}/${PN/-/_}
@@ -12,7 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
DEPEND="sys-apps/tar sys-apps/bzip2"
-RDEPEND=">=sys-apps/bash-2.05a"
+RDEPEND=">=app-shells/bash-2.05a"
src_install() {
insinto /etc
diff --git a/app-shells/bash-completion/bash-completion-20021231.ebuild b/app-shells/bash-completion/bash-completion-20021231.ebuild
index d1c71e3ac97c..94d7fe66d158 100644
--- a/app-shells/bash-completion/bash-completion-20021231.ebuild
+++ b/app-shells/bash-completion/bash-completion-20021231.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021231.ebuild,v 1.2 2003/02/13 09:28:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20021231.ebuild,v 1.3 2003/03/11 20:50:08 seemant Exp $
S=${WORKDIR}/${PN/-/_}
@@ -12,7 +12,7 @@ LICENSE="GPL-2"
SLOT="0"
DEPEND="sys-apps/tar sys-apps/bzip2"
-RDEPEND=">=sys-apps/bash-2.05a"
+RDEPEND=">=app-shells/bash-2.05a"
src_install() {
insinto /etc
diff --git a/app-shells/bash-completion/bash-completion-20030209.ebuild b/app-shells/bash-completion/bash-completion-20030209.ebuild
index e886c13df26f..d4047398bd66 100644
--- a/app-shells/bash-completion/bash-completion-20030209.ebuild
+++ b/app-shells/bash-completion/bash-completion-20030209.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20030209.ebuild,v 1.1 2003/02/17 20:58:12 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20030209.ebuild,v 1.2 2003/03/11 20:50:08 seemant Exp $
S=${WORKDIR}/${PN/-/_}
DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
@@ -14,7 +14,7 @@ KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
DEPEND="sys-apps/tar
sys-apps/bzip2"
-RDEPEND=">=sys-apps/bash-2.05a"
+RDEPEND=">=app-shells/bash-2.05a"
src_install() {
insinto /etc
diff --git a/app-shells/bash/ChangeLog b/app-shells/bash/ChangeLog
new file mode 100644
index 000000000000..487eda434974
--- /dev/null
+++ b/app-shells/bash/ChangeLog
@@ -0,0 +1,99 @@
+# ChangeLog for sys-apps/bash
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/ChangeLog,v 1.1 2003/03/11 20:50:08 seemant Exp $
+
+*bash-2.05a-r3 (11 Mar 2003)
+
+ 11 Mar 2003; Seemant Kulleen <seemant@gentoo.org> bash-2.05a-r3.ebuild,
+ bash-2.05b-r3.ebuild, files/config-top.h.diff:
+ moved to app-shells
+
+ 20 Feb 2003; Zach Welch <zwelch@gentoo.org> bash-2.05b-r3.ebuild :
+ Added arm to keywords.
+
+ 07 Feb 2003; Guy Martin <gmsoft@gentoo.org> bash-2.05b-r3.ebuild :
+ Added hppa to keywords.
+
+ 03 Dec 2002; Martin Schlemmer <azarah@gentoo.org> bash-2.05b-r3.ebuild :
+ Remove autoconf dependency, resolving stage0 -> stage1 breakage, thanks
+ to Daniel Robbins.
+
+*bash-2.05a-r3 (20 Dec 2002)
+
+ 20 Dec 2002; Jan Seidel <tuxus@gentoo.org> bash-2.05a-r3.ebuild :
+ Added mips to keywords
+
+ 17 Dec 2002; Mark Guertin <gerk@gentoo.org> bsh-2.05b-r3.ebuild :
+ Downgraded back to testing, the DEPEND for autoconf breaks the build
+ order for making stage1's (pulls in many unmatchable deps that require
+ g++ to build).
+
+ 10 Dec 2002; Martin Schlemmer <azarah@gentoo.org> bash-2.05b-r3.ebuild :
+
+ Mark stable.
+
+ 06 Dec 2002; Rodney Rees <manson@gentoo.org> :
+
+ Changed sparc ~sparc keywords
+
+*bash-2.05b-r3 (25 Sep 2002)
+
+ 24 Feb 2003; Nicholas Wourms <dragon@gentoo.org> bash-2.05b-r3.ebuild :
+ Marked as stable for mips.
+
+ 18 Jan 2003; Jan Seidel <tuxus@gentoo.org> :
+ Added ~mips to keywords
+
+ 25 Sep 2002; Martin Schlemmer <azarah@gentoo.org> bash-2.05b-r3.ebuild :
+ Added a few patches.
+
+*bash-2.05b-r2 (1 Sep 2002)
+*bash-2.05a-r3 (1 Sep 2002)
+
+ 1 Sep 2002; Seemant Kulleen <seemant@gentoo.org> bash-2.05a-r3 bash-2.05b-r2 :
+
+ ska-fan in #gentoo-dev offered insight into bug #7332 by
+ Jan.Schubert@GMX.li (Jan Schubert). Note that ska-fan is:
+ twanger@bluetwanger.de
+
+ 1 Sep 2002; Martin Schlemmer <azarah@gentoo.org> bash-2.05a-r3 bash-2.05b-r2 :
+ Update to use internal readline. This fixes problems where bash stops
+ working if readline (external) is updated.
+
+*bash-2.05b-r1 (30 Aug 2002)
+
+ 30 Aug 2002; mark Guertin <gerk@gentoo.org> bash-2.05b.ebuild bash-2.05b-r1.ebuild :
+ set -ppc as readline 4.3 (required) breaks system with inplace upgrade
+
+ 30 Aug 2002; Seemant Kulleen <seemant@gentoo.org> bash-2.05b-r1.ebuild
+ files/digest-bash-2.05b-r1 :
+
+ Applied Mandrake's patchset to this, which fixes readline bugs, command
+ completion, gcc-3 compilation. Patchset compiled by Thierry Vignaud of
+ Mandrake (tvignaud@mandrakesoft.com)
+
+ 31 Aug 2002; Bart Verwilst <verwilst@gentoo.org> bash-2.05b-r1.ebuild :
+
+ Added autoconf to DEPEND
+
+*bash-2.05b (23 Jul 2002)
+
+ 23 Jul 2002; Seemant Kulleen <seemant@gentoo.org> bash-2.05b.ebuild :
+
+ Version bump. Thanks to christian-neumair@web.de (Christian - Manny
+ Calavera - Neumair) in bug #5422
+
+*bash-2.05a-r1.ebuild (14 July 2002)
+
+ 14 Jul 2002; phoen][x <phoenix@gentoo.org> bash-2.05a-r1.ebuild :
+ Added KEYWORDS, SLOT.
+
+*bash-2.05a-r2 (09 Apr 2002)
+
+ 14 Jul 2002; phoen][x <phoenix@gentoo.org> bash-2.05a-r2.ebuild :
+ Added KEYWORDS, SLOT.
+
+ 09 Apr 2002; Daniel Robbins <drobbins@gentoo.org> : New bash release that has
+ a patch to allow non-interactive login shells to inherit their environment.
+ This allows your prompt to be preserved after you start X. This closes bug
+ #1579.
diff --git a/app-shells/bash/bash-2.05a-r3.ebuild b/app-shells/bash/bash-2.05a-r3.ebuild
new file mode 100644
index 000000000000..1c84b6caacc9
--- /dev/null
+++ b/app-shells/bash/bash-2.05a-r3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05a-r3.ebuild,v 1.1 2003/03/11 20:50:08 seemant Exp $
+
+inherit flag-o-matic gnuconfig
+
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+KEYWORDS="x86 ppc sparc alpha mips"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls build"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ #enable non-interactive login shells; this patch allows your prompt
+ #to be preserved when you start X and closes bug #1579.
+ cat ${FILESDIR}/config-top.h.diff | patch -p0 -l || die
+ # bash's config.sub doesn't recognize alphaev67. update it.
+ use alpha && gnuconfig_update
+}
+
+src_compile() {
+
+ filter-flags -malign-double
+
+ local myconf=""
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #[ "`use readline`" ] && myconf="--with-installed-readline"
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ [ -z "`use nls`" ] && myconf="${myconf} --disable-nls"
+
+ ./configure --prefix=/ \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ --disable-profiling \
+ --with-curses \
+ --without-gnu-malloc \
+ ${myconf} || die
+ # bash 2.0.5 doesn't like -j>1
+
+ emake -j1 || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+
+ if [ -z "`use build`" ]
+ then
+ doman doc/*.1 doc/*.3
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc doc/FAQ doc/INTRO
+ else
+ rm -rf ${D}/usr
+ fi
+}
+
diff --git a/app-shells/bash/bash-2.05b-r3.ebuild b/app-shells/bash/bash-2.05b-r3.ebuild
new file mode 100644
index 000000000000..bfdb5d8def65
--- /dev/null
+++ b/app-shells/bash/bash-2.05b-r3.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-2.05b-r3.ebuild,v 1.1 2003/03/11 20:50:08 seemant Exp $
+
+inherit eutils flag-o-matic
+
+# Official patches
+PLEVEL="x002 x003 x004"
+
+DESCRIPTION="The standard GNU Bourne again shell"
+SRC_URI="ftp://ftp.gnu.org/gnu/bash/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2
+ ${PLEVEL//x/ftp://ftp.gnu.org/gnu/bash/bash-${PV}-patches/bash${PV/\.}-}"
+HOMEPAGE="http://www.gnu.org/software/bash/bash.html"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc alpha mips hppa arm"
+IUSE="nls build"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ epatch ${DISTDIR}/${P}-gentoo.diff.bz2
+
+ for x in ${PLEVEL//x}
+ do
+ epatch ${DISTDIR}/${PN}${PV/\.}-${x}
+ done
+
+ # Remove autoconf dependency
+ cp Makefile.in Makefile.in.orig
+ sed -e "/&& autoconf/d" Makefile.in.orig > Makefile.in
+}
+
+src_compile() {
+
+ filter-flags -malign-double
+
+ local myconf=""
+
+ # Always use the buildin readline, else if we update readline
+ # bash gets borked as readline is usually not binary compadible
+ # between minor versions.
+ #
+ # Martin Schlemmer <azarah@gentoo.org> (1 Sep 2002)
+ #use readline && myconf="--with-installed-readline"
+ #use static && export LDFLAGS="${LDFLAGS} -static"
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf \
+ --disable-profiling \
+ --with-curses \
+ --without-gnu-malloc \
+ ${myconf} || die
+
+ make || die
+}
+
+src_install() {
+ einstall || die
+
+ dodir /bin
+ mv ${D}/usr/bin/bash ${D}/bin
+ dosym bash /bin/sh
+
+ use build \
+ && rm -rf ${D}/usr \
+ || ( \
+ doman doc/*.1 doc/*.3
+ dodoc README NEWS AUTHORS CHANGES COMPAT COPYING Y2K
+ dodoc doc/FAQ doc/INTRO
+ )
+}
diff --git a/app-shells/bash/files/config-top.h.diff b/app-shells/bash/files/config-top.h.diff
new file mode 100644
index 000000000000..51367b300833
--- /dev/null
+++ b/app-shells/bash/files/config-top.h.diff
@@ -0,0 +1,12 @@
+--- config-top.h.orig 2002-04-06 18:38:23.000000000 +0200
++++ config-top.h 2002-04-06 18:24:18.000000000 +0200
+@@ -56,7 +56,7 @@
+
+ /* Define this to make non-interactive shells begun with argv[0][0] == '-'
+ run the startup files when not in posix mode. */
+-/* #define NON_INTERACTIVE_LOGIN_SHELLS */
++#define NON_INTERACTIVE_LOGIN_SHELLS
+
+ /* Define this if you want bash to try to check whether it's being run by
+ sshd and source the .bashrc if so (like the rshd behavior). */
+
diff --git a/app-shells/bash/files/digest-bash-2.05a-r3 b/app-shells/bash/files/digest-bash-2.05a-r3
new file mode 100644
index 000000000000..5dc9061017e7
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-2.05a-r3
@@ -0,0 +1 @@
+MD5 eeabc3f624861c4a8a687f7701db3d06 bash-2.05a.tar.gz 1807947
diff --git a/app-shells/bash/files/digest-bash-2.05b-r3 b/app-shells/bash/files/digest-bash-2.05b-r3
new file mode 100644
index 000000000000..9e2103210e00
--- /dev/null
+++ b/app-shells/bash/files/digest-bash-2.05b-r3
@@ -0,0 +1,5 @@
+MD5 5238251b4926d778dfe162f6ce729733 bash-2.05b.tar.gz 1956216
+MD5 acac0949285525a5920d80f2aa4668de bash-2.05b-gentoo.diff.bz2 2744
+MD5 2957bbe5f6db1830d649d1071baba63c bash205b-002 755
+MD5 2828e78563927b806246e2b4806ee0f5 bash205b-003 2356
+MD5 6bf89831209ba6d208943d2ebaa7fe3a bash205b-004 1110